summaryrefslogtreecommitdiffstats
path: root/meta-ti-bsp/recipes-bsp/powervr-drivers/ti-img-rogue-driver_23.3.6512818.bb
diff options
context:
space:
mode:
authorRandolph Sapp <rs@ti.com>2024-02-01 10:36:15 -0600
committerRyan Eatmon <reatmon@ti.com>2024-02-07 10:38:35 -0600
commite9ed788e1882ea24c0f349789370e89003c4d019 (patch)
treefabdcab83c976cf4108d16fcb394c0d0035e3f55 /meta-ti-bsp/recipes-bsp/powervr-drivers/ti-img-rogue-driver_23.3.6512818.bb
parent5b29403de4be5fea2cc1fcc34e378a3d12e6e47f (diff)
downloadmeta-ti-e9ed788e1882ea24c0f349789370e89003c4d019.tar.gz
ti-img-rogue-*: version bump to 23.3.6512818
Migrate to version 23.3.6512818, this includes the stability updates released in 23.2 as well as some additional modifications to help with userspace application support, namely Chromium. We're also dropping the x11 window system extensions from the Vulkan libraries for now. Ideally, both x11 and wayland extensions will be provided by mesa's vulkan-wsi-layer in the future, but currently x11 isn't supported and this just added extra complexity to the package in Yocto. Signed-off-by: Randolph Sapp <rs@ti.com> Tested-by: Darren Etheridge <detheridge@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'meta-ti-bsp/recipes-bsp/powervr-drivers/ti-img-rogue-driver_23.3.6512818.bb')
-rw-r--r--meta-ti-bsp/recipes-bsp/powervr-drivers/ti-img-rogue-driver_23.3.6512818.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/meta-ti-bsp/recipes-bsp/powervr-drivers/ti-img-rogue-driver_23.3.6512818.bb b/meta-ti-bsp/recipes-bsp/powervr-drivers/ti-img-rogue-driver_23.3.6512818.bb
new file mode 100644
index 00000000..bc59816a
--- /dev/null
+++ b/meta-ti-bsp/recipes-bsp/powervr-drivers/ti-img-rogue-driver_23.3.6512818.bb
@@ -0,0 +1,42 @@
1DESCRIPTION = "Kernel drivers for the PowerVR Rogue GPU found in the TI SoCs"
2HOMEPAGE = "http://git.ti.com/graphics/ti-img-rogue-driver"
3LICENSE = "MIT | GPL-2.0-only"
4LIC_FILES_CHKSUM = "file://README;beginline=14;endline=19;md5=0403c7dea01a2b8232261e805325fac2"
5
6inherit module
7
8PROVIDES = "virtual/gpudriver"
9
10MACHINE_KERNEL_PR:append = "b"
11PR = "${MACHINE_KERNEL_PR}"
12
13PACKAGE_ARCH = "${MACHINE_ARCH}"
14
15COMPATIBLE_MACHINE = "j721e|j721s2|j784s4|am62xx|am62pxx|j722s"
16
17DEPENDS = "virtual/kernel"
18
19BRANCH = "linuxws/kirkstone/k6.1/${PV}"
20
21SRC_URI = "git://git.ti.com/git/graphics/ti-img-rogue-driver.git;protocol=https;branch=${BRANCH}"
22
23S = "${WORKDIR}/git"
24
25SRCREV = "41a494accb30aa2f247e6a4e123a4954982f2a88"
26
27TARGET_PRODUCT:j721e = "j721e_linux"
28TARGET_PRODUCT:j721s2 = "j721s2_linux"
29TARGET_PRODUCT:j784s4 = "j784s4_linux"
30TARGET_PRODUCT:am62xx = "am62_linux"
31TARGET_PRODUCT:am62pxx = "am62p_linux"
32TARGET_PRODUCT:j722s = "j722s_linux"
33PVR_BUILD = "release"
34PVR_WS = "lws-generic"
35
36EXTRA_OEMAKE += 'KERNELDIR="${STAGING_KERNEL_DIR}" BUILD=${PVR_BUILD} PVR_BUILD_DIR=${TARGET_PRODUCT} WINDOW_SYSTEM=${PVR_WS}'
37
38do_install() {
39 make -C ${STAGING_KERNEL_DIR} M=${B}/binary_${TARGET_PRODUCT}_${PVR_WS}_${PVR_BUILD}/target_aarch64/kbuild INSTALL_MOD_PATH=${D}${root_prefix} PREFIX=${STAGING_DIR_HOST} modules_install
40}
41
42RRECOMMENDS:${PN} += "ti-img-rogue-umlibs"