summaryrefslogtreecommitdiffstats
path: root/meta-ti-bsp/dynamic-layers
diff options
context:
space:
mode:
authorRandolph Sapp <rs@ti.com>2023-08-21 20:11:38 -0500
committerRyan Eatmon <reatmon@ti.com>2023-09-20 17:30:56 -0500
commitdbc6afc46e55b247606dfad5238137c8fa807843 (patch)
treeb4ba588e6dddc4f737a56cdaab8fcd020a9393e6 /meta-ti-bsp/dynamic-layers
parent9bc415f9bba803b1bb500f92e8f8b129fd291d59 (diff)
downloadmeta-ti-dbc6afc46e55b247606dfad5238137c8fa807843.tar.gz
mesa-pvr: add dynamic-layer append for llvmpipe
Meta-clang provides a bbappend for mesa to use clang to accelerate it's rasterization with runtime code generation through the use of llvmpipe. With the addition of mesa-pvr we no longer get this for free with the blanket mesa bbappend on the devices that explicitly request mesa-pvr so lets add a dynamic layer to append the same args meta-clang does. Though the number of devices that would select pvr-mesa and still want to use software rendering is small, it's not zero due to debug and testing purposes. Signed-off-by: Randolph Sapp <rs@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'meta-ti-bsp/dynamic-layers')
-rw-r--r--meta-ti-bsp/dynamic-layers/clang-layer/recipes-graphics/mesa/mesa-pvr_%.bbappend14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta-ti-bsp/dynamic-layers/clang-layer/recipes-graphics/mesa/mesa-pvr_%.bbappend b/meta-ti-bsp/dynamic-layers/clang-layer/recipes-graphics/mesa/mesa-pvr_%.bbappend
new file mode 100644
index 00000000..7e5c36fd
--- /dev/null
+++ b/meta-ti-bsp/dynamic-layers/clang-layer/recipes-graphics/mesa/mesa-pvr_%.bbappend
@@ -0,0 +1,14 @@
1# This is a copy of meta-clang/recipes-graphics/mesa/mesa_%.bbappend required
2# for llvmpipe when using pvr-mesa since we aren't caught by that glob.
3
4FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
5
6LDFLAGS:append:toolchain-clang = " -latomic -lm"
7DEPENDS:append:toolchain-clang = " libatomic-ops"
8
9EXTRA_OEMASON:append:toolchain-clang:x86 = " -Dasm=false"
10EXTRA_OEMASON:append:toolchain-clang:x86-64 = " -Dasm=false"
11
12export YOCTO_ALTERNATE_EXE_PATH = "${STAGING_LIBDIR}/llvm-config"
13
14PACKAGECONFIG[gallium-llvm] = "-Dllvm=true -Dshared-llvm=true -Ddraw-use-llvm=true,-Dllvm=false,clang clang-native elfutils"