summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Davis <afd@ti.com>2023-10-20 09:28:59 -0500
committerRyan Eatmon <reatmon@ti.com>2023-10-20 17:27:03 -0500
commitfc51c79233d85f83f8774ab8decd4836586e335f (patch)
treed34278f2220894b58c3c89ced1e48c341ac67d30
parentfe75c0410d6848317e908b0546868bc741af0c42 (diff)
downloadmeta-ti-fc51c79233d85f83f8774ab8decd4836586e335f.tar.gz
ti-pru-sw-edma-driver: Remove this recipe
Not used and the source is gone anyway, remove. Signed-off-by: Andrew Davis <afd@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r--meta-ti-extras/recipes-bsp/pru/ti-pru-sw-edma-driver_1.00.00.bb31
1 files changed, 0 insertions, 31 deletions
diff --git a/meta-ti-extras/recipes-bsp/pru/ti-pru-sw-edma-driver_1.00.00.bb b/meta-ti-extras/recipes-bsp/pru/ti-pru-sw-edma-driver_1.00.00.bb
deleted file mode 100644
index 449a9095..00000000
--- a/meta-ti-extras/recipes-bsp/pru/ti-pru-sw-edma-driver_1.00.00.bb
+++ /dev/null
@@ -1,31 +0,0 @@
1DESCRIPTION = "Builds eDMA module used by eDMA libraries for PRU sw example applications"
2HOMEPAGE = "https://gforge.ti.com/gf/project/pru_sw/"
3LICENSE = "GPL-2.0-only"
4LIC_FILES_CHKSUM = "file://edmautils.c;beginline=1;endline=23;md5=312e9cb8a37a044c617c98a9e980ad1b"
5
6COMPATIBLE_MACHINE = "omapl138"
7
8INHIBIT_PACKAGE_STRIP = "1"
9
10MACHINE_KERNEL_PR:append = "b"
11PR = "${MACHINE_KERNEL_PR}"
12PV:append = "+svn${SRCPV}"
13
14SRC_URI = "svn://gforge.ti.com/svn/pru_sw/;module=trunk;protocol=https;user=anonymous;pswd=''"
15
16SRCREV = "33"
17
18S = "${WORKDIR}/trunk/peripheral_lib/edma_driver/module"
19
20inherit module
21
22EXTRA_OEMAKE += "KERNEL_DIR='${STAGING_KERNEL_DIR}'"
23
24do_compile:prepend () {
25 export CCTOOL_PREFIX="${TOOLCHAIN_PATH}/bin/${TARGET_PREFIX}"
26}
27
28do_install () {
29 install -d ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/pru
30 install -m 0755 ${S}/edmautils.ko ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/pru/
31}