summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGowtham Tammana <g-tammana@ti.com>2016-08-23 00:14:59 +0000
committerDenys Dmytriyenko <denys@ti.com>2016-08-23 14:40:05 -0400
commitf807c7185321fb407e82c529ddff310dc037f727 (patch)
treea2feec0cead9857b359a1c3cd46c94a20eb35afa
parentec487fccaa028c31583b6c51f5fdc317707b0225 (diff)
downloadmeta-ti-f807c7185321fb407e82c529ddff310dc037f727.tar.gz
ti-gc320-libs: add recipe for gc320 user lib
Userspace libraries for GC320 chipset on TI SoCs Signed-off-by: Gowtham Tammana <g-tammana@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-graphics/libgal/ti-gc320-libs_5.0.11.p7.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/recipes-graphics/libgal/ti-gc320-libs_5.0.11.p7.bb b/recipes-graphics/libgal/ti-gc320-libs_5.0.11.p7.bb
new file mode 100644
index 00000000..45c8d519
--- /dev/null
+++ b/recipes-graphics/libgal/ti-gc320-libs_5.0.11.p7.bb
@@ -0,0 +1,39 @@
1DESCRIPTION = "Userspace libraries for GC320 chipset on TI SoCs"
2HOMEPAGE = "https://git.ti.com/graphics/ti-gc320-libs"
3LICENSE = "TI-TSPA"
4LIC_FILES_CHKSUM = "file://Manifest.html;md5=4d759c4e533af6aaeff2af7f405697c2"
5
6PACKAGE_ARCH = "${MACHINE_ARCH}"
7
8CLEANBROKEN = "1"
9
10BRANCH = "ti-${PV}"
11
12SRC_URI = "git://git.ti.com/graphics/ti-gc320-libs.git;protocol=git;branch=${BRANCH}"
13SRCREV = "ab0ca5bff345f6c13807fea3c4acabf5f2b9b10a"
14
15# There's only hardfp version available
16python __anonymous() {
17 tunes = bb.data.getVar("TUNE_FEATURES", d, 1)
18 if not tunes:
19 return
20 pkgn = bb.data.getVar("PN", d, 1)
21 pkgv = bb.data.getVar("PV", d, 1)
22 if "callconvention-hard" not in tunes:
23 bb.warn("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv))
24 raise bb.parse.SkipPackage("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv))
25}
26
27TARGET_PRODUCT_omap-a15 = "jacinto6evm"
28
29PR = "r1"
30
31S = "${WORKDIR}/git"
32
33EXTRA_OEMAKE += "DESTDIR=${D} TARGET_PRODUCT=${TARGET_PRODUCT} LIBDIR=${libdir}"
34
35do_install() {
36 oe_runmake install
37}
38
39INSANE_SKIP_${PN} += "ldflags"