summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2016-05-09 22:40:18 +0000
committerDenys Dmytriyenko <denys@ti.com>2016-05-09 12:50:28 -0400
commitf7c550cdfb6bb5079b34059c5ea44bfedc3c2474 (patch)
tree1ec394dcccaf6ea226b992f357808914d895a08c
parent9b6527720cf43d2042cdc93b91d0f8f04cc02da7 (diff)
downloadmeta-ti-f7c550cdfb6bb5079b34059c5ea44bfedc3c2474.tar.gz
prueth-fw: add FW images for am335x
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-bsp/prueth-fw/prueth-fw_git.bb10
1 files changed, 6 insertions, 4 deletions
diff --git a/recipes-bsp/prueth-fw/prueth-fw_git.bb b/recipes-bsp/prueth-fw/prueth-fw_git.bb
index e4970aa1..234fba5e 100644
--- a/recipes-bsp/prueth-fw/prueth-fw_git.bb
+++ b/recipes-bsp/prueth-fw/prueth-fw_git.bb
@@ -1,20 +1,21 @@
1DESCRIPTION = "PRU Ethernet firmware for AM57xx and AM437x" 1DESCRIPTION = "PRU Ethernet firmware for AM57xx, AM437x and AM335x"
2 2
3LICENSE = "TI-TFL" 3LICENSE = "TI-TFL"
4LIC_FILES_CHKSUM = "file://LICENSE.ti;md5=b5aebf0668bdf95621259288c4a46d76" 4LIC_FILES_CHKSUM = "file://LICENSE.ti;md5=b5aebf0668bdf95621259288c4a46d76"
5 5
6PV_am57xx-evm = "1.0.0" 6PV_am57xx-evm = "1.0.0"
7PV_am437x-evm = "2.1.2" 7PV_am437x-evm = "2.1.2"
8PV_am335x-evm = "2.1.2"
8 9
9PR = "r1" 10PR = "r2"
10 11
11CLEANBROKEN = "1" 12CLEANBROKEN = "1"
12 13
13COMPATIBLE_MACHINE = "am57xx-evm|am437x-evm" 14COMPATIBLE_MACHINE = "am57xx-evm|am437x-evm|am335x-evm"
14 15
15PACKAGE_ARCH = "${MACHINE_ARCH}" 16PACKAGE_ARCH = "${MACHINE_ARCH}"
16 17
17SRCREV = "f6c712fd26044d90939ff774f07dfcb951bcefc9" 18SRCREV = "4096bf1129c4a707069e685edd44ca64bd51421d"
18BRANCH ?= "ti-linux-firmware-4.1.y" 19BRANCH ?= "ti-linux-firmware-4.1.y"
19 20
20SRC_URI = "git://git.ti.com/processor-firmware/ti-linux-firmware.git;protocol=git;branch=${BRANCH}" 21SRC_URI = "git://git.ti.com/processor-firmware/ti-linux-firmware.git;protocol=git;branch=${BRANCH}"
@@ -23,6 +24,7 @@ S = "${WORKDIR}/git"
23 24
24TARGET_am57xx-evm = "am57xx-pru0-prueth-fw.elf am57xx-pru1-prueth-fw.elf" 25TARGET_am57xx-evm = "am57xx-pru0-prueth-fw.elf am57xx-pru1-prueth-fw.elf"
25TARGET_am437x-evm = "am437x-pru0-prueth-fw.elf am437x-pru1-prueth-fw.elf" 26TARGET_am437x-evm = "am437x-pru0-prueth-fw.elf am437x-pru1-prueth-fw.elf"
27TARGET_am335x-evm = "am335x-pru0-prueth-fw.elf am335x-pru1-prueth-fw.elf"
26 28
27do_install() { 29do_install() {
28 install -d ${D}${base_libdir}/firmware/ti-pruss 30 install -d ${D}${base_libdir}/firmware/ti-pruss