summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2018-07-27 03:25:29 +0000
committerDenys Dmytriyenko <denys@ti.com>2018-07-26 23:01:40 +0000
commitf708e4686fb0d3c7e5aedf5e6b66dbae15d23c5b (patch)
tree164410df655653c019886aa328e29846751cc144
parentf9e8966a355f4abfb27375f61ae8f9998ac267ab (diff)
downloadmeta-ti-f708e4686fb0d3c7e5aedf5e6b66dbae15d23c5b.tar.gz
u-boot-ti: don't override do_compile, pass PACKAGECONFIG_CONFARGS to EXTRA_OEMAKE
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-bsp/u-boot/u-boot-ti.inc21
1 files changed, 2 insertions, 19 deletions
diff --git a/recipes-bsp/u-boot/u-boot-ti.inc b/recipes-bsp/u-boot/u-boot-ti.inc
index 4fd3529c..61bf990d 100644
--- a/recipes-bsp/u-boot/u-boot-ti.inc
+++ b/recipes-bsp/u-boot/u-boot-ti.inc
@@ -35,6 +35,8 @@ PACKAGECONFIG[optee] = "TEE=${STAGING_DIR_HOST}/boot/bl32.bin,,optee-os"
35# optee-os is not a direct dependency, do not enable optee by default 35# optee-os is not a direct dependency, do not enable optee by default
36PACKAGECONFIG_append_k3 = " atf" 36PACKAGECONFIG_append_k3 = " atf"
37 37
38EXTRA_OEMAKE += "${PACKAGECONFIG_CONFARGS}"
39
38PROVIDES += "u-boot" 40PROVIDES += "u-boot"
39PKG_${PN} = "u-boot" 41PKG_${PN} = "u-boot"
40PKG_${PN}-dev = "u-boot-dev" 42PKG_${PN}-dev = "u-boot-dev"
@@ -107,25 +109,6 @@ UBOOT_HS_2ND_BINARY = "u-boot-spl_HS_2ND"
107UBOOT_HS_2ND_IMAGE = "u-boot-spl_HS_2ND-${MACHINE}-${PV}-${PR}" 109UBOOT_HS_2ND_IMAGE = "u-boot-spl_HS_2ND-${MACHINE}-${PV}-${PR}"
108UBOOT_HS_2ND_SYMLINK = "u-boot-spl_HS_2ND-${MACHINE}" 110UBOOT_HS_2ND_SYMLINK = "u-boot-spl_HS_2ND-${MACHINE}"
109 111
110do_compile_k3 () {
111 if [ "${@bb.utils.filter('DISTRO_FEATURES', 'ld-is-gold', d)}" ]; then
112 sed -i 's/$(CROSS_COMPILE)ld$/$(CROSS_COMPILE)ld.bfd/g' ${S}/config.mk
113 fi
114
115 unset LDFLAGS
116 unset CFLAGS
117 unset CPPFLAGS
118
119 if [ ! -e ${B}/.scmversion -a ! -e ${S}/.scmversion ]
120 then
121 echo ${UBOOT_LOCALVERSION} > ${B}/.scmversion
122 echo ${UBOOT_LOCALVERSION} > ${S}/.scmversion
123 fi
124
125 oe_runmake -C ${S} O=${B} ${UBOOT_MACHINE}
126 oe_runmake -C ${S} O=${B} ${PACKAGECONFIG_CONFARGS} ${UBOOT_MAKE_TARGET}
127}
128
129do_install_append () { 112do_install_append () {
130 if [ -n "${UBOOT_CONFIG}" ] 113 if [ -n "${UBOOT_CONFIG}" ]
131 then 114 then