summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2015-05-14 03:21:59 +0000
committerDenys Dmytriyenko <denys@ti.com>2015-05-13 17:43:39 -0400
commiteeb5d555f27837fab7fcc0572212643db8923ce2 (patch)
tree2af2564d90fed1ab82d77909a9f807b71219a581
parent5899523f97ea91e84f6b38356c0acf9b96453f9b (diff)
downloadmeta-ti-eeb5d555f27837fab7fcc0572212643db8923ce2.tar.gz
boot-monitor: pass custom LD var that includes sysroot option
Otherwise it fails to link against static libgcc with OE toolchain. Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-bsp/boot-monitor/boot-monitor_git.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes-bsp/boot-monitor/boot-monitor_git.bb b/recipes-bsp/boot-monitor/boot-monitor_git.bb
index 8273ce8b..72dc9241 100644
--- a/recipes-bsp/boot-monitor/boot-monitor_git.bb
+++ b/recipes-bsp/boot-monitor/boot-monitor_git.bb
@@ -7,7 +7,7 @@ COMPATIBLE_MACHINE = "keystone"
7SRC_URI = "git://git.ti.com/keystone-linux/boot-monitor.git;protocol=git;branch=${BRANCH}" 7SRC_URI = "git://git.ti.com/keystone-linux/boot-monitor.git;protocol=git;branch=${BRANCH}"
8 8
9PV = "2.0" 9PV = "2.0"
10PR = "r1+gitr${SRCPV}" 10PR = "r2+gitr${SRCPV}"
11 11
12BRANCH = "master" 12BRANCH = "master"
13 13
@@ -21,7 +21,7 @@ BOOT_MONITOR_IMAGE ?= "skern-${MACHINE}.bin"
21 21
22FLOATABI = "${@base_contains("TUNE_FEATURES", "vfp", base_contains("TUNE_FEATURES", "callconvention-hard", " -mfloat-abi=hard", " -mfloat-abi=softfp", d), "" ,d)}" 22FLOATABI = "${@base_contains("TUNE_FEATURES", "vfp", base_contains("TUNE_FEATURES", "callconvention-hard", " -mfloat-abi=hard", " -mfloat-abi=softfp", d), "" ,d)}"
23 23
24EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX} CC="${TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS} ${FLOATABI}"" 24EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX} CC="${TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS} ${FLOATABI}" LD="${TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS} ${FLOATABI}""
25 25
26do_compile () { 26do_compile () {
27 unset LDFLAGS 27 unset LDFLAGS