summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSuman Anna <s-anna@ti.com>2020-10-22 06:56:14 +0000
committerDan Murphy <dmurphy@ti.com>2020-10-22 11:27:19 -0500
commite4403ea5377d1030594cf946a5b92fe4ee06f859 (patch)
tree48bec63cf42a29fc39e01d7b5b47c6b552c12506
parent2efa25e5ef35dd1c9b12d1394d1866b26cc483ca (diff)
downloadmeta-ti-e4403ea5377d1030594cf946a5b92fe4ee06f859.tar.gz
ipc: ti-rpmsg-char: Add initial recipes
Add the initial recipes for building the ti-rpmsg-char package. The library and examples are built using two separate recipes in ti-rpmsg-char_git.bb and ti-rpmsg-char-examples_git.bb. Signed-off-by: Suman Anna <s-anna@ti.com> Signed-off-by: Gowtham Tammana <g-tammana@ti.com> Signed-off-by: Dan Murphy <dmurphy@ti.com>
-rw-r--r--recipes-ti/ipc/ti-rpmsg-char-examples_git.bb11
-rw-r--r--recipes-ti/ipc/ti-rpmsg-char.inc15
-rw-r--r--recipes-ti/ipc/ti-rpmsg-char_git.bb7
3 files changed, 33 insertions, 0 deletions
diff --git a/recipes-ti/ipc/ti-rpmsg-char-examples_git.bb b/recipes-ti/ipc/ti-rpmsg-char-examples_git.bb
new file mode 100644
index 00000000..142e5bf0
--- /dev/null
+++ b/recipes-ti/ipc/ti-rpmsg-char-examples_git.bb
@@ -0,0 +1,11 @@
1SUMMARY = "TI RPMsg Char Sample Applications and Tests"
2
3require ti-rpmsg-char.inc
4
5DEPENDS = "ti-rpmsg-char"
6
7inherit autotools pkgconfig
8
9EXTRA_OEMAKE = "-C ${B}/examples"
10
11PR = "r0"
diff --git a/recipes-ti/ipc/ti-rpmsg-char.inc b/recipes-ti/ipc/ti-rpmsg-char.inc
new file mode 100644
index 00000000..b41e68eb
--- /dev/null
+++ b/recipes-ti/ipc/ti-rpmsg-char.inc
@@ -0,0 +1,15 @@
1SUMMARY = "TI RPMsg Char Utility Library"
2
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://${S}/src/rpmsg_char.c;beginline=1;endline=31;md5=71987db43a2159cff5ea00505c6fce58"
5
6PROTOCOL = "git"
7BRANCH = "master"
8SRC_URI = "git://git.ti.com/rpmsg/ti-rpmsg-char.git;protocol=${PROTOCOL};branch=${BRANCH};"
9
10# Initial 0.1.0 release
11SRCREV = "9be402c2bf4053900b6b9a8092fbb42e7e303108"
12
13PV = "0.1.0+git${SRCPV}"
14
15S = "${WORKDIR}/git"
diff --git a/recipes-ti/ipc/ti-rpmsg-char_git.bb b/recipes-ti/ipc/ti-rpmsg-char_git.bb
new file mode 100644
index 00000000..63711a3b
--- /dev/null
+++ b/recipes-ti/ipc/ti-rpmsg-char_git.bb
@@ -0,0 +1,7 @@
1SUMMARY = "TI RPMsg Char Utility Library"
2
3require ti-rpmsg-char.inc
4
5inherit autotools pkgconfig
6
7PR = "r0"