diff options
author | Gou, Hongmei <h-gou@ti.com> | 2015-10-28 20:52:12 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2015-10-28 16:06:11 -0400 |
commit | c96067711695a7327ad362eb82af0625002a6a55 (patch) | |
tree | 81b0b87915295fcfd98ea0f4d85ce1c2465e65fe | |
parent | 667b451588a9ea2533d63745c81e91071c49ed36 (diff) | |
download | meta-ti-c96067711695a7327ad362eb82af0625002a6a55.tar.gz |
ipumm-fw: update recipe to build ipumm-fw from git source
Signed-off-by: Hongmei Gou <h-gou@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r-- | recipes-bsp/ipumm-fw/ipumm-fw_3.00.09.01.bb | 35 | ||||
-rw-r--r-- | recipes-bsp/ipumm-fw/ipumm-fw_git.bb | 62 |
2 files changed, 62 insertions, 35 deletions
diff --git a/recipes-bsp/ipumm-fw/ipumm-fw_3.00.09.01.bb b/recipes-bsp/ipumm-fw/ipumm-fw_3.00.09.01.bb deleted file mode 100644 index f537179c..00000000 --- a/recipes-bsp/ipumm-fw/ipumm-fw_3.00.09.01.bb +++ /dev/null | |||
@@ -1,35 +0,0 @@ | |||
1 | python __anonymous() { | ||
2 | features = bb.data.getVar("MACHINE_FEATURES", d, 1) | ||
3 | if not features: | ||
4 | return | ||
5 | if "mmip" not in features: | ||
6 | raise bb.parse.SkipPackage('ipumm-fw does not apply to systems without the "mmip" flag in MACHINE_FEATURES') | ||
7 | } | ||
8 | |||
9 | DESCRIPTION = "Firmware for IPU for supporting Accelerated MM decode and encode" | ||
10 | LICENSE = "TI-TSPA" | ||
11 | |||
12 | LIC_FILES_CHKSUM = "file://MMIP-${PV}-Manifest.doc;md5=5803e271087f74d03239d868bebcc2c7" | ||
13 | |||
14 | COMPATIBLE_MACHINE = "dra7xx" | ||
15 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
16 | |||
17 | RDEPENDS_${PN} = " libdce" | ||
18 | |||
19 | SRC_URI = "http://downloads.ti.com/infotainment/esd/jacinto6/glsdk/ipumm/3_00_09_01/exports/ipumm-dra7xx-evm-${PV}.tar.gz;protocol=http" | ||
20 | |||
21 | SRC_URI[md5sum] = "bf15624e26bdef4dbb67b98ccd8b9754" | ||
22 | SRC_URI[sha256sum] = "e70a38b62e3e4d11d5ce68f0980de4df5256bd597068f179e220fa5afcd065fe" | ||
23 | |||
24 | S = "${WORKDIR}/ipumm-dra7xx-evm-${PV}" | ||
25 | |||
26 | TARGET = "dra7-ipu2-fw.xem4" | ||
27 | |||
28 | do_install() { | ||
29 | mkdir -p ${D}${base_libdir}/firmware | ||
30 | cp ${S}/firmware/${TARGET} ${D}${base_libdir}/firmware/${TARGET} | ||
31 | } | ||
32 | |||
33 | FILES_${PN} += "${base_libdir}/firmware/${TARGET}" | ||
34 | |||
35 | PR = "r0" | ||
diff --git a/recipes-bsp/ipumm-fw/ipumm-fw_git.bb b/recipes-bsp/ipumm-fw/ipumm-fw_git.bb new file mode 100644 index 00000000..af53c3c2 --- /dev/null +++ b/recipes-bsp/ipumm-fw/ipumm-fw_git.bb | |||
@@ -0,0 +1,62 @@ | |||
1 | python __anonymous() { | ||
2 | features = bb.data.getVar("MACHINE_FEATURES", d, 1) | ||
3 | if not features: | ||
4 | return | ||
5 | if "mmip" not in features: | ||
6 | raise bb.parse.SkipPackage('ipumm-fw does not apply to systems without the "mmip" flag in MACHINE_FEATURES') | ||
7 | } | ||
8 | |||
9 | DESCRIPTION = "Firmware for IPU for supporting Accelerated MM decode and encode" | ||
10 | LICENSE = "TI-TSPA" | ||
11 | |||
12 | LIC_FILES_CHKSUM = "file://Texas_Instruments_ipumm_Manifest.pdf;md5=036f6300761559fbc5ce7d06e1ccea5a" | ||
13 | |||
14 | COMPATIBLE_MACHINE = "dra7xx" | ||
15 | |||
16 | RDEPENDS_${PN} = " libdce" | ||
17 | |||
18 | SRC_URI = "git://git.ti.com/ivimm/ipumm.git;protocol=git" | ||
19 | |||
20 | SRCREV = "7f15373c21a9a98b8881d81c3681c09e858a9d2c" | ||
21 | |||
22 | S = "${WORKDIR}/git" | ||
23 | |||
24 | PV = "3.00.09.01" | ||
25 | |||
26 | require recipes-ti/includes/ti-paths.inc | ||
27 | require recipes-ti/includes/ti-staging.inc | ||
28 | |||
29 | DEPENDS = "ti-xdctools ti-sysbios ti-codec-engine ti-framework-components ti-xdais ti-ccsv6-native ti-ipc-rtos" | ||
30 | |||
31 | export HWVERSION="ES10" | ||
32 | export BIOSTOOLSROOT="${STAGING_DIR_TARGET}/usr/share/ti" | ||
33 | |||
34 | export XDCVERSION="ti-xdctools-tree" | ||
35 | export BIOSVERSION="ti-sysbios-tree" | ||
36 | export IPCVERSION="ti-ipc-tree" | ||
37 | export CEVERSION="ti-codec-engine-tree" | ||
38 | export FCVERSION="ti-framework-components-tree" | ||
39 | export XDAISVERSION="ti-xdais-tree" | ||
40 | |||
41 | export TMS470CGTOOLPATH="${M4_TOOLCHAIN_INSTALL_DIR}" | ||
42 | export IPCSRC="${STAGING_DIR_TARGET}/usr/share/ti/ti-ipc-tree" | ||
43 | |||
44 | do_configure() { | ||
45 | oe_runmake unconfig | ||
46 | oe_runmake vayu_smp_config | ||
47 | } | ||
48 | |||
49 | do_compile() { | ||
50 | oe_runmake | ||
51 | } | ||
52 | |||
53 | TARGET = "dra7-ipu2-fw.xem4" | ||
54 | |||
55 | do_install() { | ||
56 | mkdir -p ${D}${base_libdir}/firmware | ||
57 | cp ${S}/${TARGET} ${D}${base_libdir}/firmware/${TARGET} | ||
58 | } | ||
59 | |||
60 | FILES_${PN} += "${base_libdir}/firmware/${TARGET}" | ||
61 | |||
62 | PR = "r1" | ||