summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSam Nelson <sam.nelson@ti.com>2014-10-07 17:36:44 +0000
committerDenys Dmytriyenko <denys@ti.com>2014-10-07 15:23:37 -0400
commitc8f0bf96559005b606a0283b8d305ccb60fe4df6 (patch)
tree5ad597a97d218ea23b798722887ee7c1b5e70a73
parent6c4d8ab62bacd54006605c1e6baca58d0fb82dd2 (diff)
downloadmeta-ti-c8f0bf96559005b606a0283b8d305ccb60fe4df6.tar.gz
common-csl-ip: (ti-csl) Moved from meta-arago and renamed
- Moved from meta-arago (where it was called ti-csl_git.bb) http://arago-project.org/git/?p=meta-arago.git;a=blob_plain;f=meta-arago-extras/recipes-bsp/ti-csl/ti-csl_git.bb;hb=HEAD - Renamed it to common-csl-ip_git.bb - This package provides chip support library interface files Signed-off-by: Sam Nelson <sam.nelson@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-bsp/common-csl-ip/common-csl-ip_git.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes-bsp/common-csl-ip/common-csl-ip_git.bb b/recipes-bsp/common-csl-ip/common-csl-ip_git.bb
new file mode 100644
index 00000000..fb5e6f84
--- /dev/null
+++ b/recipes-bsp/common-csl-ip/common-csl-ip_git.bb
@@ -0,0 +1,21 @@
1DESCRIPTION = "TI CSL"
2LICENSE = "TI BSD"
3LIC_FILES_CHKSUM = "file://COPYING.txt;md5=5857833e20836213677fac33f9aded21"
4
5COMPATIBLE_MACHINE = "keystone"
6ALLOW_EMPTY_${PN} = "1"
7
8PR = "r0"
9BRANCH="master"
10SRC_URI = "git://git.ti.com/keystone-rtos/common-csl-ip.git;protocol=git;branch=${BRANCH}"
11# commit ID corresponds to DEV.CSL_KEYSTONE2.02.00.00.17
12SRCREV = "f6f90144c14e1ee783c4b893b52e54830be8166e"
13
14S = "${WORKDIR}/git"
15
16do_install () {
17 install -d ${D}${includedir}/ti/csl
18 find . -name "*.h" -type f | xargs -I {} cp --parents {} ${D}${includedir}/ti/csl
19 find ./src/ip/serdes_sb/V0 -name "*.c" -type f | xargs -I {} cp --parents {} ${D}${includedir}/ti/csl
20}
21