summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSam Nelson <sam.nelson@ti.com>2018-08-24 23:46:53 +0000
committerDenys Dmytriyenko <denys@ti.com>2018-08-24 20:22:19 +0000
commitb38fd8247aff79db054b455ee38467c1ec89842e (patch)
tree198add05bad9d02c30dd8b27c6b60dcf256f1e72
parent5b3ec3236e0710a83d8f3530c502e25c26676cbe (diff)
downloadmeta-ti-b38fd8247aff79db054b455ee38467c1ec89842e.tar.gz
ti-ipc: Update to new version 3.50.01.01
-Updates to use sciclient for configuring interrupt routing in SOC Signed-off-by: Sam Nelson <sam.nelson@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-ti/ipc/ti-ipc-common.inc2
-rw-r--r--recipes-ti/ipc/ti-ipc-examples_git.bb2
-rw-r--r--recipes-ti/ipc/ti-ipc-rtos.inc12
-rw-r--r--recipes-ti/ipc/ti-ipc-rtos_git.bb1
-rw-r--r--recipes-ti/ipc/ti-ipc.inc4
5 files changed, 14 insertions, 7 deletions
diff --git a/recipes-ti/ipc/ti-ipc-common.inc b/recipes-ti/ipc/ti-ipc-common.inc
index 6aea8e64..543990a7 100644
--- a/recipes-ti/ipc/ti-ipc-common.inc
+++ b/recipes-ti/ipc/ti-ipc-common.inc
@@ -1,4 +1,4 @@
1PV = "3.50.01.00" 1PV = "3.50.01.01"
2INC_PR = "r0" 2INC_PR = "r0"
3 3
4PACKAGE_ARCH = "${MACHINE_ARCH}" 4PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/recipes-ti/ipc/ti-ipc-examples_git.bb b/recipes-ti/ipc/ti-ipc-examples_git.bb
index c46e5c81..d8733aeb 100644
--- a/recipes-ti/ipc/ti-ipc-examples_git.bb
+++ b/recipes-ti/ipc/ti-ipc-examples_git.bb
@@ -3,6 +3,8 @@ require ti-ipc-examples.inc
3 3
4DEPENDS = "ti-ipc ti-xdctools-native ti-sysbios ti-ipc-rtos zip-native" 4DEPENDS = "ti-ipc ti-xdctools-native ti-sysbios ti-ipc-rtos zip-native"
5 5
6DEPENDS_append_am65xx-evm = " sciclient-rtos"
7
6do_compile_append() { 8do_compile_append() {
7 9
8 if [ "${PLATFORM}" != "UNKNOWN" ]; then 10 if [ "${PLATFORM}" != "UNKNOWN" ]; then
diff --git a/recipes-ti/ipc/ti-ipc-rtos.inc b/recipes-ti/ipc/ti-ipc-rtos.inc
index 13b19146..4b2d7d7e 100644
--- a/recipes-ti/ipc/ti-ipc-rtos.inc
+++ b/recipes-ti/ipc/ti-ipc-rtos.inc
@@ -24,11 +24,13 @@ protocol=${TI_IPC_METADATA_GIT_PROTOCOL};\
24branch=${TI_IPC_METADATA_GIT_BRANCH};\ 24branch=${TI_IPC_METADATA_GIT_BRANCH};\
25name=${TI_IPC_METADATA_NAME}" 25name=${TI_IPC_METADATA_NAME}"
26 26
27# Corresponds to tag: 3.50.01.00 27# Corresponds to tag: 3.50.01.01
28SRCREV_ipc-metadata = "19a8e70cf6ca4fe0984987e25d937c61a62c7658" 28TI_IPC_METADATA_SRCREV = "c749d4dd70cc259679dc862a164ad147d51381f6"
29# Corresponds to tag: 3.50.01.01
30TI_IPC_EXAMPLES_SRCREV = "71f6e59a6b2c7e20c2656e5000f318339ded2f3c"
29 31
30# Corresponds to tag: 3.50.01.00 32SRCREV_ipc-metadata = "${TI_IPC_METADATA_SRCREV}"
31SRCREV_ipc-examples = "1975687076426b587be8d2530df56c24425ca53a" 33SRCREV_ipc-examples = "${TI_IPC_EXAMPLES_SRCREV}"
32 34
33S_ipc-examples = "${WORKDIR}/git/ipc-examples" 35S_ipc-examples = "${WORKDIR}/git/ipc-examples"
34S_ipc-metadata = "${WORKDIR}/git/ipc-metadata" 36S_ipc-metadata = "${WORKDIR}/git/ipc-metadata"
@@ -89,3 +91,5 @@ EXTRA_OEMAKE = "\
89 JOBS="--jobs=${BB_NUMBER_THREADS}" \ 91 JOBS="--jobs=${BB_NUMBER_THREADS}" \
90 JAVA_TOOL_OPTIONS=-Xss2560k \ 92 JAVA_TOOL_OPTIONS=-Xss2560k \
91" 93"
94EXTRA_OEMAKE_append_am65xx-evm = " PDK_INSTALL_DIR=${PDK_INSTALL_DIR}"
95
diff --git a/recipes-ti/ipc/ti-ipc-rtos_git.bb b/recipes-ti/ipc/ti-ipc-rtos_git.bb
index c374bb1f..ee7778a9 100644
--- a/recipes-ti/ipc/ti-ipc-rtos_git.bb
+++ b/recipes-ti/ipc/ti-ipc-rtos_git.bb
@@ -3,6 +3,7 @@ require ti-ipc-common.inc
3require ti-ipc-rtos.inc 3require ti-ipc-rtos.inc
4 4
5DEPENDS = "ti-xdctools-native ti-sysbios doxygen-native zip-native" 5DEPENDS = "ti-xdctools-native ti-sysbios doxygen-native zip-native"
6DEPENDS_append_am65xx-evm = " sciclient-rtos"
6 7
7PACKAGES =+ "${PN}-fw" 8PACKAGES =+ "${PN}-fw"
8FILES_${PN}-fw = "${base_libdir}/firmware/*" 9FILES_${PN}-fw = "${base_libdir}/firmware/*"
diff --git a/recipes-ti/ipc/ti-ipc.inc b/recipes-ti/ipc/ti-ipc.inc
index b10e242a..ca392924 100644
--- a/recipes-ti/ipc/ti-ipc.inc
+++ b/recipes-ti/ipc/ti-ipc.inc
@@ -8,8 +8,8 @@ TI_IPC_GIT_URI = "git://git.ti.com/ipc/ipcdev.git"
8TI_IPC_GIT_PROTOCOL = "git" 8TI_IPC_GIT_PROTOCOL = "git"
9TI_IPC_GIT_BRANCH = "3.50" 9TI_IPC_GIT_BRANCH = "3.50"
10 10
11#Corresponds to 3.50.01.00C 11#Corresponds to 3.50.01.01
12TI_IPC_SRCREV = "32294eb80e9889ba12d0c008b21acab4545713af" 12TI_IPC_SRCREV = "771859b9687476c3ba1b5bf0d4afb3c97876137e"
13 13
14BRANCH = "${TI_IPC_GIT_BRANCH}" 14BRANCH = "${TI_IPC_GIT_BRANCH}"
15SRC_URI = "${TI_IPC_GIT_URI};protocol=${TI_IPC_GIT_PROTOCOL};branch=${BRANCH};name=ipcdev" 15SRC_URI = "${TI_IPC_GIT_URI};protocol=${TI_IPC_GIT_PROTOCOL};branch=${BRANCH};name=ipcdev"