summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRyan Eatmon <reatmon@ti.com>2024-05-21 11:33:26 -0500
committerRyan Eatmon <reatmon@ti.com>2024-05-31 11:51:39 -0500
commitafcdfa2e638292d43cbe0eed8dc1271c95a1931e (patch)
tree10b7c85c0cab857726dbea74b1d3bfab8a4c64d3
parent67b556502b1c44fb55ddd02af1fa0b07a753b075 (diff)
downloadmeta-ti-afcdfa2e638292d43cbe0eed8dc1271c95a1931e.tar.gz
recipes: Update to UNPACKDIR for files going into WORKDIR
For recipes that have file:// in SRC_URI, the files are placed into WORKDIR. Moving forward [1], that directory will be UNPACKDIR and eventually move to somewhere other than WORKDIR. So update all references to WORKDIR that are looking for these file to use UNPACKDIR instead. [1] https://git.openembedded.org/openembedded-core/commit/?id=e022d62ba917790af2121da57646271ef17c03fa Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r--meta-ti-bsp/recipes-core/udev/eudev_%.bbappend4
-rw-r--r--meta-ti-bsp/recipes-kernel/linux/setup-defconfig.inc2
-rw-r--r--meta-ti-bsp/recipes-ti/ipc/ti-ipc_git.bb12
-rw-r--r--meta-ti-extras/recipes-ti/beagleboard/beaglebone-capes.bb4
-rw-r--r--meta-ti-extras/recipes-ti/beagleboard/gadget-init.bb10
-rw-r--r--meta-ti-extras/recipes-ti/devtools/ti-cgt-pru_2.3.3.bb8
-rw-r--r--meta-ti-extras/recipes-ti/devtools/ti-cgt6x_8.3.2.bb2
-rw-r--r--meta-ti-extras/recipes-ti/includes/ti-unpack.inc4
8 files changed, 23 insertions, 23 deletions
diff --git a/meta-ti-bsp/recipes-core/udev/eudev_%.bbappend b/meta-ti-bsp/recipes-core/udev/eudev_%.bbappend
index ddb1e75d..dee46cda 100644
--- a/meta-ti-bsp/recipes-core/udev/eudev_%.bbappend
+++ b/meta-ti-bsp/recipes-core/udev/eudev_%.bbappend
@@ -8,6 +8,6 @@ SRC_URI:append:ti-soc = " \
8PR:append:ti-soc = ".3" 8PR:append:ti-soc = ".3"
9 9
10do_install:append:ti-soc() { 10do_install:append:ti-soc() {
11 install -m 0644 ${WORKDIR}/omap-tty.rules ${D}${sysconfdir}/udev/rules.d/ 11 install -m 0644 ${UNPACKDIR}/omap-tty.rules ${D}${sysconfdir}/udev/rules.d/
12 install -m 0644 ${WORKDIR}/firmware.rules ${D}${sysconfdir}/udev/rules.d/ 12 install -m 0644 ${UNPACKDIR}/firmware.rules ${D}${sysconfdir}/udev/rules.d/
13} 13}
diff --git a/meta-ti-bsp/recipes-kernel/linux/setup-defconfig.inc b/meta-ti-bsp/recipes-kernel/linux/setup-defconfig.inc
index 8da90c79..213f6871 100644
--- a/meta-ti-bsp/recipes-kernel/linux/setup-defconfig.inc
+++ b/meta-ti-bsp/recipes-kernel/linux/setup-defconfig.inc
@@ -9,7 +9,7 @@ do_configure() {
9 # Always copy the defconfig file to .config to keep consistency 9 # Always copy the defconfig file to .config to keep consistency
10 # between the case where there is a real config and the in kernel 10 # between the case where there is a real config and the in kernel
11 # tree config 11 # tree config
12 cp ${WORKDIR}/defconfig ${B}/.config 12 cp ${UNPACKDIR}/defconfig ${B}/.config
13 13
14 scm_version=$(printf '%s%s' -g $(git -C ${S} rev-parse --verify HEAD 2>/dev/null | cut -c1-12)) 14 scm_version=$(printf '%s%s' -g $(git -C ${S} rev-parse --verify HEAD 2>/dev/null | cut -c1-12))
15 15
diff --git a/meta-ti-bsp/recipes-ti/ipc/ti-ipc_git.bb b/meta-ti-bsp/recipes-ti/ipc/ti-ipc_git.bb
index e2db6efd..11be09ea 100644
--- a/meta-ti-bsp/recipes-ti/ipc/ti-ipc_git.bb
+++ b/meta-ti-bsp/recipes-ti/ipc/ti-ipc_git.bb
@@ -18,7 +18,7 @@ SRC_URI += "file://tiipclad-daemon.sh \
18 file://0001-MmRpc-Stop-looking-for-rpmsg_rpc.h-in-the-kernel.patch \ 18 file://0001-MmRpc-Stop-looking-for-rpmsg_rpc.h-in-the-kernel.patch \
19 " 19 "
20 20
21CFLAGS += "-I${WORKDIR}" 21CFLAGS += "-I${UNPACKDIR}"
22 22
23DAEMON = "UNKNOWN" 23DAEMON = "UNKNOWN"
24DAEMON:dra7xx = "lad_dra7xx" 24DAEMON:dra7xx = "lad_dra7xx"
@@ -45,18 +45,18 @@ do_install:append() {
45 45
46 # Modify the startup scripts to point to the right 46 # Modify the startup scripts to point to the right
47 # lad daemon executable. 47 # lad daemon executable.
48 sed -i -e "s/__LAD_DAEMON__/${DAEMON}/" ${WORKDIR}/tiipclad-daemon.sh 48 sed -i -e "s/__LAD_DAEMON__/${DAEMON}/" ${UNPACKDIR}/tiipclad-daemon.sh
49 sed -i -e "s/__LAD_DAEMON__/${DAEMON}/" ${WORKDIR}/tiipclad-daemon.service 49 sed -i -e "s/__LAD_DAEMON__/${DAEMON}/" ${UNPACKDIR}/tiipclad-daemon.service
50 50
51 install -d ${D}${systemd_system_unitdir} 51 install -d ${D}${systemd_system_unitdir}
52 install -m 0644 ${WORKDIR}/tiipclad-daemon.service ${D}${systemd_system_unitdir} 52 install -m 0644 ${UNPACKDIR}/tiipclad-daemon.service ${D}${systemd_system_unitdir}
53 install -d ${D}${sysconfdir}/init.d/ 53 install -d ${D}${sysconfdir}/init.d/
54 install -c -m 755 ${WORKDIR}/tiipclad-daemon.sh ${D}${sysconfdir}/init.d/${INITSCRIPT_NAME} 54 install -c -m 755 ${UNPACKDIR}/tiipclad-daemon.sh ${D}${sysconfdir}/init.d/${INITSCRIPT_NAME}
55} 55}
56 56
57do_install:append:dra7xx() { 57do_install:append:dra7xx() {
58 install -d ${D}${sysconfdir}/modprobe.d/ 58 install -d ${D}${sysconfdir}/modprobe.d/
59 install -c -m 644 ${WORKDIR}/omap_remoteproc.conf ${D}${sysconfdir}/modprobe.d/ 59 install -c -m 644 ${UNPACKDIR}/omap_remoteproc.conf ${D}${sysconfdir}/modprobe.d/
60} 60}
61 61
62PACKAGES =+ "${PN}-test" 62PACKAGES =+ "${PN}-test"
diff --git a/meta-ti-extras/recipes-ti/beagleboard/beaglebone-capes.bb b/meta-ti-extras/recipes-ti/beagleboard/beaglebone-capes.bb
index ceefe0d6..ded1d9c0 100644
--- a/meta-ti-extras/recipes-ti/beagleboard/beaglebone-capes.bb
+++ b/meta-ti-extras/recipes-ti/beagleboard/beaglebone-capes.bb
@@ -14,13 +14,13 @@ SRC_URI = "file://cape.service \
14 14
15do_install() { 15do_install() {
16 install -d ${D}${base_libdir}/systemd/system/ 16 install -d ${D}${base_libdir}/systemd/system/
17 install -m 0644 ${WORKDIR}/cape.service ${D}${base_libdir}/systemd/system 17 install -m 0644 ${UNPACKDIR}/cape.service ${D}${base_libdir}/systemd/system
18 18
19 install -d ${D}${base_libdir}/systemd/system/basic.target.wants 19 install -d ${D}${base_libdir}/systemd/system/basic.target.wants
20 ln -sf ../cape.service ${D}${base_libdir}/systemd/system/basic.target.wants/ 20 ln -sf ../cape.service ${D}${base_libdir}/systemd/system/basic.target.wants/
21 21
22 install -d ${D}${bindir} 22 install -d ${D}${bindir}
23 install -m 0755 ${WORKDIR}/cape*.sh ${D}${bindir} 23 install -m 0755 ${UNPACKDIR}/cape*.sh ${D}${bindir}
24} 24}
25 25
26FILES:${PN} += "${base_libdir}/systemd/system" 26FILES:${PN} += "${base_libdir}/systemd/system"
diff --git a/meta-ti-extras/recipes-ti/beagleboard/gadget-init.bb b/meta-ti-extras/recipes-ti/beagleboard/gadget-init.bb
index 3ab00ec3..f22583c0 100644
--- a/meta-ti-extras/recipes-ti/beagleboard/gadget-init.bb
+++ b/meta-ti-extras/recipes-ti/beagleboard/gadget-init.bb
@@ -22,19 +22,19 @@ SRC_URI = "file://storage-gadget-init.service \
22 22
23do_install() { 23do_install() {
24 install -d ${D}${base_libdir}/systemd/system/basic.target.wants 24 install -d ${D}${base_libdir}/systemd/system/basic.target.wants
25 install -m 0644 ${WORKDIR}/*.service ${D}${base_libdir}/systemd/system 25 install -m 0644 ${UNPACKDIR}/*.service ${D}${base_libdir}/systemd/system
26 26
27 for i in ${WORKDIR}/storage-gadget-init.service ; do 27 for i in ${UNPACKDIR}/storage-gadget-init.service ; do
28 install -m 0644 $i ${D}${base_libdir}/systemd/system 28 install -m 0644 $i ${D}${base_libdir}/systemd/system
29 ln -sf ../$(basename $i) ${D}${base_libdir}/systemd/system/basic.target.wants/ 29 ln -sf ../$(basename $i) ${D}${base_libdir}/systemd/system/basic.target.wants/
30 done 30 done
31 31
32 install -d ${D}${sysconfdir}/udev/rules.d 32 install -d ${D}${sysconfdir}/udev/rules.d
33 install -m 0644 ${WORKDIR}/*.rules ${D}${sysconfdir}/udev/rules.d 33 install -m 0644 ${UNPACKDIR}/*.rules ${D}${sysconfdir}/udev/rules.d
34 install -m 0644 ${WORKDIR}/*.conf ${D}${sysconfdir} 34 install -m 0644 ${UNPACKDIR}/*.conf ${D}${sysconfdir}
35 35
36 install -d ${D}${bindir} 36 install -d ${D}${bindir}
37 install -m 0755 ${WORKDIR}/*.sh ${D}${bindir} 37 install -m 0755 ${UNPACKDIR}/*.sh ${D}${bindir}
38} 38}
39 39
40PACKAGES =+ "${PN}-storage ${PN}-network ${PN}-udhcpd" 40PACKAGES =+ "${PN}-storage ${PN}-network ${PN}-udhcpd"
diff --git a/meta-ti-extras/recipes-ti/devtools/ti-cgt-pru_2.3.3.bb b/meta-ti-extras/recipes-ti/devtools/ti-cgt-pru_2.3.3.bb
index c96113fe..47bd6a51 100644
--- a/meta-ti-extras/recipes-ti/devtools/ti-cgt-pru_2.3.3.bb
+++ b/meta-ti-extras/recipes-ti/devtools/ti-cgt-pru_2.3.3.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "TI PRU Code Generation Tools"
2HOMEPAGE = "https://www-a.ti.com/downloads/sds_support/TICodegenerationTools/download.htm" 2HOMEPAGE = "https://www-a.ti.com/downloads/sds_support/TICodegenerationTools/download.htm"
3LICENSE = "(TI-TSPA & Thai-Open-Source-Software-Center) & BSD-3-Clause & BSL-1.0 & Hewlett-Packard & AFL-3.0 & MIT & BSD-2-Clause & PD" 3LICENSE = "(TI-TSPA & Thai-Open-Source-Software-Center) & BSD-3-Clause & BSL-1.0 & Hewlett-Packard & AFL-3.0 & MIT & BSD-2-Clause & PD"
4 4
5LIC_FILES_CHKSUM = "file://ti-cgt-pru_${PV}/PRU_Code_Generation_Tools_2.3.x_manifest.html;md5=e22f9d8240f7cca0c0aa5242d9ffa5bc" 5LIC_FILES_CHKSUM = "file://${UNPACKDIR}/ti-cgt-pru_${PV}/PRU_Code_Generation_Tools_2.3.x_manifest.html;md5=e22f9d8240f7cca0c0aa5242d9ffa5bc"
6LIC_FILES_CHKSUM:class-target = "file://usr/share/doc/ti/cgt-pru/PRU_Code_Generation_Tools_2.3.x_manifest.html;md5=e22f9d8240f7cca0c0aa5242d9ffa5bc" 6LIC_FILES_CHKSUM:class-target = "file://usr/share/doc/ti/cgt-pru/PRU_Code_Generation_Tools_2.3.x_manifest.html;md5=e22f9d8240f7cca0c0aa5242d9ffa5bc"
7 7
8require recipes-ti/includes/ti-paths.inc 8require recipes-ti/includes/ti-paths.inc
@@ -10,7 +10,7 @@ require recipes-ti/includes/ti-unpack.inc
10 10
11BINFILE = "ti_cgt_pru_${PV}_linux_installer_x86.bin" 11BINFILE = "ti_cgt_pru_${PV}_linux_installer_x86.bin"
12BINFILE_NAME = "cgt-pru-x86" 12BINFILE_NAME = "cgt-pru-x86"
13TI_BIN_UNPK_ARGS = "--prefix ${S}" 13TI_BIN_UNPK_ARGS = "--prefix ${UNPACKDIR}"
14TI_BIN_UNPK_CMDS = "" 14TI_BIN_UNPK_CMDS = ""
15 15
16BINFILE:class-target = "ti_cgt_pru_${PV}_armlinuxa8hf_busybox_installer.sh" 16BINFILE:class-target = "ti_cgt_pru_${PV}_armlinuxa8hf_busybox_installer.sh"
@@ -26,12 +26,12 @@ SRC_URI[cgt-pru-arm.sha256sum] = "8390cb77b46b728ce2940595b81406f76d86dfed58c212
26 26
27do_install() { 27do_install() {
28 install -d ${D}${TI_CGT_PRU_INSTALL_DIR_RECIPE} 28 install -d ${D}${TI_CGT_PRU_INSTALL_DIR_RECIPE}
29 cp -r ${S}/ti-cgt-pru_${PV}/. \ 29 cp -r ${UNPACKDIR}/ti-cgt-pru_${PV}/. \
30 ${D}${TI_CGT_PRU_INSTALL_DIR_RECIPE}/ 30 ${D}${TI_CGT_PRU_INSTALL_DIR_RECIPE}/
31} 31}
32 32
33do_install:class-target() { 33do_install:class-target() {
34 ${WORKDIR}/${BINFILE} --prefix ${D} 34 ${UNPACKDIR}/${BINFILE} --prefix ${D}
35} 35}
36 36
37FILES:${PN} += "${datadir}/ti/*" 37FILES:${PN} += "${datadir}/ti/*"
diff --git a/meta-ti-extras/recipes-ti/devtools/ti-cgt6x_8.3.2.bb b/meta-ti-extras/recipes-ti/devtools/ti-cgt6x_8.3.2.bb
index fd34657a..1acd2f9f 100644
--- a/meta-ti-extras/recipes-ti/devtools/ti-cgt6x_8.3.2.bb
+++ b/meta-ti-extras/recipes-ti/devtools/ti-cgt6x_8.3.2.bb
@@ -92,7 +92,7 @@ do_install() {
92} 92}
93 93
94do_install:class-target() { 94do_install:class-target() {
95 ${WORKDIR}/${BINFILE} --prefix ${D} 95 ${UNPACKDIR}/${BINFILE} --prefix ${D}
96} 96}
97 97
98FILES:${PN} += "${datadir}/ti/*" 98FILES:${PN} += "${datadir}/ti/*"
diff --git a/meta-ti-extras/recipes-ti/includes/ti-unpack.inc b/meta-ti-extras/recipes-ti/includes/ti-unpack.inc
index 13068843..4cefefbf 100644
--- a/meta-ti-extras/recipes-ti/includes/ti-unpack.inc
+++ b/meta-ti-extras/recipes-ti/includes/ti-unpack.inc
@@ -5,7 +5,7 @@
5# TI_BIN_UNPK_ARGS - contains the arguments to be passed to the bin file. 5# TI_BIN_UNPK_ARGS - contains the arguments to be passed to the bin file.
6# TI_BIN_UNPK_CMDS - contains list of commands separated with colon to be 6# TI_BIN_UNPK_CMDS - contains list of commands separated with colon to be
7# passed while unpacking the bin file. The keyword 7# passed while unpacking the bin file. The keyword
8# workdir expands to WORKDIR and commands are appendded 8# workdir expands to UNPACKDIR and commands are appendded
9# with '\n'. Eg. TI_BIN_UNPK_CMDS="Y:Y: qY:workdir" 9# with '\n'. Eg. TI_BIN_UNPK_CMDS="Y:Y: qY:workdir"
10# TI_BIN_UNPK_WDEXT - This variable extends workdir path, if user wants to put 10# TI_BIN_UNPK_WDEXT - This variable extends workdir path, if user wants to put
11# the output in some internal directory 11# the output in some internal directory
@@ -30,7 +30,7 @@ python ti_bin_do_unpack() {
30 30
31 # Change to the working directory 31 # Change to the working directory
32 save_cwd = os.getcwd() 32 save_cwd = os.getcwd()
33 workdir = localdata.getVar('WORKDIR') 33 workdir = localdata.getVar('UNPACKDIR')
34 workdir = bb.data.expand(workdir, localdata) 34 workdir = bb.data.expand(workdir, localdata)
35 os.chdir(workdir) 35 os.chdir(workdir)
36 36