summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2020-01-30 04:38:16 +0000
committerDenys Dmytriyenko <denys@ti.com>2020-01-31 22:31:50 +0000
commitaecb431a600c122487e6eccdfe30251eafb14d99 (patch)
treec3143611e3a3de17bc9f7d1189afc2e988c4ff73
parent823ddbf9e5e2db66a09b70b7dbba559d798e5ee1 (diff)
downloadmeta-ti-aecb431a600c122487e6eccdfe30251eafb14d99.tar.gz
jailhouse: switch to Python3 dependencies
python-argparse is not available in oe-core, but meta-python provides a drop-in replacement python3-configargparse, if needed. meta-ti does not depend on meta-python for now - can be adjusted in the distro layer. Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-kernel/jailhouse/jailhouse_git.bb22
1 files changed, 11 insertions, 11 deletions
diff --git a/recipes-kernel/jailhouse/jailhouse_git.bb b/recipes-kernel/jailhouse/jailhouse_git.bb
index 4186dc3a..ed23cdec 100644
--- a/recipes-kernel/jailhouse/jailhouse_git.bb
+++ b/recipes-kernel/jailhouse/jailhouse_git.bb
@@ -18,18 +18,18 @@ SRC_URI = " \
18 git://git.ti.com/jailhouse/ti-jailhouse.git;protocol=git;branch=${BRANCH} \ 18 git://git.ti.com/jailhouse/ti-jailhouse.git;protocol=git;branch=${BRANCH} \
19" 19"
20 20
21DEPENDS = "virtual/kernel dtc-native python-mako-native python-mako make-native" 21DEPENDS = "virtual/kernel dtc-native python3-mako-native python3-mako make-native"
22RDEPENDS_${PN} += "\ 22RDEPENDS_${PN} += "\
23 python-curses\ 23 python3-curses\
24 python-datetime\ 24 python3-datetime\
25 python-argparse\ 25 python3-mmap\
26 python-mmap\
27" 26"
28 27
29S = "${WORKDIR}/git"
30
31require jailhouse-arch.inc 28require jailhouse-arch.inc
32inherit module pythonnative bash-completion deploy setuptools 29inherit module python3native bash-completion deploy setuptools3
30
31S = "${WORKDIR}/git"
32B = "${S}"
33 33
34PACKAGE_ARCH = "${MACHINE_ARCH}" 34PACKAGE_ARCH = "${MACHINE_ARCH}"
35COMPATIBLE_MACHINE = "(ti-soc)" 35COMPATIBLE_MACHINE = "(ti-soc)"
@@ -88,7 +88,7 @@ do_compile() {
88 88
89do_install() { 89do_install() {
90 # Install pyjailhouse python modules needed by the tools 90 # Install pyjailhouse python modules needed by the tools
91 distutils_do_install 91 distutils3_do_install
92 92
93 # We want to install the python tools, but we do not want to use pip... 93 # We want to install the python tools, but we do not want to use pip...
94 # At least with v0.10, we can work around this with 94 # At least with v0.10, we can work around this with
@@ -141,8 +141,8 @@ FILES_${PN} = "${base_libdir}/firmware ${libexecdir} ${sbindir} ${JH_DATADIR} /b
141FILES_pyjailhouse = "${PYTHON_SITEPACKAGES_DIR}" 141FILES_pyjailhouse = "${PYTHON_SITEPACKAGES_DIR}"
142FILES_${PN}-tools = "${libexecdir}/${BPN}/${BPN}-*" 142FILES_${PN}-tools = "${libexecdir}/${BPN}/${BPN}-*"
143 143
144RDEPENDS_${PN}-tools = "pyjailhouse python-mmap python-math python-argparse python-datetime python-curses python-compression" 144RDEPENDS_${PN}-tools = "pyjailhouse python3-mmap python3-math python3-datetime python3-curses python3-compression"
145RDEPENDS_pyjailhouse = "python-core python-ctypes python-fcntl python-shell" 145RDEPENDS_pyjailhouse = "python3-core python3-ctypes python3-fcntl python3-shell"
146 146
147RRECOMMENDS_${PN} = "${PN}-tools" 147RRECOMMENDS_${PN} = "${PN}-tools"
148 148