summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRandolph Sapp <rs@ti.com>2023-05-06 02:37:42 +0000
committerRyan Eatmon <reatmon@ti.com>2023-05-08 11:11:09 -0500
commitade5e668dcaddf607b0b45baaab397e876a1d7f2 (patch)
treef3d3353ca46eed9af629b91af2a46000c864cee1
parent6225d78b65e2a634d5f6aac356329f3cec0992c8 (diff)
downloadmeta-ti-ade5e668dcaddf607b0b45baaab397e876a1d7f2.tar.gz
cairo: resolve opengl version
Cairo can either be built for use with OpenGL or OpenGLES. By default it assumes it can use OpenGL if X11 is provided as a distro feature. This assumption is not true when using the proprietary SGX / Rogue drivers. Vulkan libraries need some X libs at runtime now, so we need to manually override the PACKAGECONFIG for cairo to use OpenGLES. Signed-off-by: Randolph Sapp <rs@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com> Signed-off-by: Denys Dmytriyenko <denys@konsulko.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r--meta-ti-bsp/recipes-graphics/cairo/cairo_%.bbappend1
-rw-r--r--meta-ti-bsp/recipes-graphics/cairo/pvr-cairo.inc5
2 files changed, 6 insertions, 0 deletions
diff --git a/meta-ti-bsp/recipes-graphics/cairo/cairo_%.bbappend b/meta-ti-bsp/recipes-graphics/cairo/cairo_%.bbappend
new file mode 100644
index 00000000..459d8d09
--- /dev/null
+++ b/meta-ti-bsp/recipes-graphics/cairo/cairo_%.bbappend
@@ -0,0 +1 @@
require ${@bb.utils.contains_any('PREFERRED_PROVIDER_virtual/gpudriver', 'ti-img-rogue-driver ti-sgx-ddk-km', 'pvr-cairo.inc', '', d)}
diff --git a/meta-ti-bsp/recipes-graphics/cairo/pvr-cairo.inc b/meta-ti-bsp/recipes-graphics/cairo/pvr-cairo.inc
new file mode 100644
index 00000000..b41f1a01
--- /dev/null
+++ b/meta-ti-bsp/recipes-graphics/cairo/pvr-cairo.inc
@@ -0,0 +1,5 @@
1# This is required since cairo expects the opengl distro feature to refer to
2# the desktop version of OpenGL. Imagination drivers only provide OpenGLES.
3
4PACKAGECONFIG:remove = "opengl"
5PACKAGECONFIG:append = " glesv2"