summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRyan Eatmon <reatmon@ti.com>2023-05-17 15:05:29 -0500
committerRyan Eatmon <reatmon@ti.com>2023-05-18 13:16:43 -0500
commita4f0f492f14059171ba515944bd9be3caf97c1d2 (patch)
tree51526d72e29e0e3d1d1e4b902a50b9357df39a5b
parentbdc8e7c9b58be79cd94906d1a2b6571e61d35561 (diff)
downloadmeta-ti-a4f0f492f14059171ba515944bd9be3caf97c1d2.tar.gz
linux-ti-*: Use vendored kernel-devicetree.bbclass
Change over to using the kernel_devicetree_vendor_dtb.bbclass to have the DTBs installed into the same vendored subdirectory that is in the kernel. Setting the variables comes in a follow on patch. Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r--meta-ti-bsp/recipes-kernel/linux/linux-ti-mainline_git.bb2
-rw-r--r--meta-ti-bsp/recipes-kernel/linux/linux-ti-next_git.bb2
-rw-r--r--meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_6.1.bb2
3 files changed, 3 insertions, 3 deletions
diff --git a/meta-ti-bsp/recipes-kernel/linux/linux-ti-mainline_git.bb b/meta-ti-bsp/recipes-kernel/linux/linux-ti-mainline_git.bb
index dfa46f48..74a4a860 100644
--- a/meta-ti-bsp/recipes-kernel/linux/linux-ti-mainline_git.bb
+++ b/meta-ti-bsp/recipes-kernel/linux/linux-ti-mainline_git.bb
@@ -3,7 +3,7 @@ SUMMARY = "Mainline Linux kernel for TI devices"
3LICENSE = "GPL-2.0-only" 3LICENSE = "GPL-2.0-only"
4LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46" 4LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
5 5
6inherit kernel 6inherit kernel_vendor_dtb
7 7
8require recipes-kernel/linux/kernel-rdepends.inc 8require recipes-kernel/linux/kernel-rdepends.inc
9require recipes-kernel/linux/ti-kernel.inc 9require recipes-kernel/linux/ti-kernel.inc
diff --git a/meta-ti-bsp/recipes-kernel/linux/linux-ti-next_git.bb b/meta-ti-bsp/recipes-kernel/linux/linux-ti-next_git.bb
index 9138c7c5..e1e1eb5e 100644
--- a/meta-ti-bsp/recipes-kernel/linux/linux-ti-next_git.bb
+++ b/meta-ti-bsp/recipes-kernel/linux/linux-ti-next_git.bb
@@ -3,7 +3,7 @@ SUMMARY = "Linux-next kernel for TI devices"
3LICENSE = "GPL-2.0-only" 3LICENSE = "GPL-2.0-only"
4LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46" 4LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
5 5
6inherit kernel 6inherit kernel_vendor_dtb
7 7
8require recipes-kernel/linux/ti-kernel.inc 8require recipes-kernel/linux/ti-kernel.inc
9 9
diff --git a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_6.1.bb b/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_6.1.bb
index cdee548f..e8622a2e 100644
--- a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_6.1.bb
+++ b/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_6.1.bb
@@ -3,7 +3,7 @@ SUMMARY = "Linux kernel for TI devices"
3LICENSE = "GPL-2.0-only" 3LICENSE = "GPL-2.0-only"
4LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46" 4LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
5 5
6inherit kernel 6inherit kernel_vendor_dtb
7 7
8require recipes-kernel/linux/setup-defconfig.inc 8require recipes-kernel/linux/setup-defconfig.inc
9require recipes-kernel/linux/kernel-rdepends.inc 9require recipes-kernel/linux/kernel-rdepends.inc