summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2019-12-10 09:07:44 +0000
committerDenys Dmytriyenko <denys@ti.com>2019-12-10 15:31:14 +0000
commit9e4389020cb7e48e08009452d5eb4262d6854947 (patch)
treedc0e5ac26edda61d9eae2f81e7e2d79eedafb4b2
parent7c8249c7dcf6b61961f8cb6baab33eb3c2103d4b (diff)
downloadmeta-ti-9e4389020cb7e48e08009452d5eb4262d6854947.tar.gz
prueth-fw, linux-ti-staging: allow packaging PRU ETH for GP and HS devices
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-bsp/prueth-fw/prueth-fw_git.bb13
-rw-r--r--recipes-kernel/linux/linux-ti-staging_4.19.bb7
2 files changed, 11 insertions, 9 deletions
diff --git a/recipes-bsp/prueth-fw/prueth-fw_git.bb b/recipes-bsp/prueth-fw/prueth-fw_git.bb
index 14518e1f..f7718ad2 100644
--- a/recipes-bsp/prueth-fw/prueth-fw_git.bb
+++ b/recipes-bsp/prueth-fw/prueth-fw_git.bb
@@ -12,25 +12,26 @@ TI_PDK_COMP = "ti.drv.icss_emac.firmware"
12 12
13B = "${S}/icss_dualemac" 13B = "${S}/icss_dualemac"
14 14
15COMPATIBLE_MACHINE = "am57xx-evm|am437x-evm|am335x-evm|k2g" 15COMPATIBLE_MACHINE = "am57xx-evm|am57xx-hs-evm|ti43x|ti33x|k2g"
16 16
17PACKAGE_ARCH = "${MACHINE_ARCH}" 17PACKAGE_ARCH = "${MACHINE_ARCH}"
18 18
19DEPENDS = "ti-cgt-pru-native" 19DEPENDS = "ti-cgt-pru-native"
20 20
21PRU_VERSION = "" 21PRU_VERSION = ""
22PRU_VERSION_am335x-evm = "REV1" 22PRU_VERSION_ti33x = "REV1"
23PRU_VERSION_am437x-evm = "REV1" 23PRU_VERSION_ti43x = "REV1"
24PRU_VERSION_am57xx-evm = "REV2" 24PRU_VERSION_am57xx-evm = "REV2"
25PRU_VERSION_am57xx-hs-evm = "REV2"
25PRU_VERSION_k2g = "REV2" 26PRU_VERSION_k2g = "REV2"
26 27
27FW_PREFIX = "" 28FW_PREFIX = ""
28FW_PREFIX_am335x-evm = "am335x" 29FW_PREFIX_ti33x = "am335x"
29FW_PREFIX_am437x-evm = "am437x" 30FW_PREFIX_ti43x = "am437x"
30FW_PREFIX_am57xx-evm = "am57xx" 31FW_PREFIX_am57xx-evm = "am57xx"
32FW_PREFIX_am57xx-hs-evm = "am57xx"
31FW_PREFIX_k2g = "k2g" 33FW_PREFIX_k2g = "k2g"
32 34
33
34EXTRA_OEMAKE += "CL_PRU_INSTALL_PATH="${TI_CGT_PRU_INSTALL_DIR}" PRU_VERSION_LIST="${PRU_VERSION}"" 35EXTRA_OEMAKE += "CL_PRU_INSTALL_PATH="${TI_CGT_PRU_INSTALL_DIR}" PRU_VERSION_LIST="${PRU_VERSION}""
35 36
36do_install() { 37do_install() {
diff --git a/recipes-kernel/linux/linux-ti-staging_4.19.bb b/recipes-kernel/linux/linux-ti-staging_4.19.bb
index 852bfa94..32d4b494 100644
--- a/recipes-kernel/linux/linux-ti-staging_4.19.bb
+++ b/recipes-kernel/linux/linux-ti-staging_4.19.bb
@@ -45,10 +45,11 @@ RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_k2l = " netcp-pa-fw"
45 45
46# Add run-time dependency for PRU Ethernet firmware to the rootfs 46# Add run-time dependency for PRU Ethernet firmware to the rootfs
47RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_am57xx-evm = " prueth-fw" 47RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_am57xx-evm = " prueth-fw"
48RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_am437x-evm = " prueth-fw" 48RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_am57xx-hs-evm = " prueth-fw"
49RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_am335x-evm = " prueth-fw" 49RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_ti43x = " prueth-fw"
50RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_ti33x = " prueth-fw"
50RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_k2g = " prueth-fw" 51RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_k2g = " prueth-fw"
51RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_am65xx-evm = " prueth-fw-am65x" 52RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_am65xx = " prueth-fw-am65x"
52 53
53# Add run-time dependency for Cadence MHDP firmware to the rootfs 54# Add run-time dependency for Cadence MHDP firmware to the rootfs
54RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_j7-evm = " cadence-mhdp-fw" 55RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_j7-evm = " cadence-mhdp-fw"