summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2017-04-24 18:18:35 -0400
committerDenys Dmytriyenko <denys@ti.com>2017-04-24 18:28:32 -0400
commit9a31cf90210ea824f86f4bdd6701d566b4260557 (patch)
treefcfa0156d142acce9ed9c4d3d3dff3550279ad51
parent9df1e2af34853f1bdc32a9e271fbd31266c83b46 (diff)
downloadmeta-ti-9a31cf90210ea824f86f4bdd6701d566b4260557.tar.gz
boot-monitor: fix build issue caused by Makefile tabs forcing sparse use
Signed-off-by: Denys Dmytriyenko <denys@ti.com> Cc: Dan Murphy <dmurphy@ti.com>
-rw-r--r--recipes-bsp/boot-monitor/boot-monitor_git.bb1
-rw-r--r--recipes-bsp/boot-monitor/files/0001-makedefs-Fix-issue-with-setting-CHECK-and-VERBOSE.patch42
2 files changed, 43 insertions, 0 deletions
diff --git a/recipes-bsp/boot-monitor/boot-monitor_git.bb b/recipes-bsp/boot-monitor/boot-monitor_git.bb
index da538672..e4ea67f6 100644
--- a/recipes-bsp/boot-monitor/boot-monitor_git.bb
+++ b/recipes-bsp/boot-monitor/boot-monitor_git.bb
@@ -8,6 +8,7 @@ PACKAGE_ARCH = "${MACHINE_ARCH}"
8DEPENDS = "u-boot-mkimage-native" 8DEPENDS = "u-boot-mkimage-native"
9 9
10SRC_URI = "git://git.ti.com/processor-firmware/ks2-boot-monitor.git;protocol=git;branch=${BRANCH}" 10SRC_URI = "git://git.ti.com/processor-firmware/ks2-boot-monitor.git;protocol=git;branch=${BRANCH}"
11SRC_URI += "file://0001-makedefs-Fix-issue-with-setting-CHECK-and-VERBOSE.patch"
11 12
12PV = "4.0+git${SRCPV}" 13PV = "4.0+git${SRCPV}"
13 14
diff --git a/recipes-bsp/boot-monitor/files/0001-makedefs-Fix-issue-with-setting-CHECK-and-VERBOSE.patch b/recipes-bsp/boot-monitor/files/0001-makedefs-Fix-issue-with-setting-CHECK-and-VERBOSE.patch
new file mode 100644
index 00000000..ae6d25ca
--- /dev/null
+++ b/recipes-bsp/boot-monitor/files/0001-makedefs-Fix-issue-with-setting-CHECK-and-VERBOSE.patch
@@ -0,0 +1,42 @@
1From f22f18d426c8f5b70c0bce9ac6015c067c46f5ad Mon Sep 17 00:00:00 2001
2From: Dan Murphy <dmurphy@ti.com>
3Date: Mon, 24 Apr 2017 17:02:56 -0500
4Subject: [PATCH] makedefs: Fix issue with setting CHECK and VERBOSE
5
6Within the ifndef tabs are not allowed. These need
7to be converted to spaces. Without this CHECK is always
8set and sparse is expected to be installed.
9
10Fixes: aba308b9868d ("Makefile: Use OBJROOT for build output to enable out-of-tree builds")
11Reported-by: Denys Dmytriyenko <denys@ti.com>
12Signed-off-by: Dan Murphy <dmurphy@ti.com>
13Signed-off-by: Denys Dmytriyenko <denys@ti.com>
14---
15 makedefs | 4 ++--
16 1 file changed, 2 insertions(+), 2 deletions(-)
17
18diff --git a/makedefs b/makedefs
19index 1c4e2a5..ab710c3 100644
20--- a/makedefs
21+++ b/makedefs
22@@ -58,7 +58,7 @@ ifeq ("$(origin C)", "command line")
23 endif
24
25 ifndef VERBOSE
26- export VERBOSE=0
27+ export VERBOSE=0
28 endif
29
30 ifeq ($(VERBOSE),1)
31@@ -69,7 +69,7 @@ else
32 endif
33
34 ifndef CHECK
35- export CHECK=0
36+ export CHECK=0
37 endif
38
39 Q_CC=$(Q:@=@echo ' CC '$@;)$(CC)
40--
412.7.4
42