summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Davis <afd@ti.com>2023-04-11 16:52:39 -0500
committerRyan Eatmon <reatmon@ti.com>2023-04-12 07:54:04 -0500
commit94e93e2b6b5b759aeb2b1a6226e81ed4e2db7c6c (patch)
tree9f5cc83e0bc1ca2d9ad4617ea4816e36fd20957d
parent00a4a5ed313bcbc774e5d7e04a86f86e8b6fba91 (diff)
downloadmeta-ti-94e93e2b6b5b759aeb2b1a6226e81ed4e2db7c6c.tar.gz
linux-ti-mainline: Remove ti-upstream-tools
Mainline should test the mainline kernel as it is, not with out-of-tree changes like new DTB/DTBOs. Use only upstream DTB/DTBOs. As that was the last thing provided by ti-upstream-tools, remove it here. Signed-off-by: Andrew Davis <afd@ti.com> Reviewed-by: Denys Dmytriyenko <denys@konsulko.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r--meta-ti-bsp/recipes-kernel/linux/linux-ti-mainline_git.bb17
1 files changed, 3 insertions, 14 deletions
diff --git a/meta-ti-bsp/recipes-kernel/linux/linux-ti-mainline_git.bb b/meta-ti-bsp/recipes-kernel/linux/linux-ti-mainline_git.bb
index 7d948a85..842864cd 100644
--- a/meta-ti-bsp/recipes-kernel/linux/linux-ti-mainline_git.bb
+++ b/meta-ti-bsp/recipes-kernel/linux/linux-ti-mainline_git.bb
@@ -1,5 +1,5 @@
1SECTION = "kernel" 1SECTION = "kernel"
2SUMMARY = "Mainline Linux kernel for TI devices (with ti-upstream-tools)" 2SUMMARY = "Mainline Linux kernel for TI devices"
3LICENSE = "GPL-2.0-only" 3LICENSE = "GPL-2.0-only"
4LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46" 4LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
5 5
@@ -15,9 +15,6 @@ KERNEL_EXTRA_ARGS += "LOADADDR=${UBOOT_ENTRYPOINT} \
15 15
16S = "${WORKDIR}/git" 16S = "${WORKDIR}/git"
17 17
18BRANCH = "master"
19TOOLS_BRANCH = "master"
20
21# 5.15 Mainline version 18# 5.15 Mainline version
22SRCREV = "8bb7eca972ad531c9b149c0a51ab43a417385813" 19SRCREV = "8bb7eca972ad531c9b149c0a51ab43a417385813"
23PV = "5.15+git${SRCPV}" 20PV = "5.15+git${SRCPV}"
@@ -28,24 +25,16 @@ PR = "${MACHINE_KERNEL_PR}"
28 25
29KERNEL_GIT_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git" 26KERNEL_GIT_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git"
30KERNEL_GIT_PROTOCOL = "https" 27KERNEL_GIT_PROTOCOL = "https"
28KERNEL_GIT_BRANCH = "master"
31SRC_URI += " \ 29SRC_URI += " \
32 ${KERNEL_GIT_URI};protocol=${KERNEL_GIT_PROTOCOL};branch=${BRANCH};name=linux \ 30 ${KERNEL_GIT_URI};protocol=${KERNEL_GIT_PROTOCOL};branch=${KERNEL_GIT_BRANCH} \
33 git://git.ti.com/git/ti-linux-kernel/ti-upstream-tools.git;branch=${TOOLS_BRANCH};protocol=${KERNEL_GIT_PROTOCOL};name=ti-upstream-tools;destsuffix=git/ti-upstream-tools \
34" 31"
35 32
36SRCREV_ti-upstream-tools = "0f60697843bba6f8d721b14da92b1652563ccb95"
37SRCREV_FORMAT = "linux"
38
39DEFCONFIG_NAME = "multi_v7_defconfig" 33DEFCONFIG_NAME = "multi_v7_defconfig"
40DEFCONFIG_NAME:omapl138 = "davinci_all_defconfig" 34DEFCONFIG_NAME:omapl138 = "davinci_all_defconfig"
41DEFCONFIG_NAME:k3 = "defconfig" 35DEFCONFIG_NAME:k3 = "defconfig"
42KERNEL_CONFIG_COMMAND = "oe_runmake -C ${S} O=${B} ${DEFCONFIG_NAME}" 36KERNEL_CONFIG_COMMAND = "oe_runmake -C ${S} O=${B} ${DEFCONFIG_NAME}"
43 37
44kernel_do_compile:append() {
45 oe_runmake dtbs CC="${KERNEL_CC} $cc_extra " LD="${KERNEL_LD}" ${KERNEL_EXTRA_ARGS}
46 oe_runmake -C ${S}/ti-upstream-tools LINUX=${S} DTC=${B}/scripts/dtc/dtc O=${B} CC="${KERNEL_CC} $cc_extra " LD="${KERNEL_LD}" ${KERNEL_EXTRA_ARGS}
47}
48
49do_shared_workdir:prepend() { 38do_shared_workdir:prepend() {
50 cd ${B} 39 cd ${B}
51 echo >> Module.symvers 40 echo >> Module.symvers