summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnand Gadiyar <gadiyar@ti.com>2022-11-04 22:46:22 +0000
committerRyan Eatmon <reatmon@ti.com>2022-11-23 16:08:24 -0600
commit79fc6e6f9136a3a88953910376a9200ea4954176 (patch)
tree2e3f478fcbda0b15aa9805e4bf594c15e869e53a
parent29ed73bad4553795a01644bfab6ae4983c7840ca (diff)
downloadmeta-ti-79fc6e6f9136a3a88953910376a9200ea4954176.tar.gz
machine: add am62xx-lp-evm configuration
This platform is similar to the currently supported am62xx-evm, except that we currently need new defconfigs for u-boot and new dtbs in the filesystem. Signed-off-by: Anand Gadiyar <gadiyar@ti.com> Cc: Hari Nagalla <hnagalla@ti.com> Cc: Andrew Davis <afd@ti.com> Cc: Praneeth Bajjuri <praneeth@ti.com> Cc: Ryan Eatmon <reatmon@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com> Signed-off-by: Denys Dmytriyenko <denys@konsulko.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r--meta-ti-bsp/conf/machine/am62xx-lp-evm-k3r5.conf11
-rw-r--r--meta-ti-bsp/conf/machine/am62xx-lp-evm.conf16
-rw-r--r--meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb1
-rw-r--r--meta-ti-bsp/recipes-bsp/tifs-lpm-stub/tifs-lpm-stub_git.bb2
-rw-r--r--meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc3
5 files changed, 30 insertions, 3 deletions
diff --git a/meta-ti-bsp/conf/machine/am62xx-lp-evm-k3r5.conf b/meta-ti-bsp/conf/machine/am62xx-lp-evm-k3r5.conf
new file mode 100644
index 00000000..ca4ced5a
--- /dev/null
+++ b/meta-ti-bsp/conf/machine/am62xx-lp-evm-k3r5.conf
@@ -0,0 +1,11 @@
1#@TYPE: Machine
2#@NAME: AM62XX LP EVM (R5F)
3#@DESCRIPTION: Machine configuration for the TI AM62xx LP EVM (R5F core)
4
5require conf/machine/include/k3r5.inc
6
7SYSFW_SOC = "am62x"
8SYSFW_CONFIG = "evm"
9SYSFW_SUFFIX = "gp"
10
11UBOOT_MACHINE = "am62x_lpsk_r5_defconfig"
diff --git a/meta-ti-bsp/conf/machine/am62xx-lp-evm.conf b/meta-ti-bsp/conf/machine/am62xx-lp-evm.conf
new file mode 100644
index 00000000..ef8e8692
--- /dev/null
+++ b/meta-ti-bsp/conf/machine/am62xx-lp-evm.conf
@@ -0,0 +1,16 @@
1#@TYPE: Machine
2#@NAME: AM62XX LP EVM
3#@DESCRIPTION: Machine configuration for the TI AM62XX LP EVM
4
5require conf/machine/include/am62xx.inc
6
7MACHINE_FEATURES += "gpu"
8
9KERNEL_DEVICETREE = " \
10 ti/k3-am62x-lp-sk.dtb \
11 ti/k3-am625-skeleton.dtb \
12 ti/k3-am625-sk-lpmdemo.dtb \
13 ti/k3-am625-sk-csi2-ov5640.dtbo \
14"
15
16UBOOT_MACHINE = "am62x_lpsk_a53_defconfig"
diff --git a/meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb b/meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
index 1b0dc4a1..6484ae87 100644
--- a/meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
+++ b/meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
@@ -36,6 +36,7 @@ SYSFW_PREFIX:j7200-hs-evm-k3r5 = "fs"
36SYSFW_PREFIX:j721s2-evm-k3r5 = "fs" 36SYSFW_PREFIX:j721s2-evm-k3r5 = "fs"
37SYSFW_PREFIX:j721s2-hs-evm-k3r5 = "fs" 37SYSFW_PREFIX:j721s2-hs-evm-k3r5 = "fs"
38SYSFW_PREFIX:am62xx-evm-k3r5 = "fs" 38SYSFW_PREFIX:am62xx-evm-k3r5 = "fs"
39SYSFW_PREFIX:am62xx-lp-evm-k3r5 = "fs"
39 40
40SYSFW_TISCI = "${S}/ti-sysfw/ti-${SYSFW_PREFIX}-firmware-${SYSFW_SOC}-*.bin" 41SYSFW_TISCI = "${S}/ti-sysfw/ti-${SYSFW_PREFIX}-firmware-${SYSFW_SOC}-*.bin"
41 42
diff --git a/meta-ti-bsp/recipes-bsp/tifs-lpm-stub/tifs-lpm-stub_git.bb b/meta-ti-bsp/recipes-bsp/tifs-lpm-stub/tifs-lpm-stub_git.bb
index 90af55f1..ce5f4e1f 100644
--- a/meta-ti-bsp/recipes-bsp/tifs-lpm-stub/tifs-lpm-stub_git.bb
+++ b/meta-ti-bsp/recipes-bsp/tifs-lpm-stub/tifs-lpm-stub_git.bb
@@ -7,7 +7,7 @@ PR = "${INC_PR}.0"
7 7
8CLEANBROKEN = "1" 8CLEANBROKEN = "1"
9 9
10COMPATIBLE_MACHINE = "am62xx-evm" 10COMPATIBLE_MACHINE = "am62xx"
11 11
12PACKAGE_ARCH = "${MACHINE_ARCH}" 12PACKAGE_ARCH = "${MACHINE_ARCH}"
13 13
diff --git a/meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc b/meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc
index 1071a278..3da41581 100644
--- a/meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc
+++ b/meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc
@@ -30,5 +30,4 @@ RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:j7 = " vxd-dec-fw"
30RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:j721s2 = " cnm-wave-fw" 30RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:j721s2 = " cnm-wave-fw"
31 31
32# Add run-time dependency for TIFS Low Power Module stub 32# Add run-time dependency for TIFS Low Power Module stub
33RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:am62xx-evm = " tifs-lpm-stub" 33RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:am62xx = " tifs-lpm-stub"
34