summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRyan Eatmon <reatmon@ti.com>2024-02-28 13:28:44 -0600
committerRyan Eatmon <reatmon@ti.com>2024-02-28 13:28:44 -0600
commit79e5bcecbc596a78f6dd08d96c10566a2eaf40ce (patch)
tree7f3769084fe8f8c99db97aa84705dc9e102e0ac8
parentd7624a767e20c776eb937c2942127299b4dc0093 (diff)
downloadmeta-ti-79e5bcecbc596a78f6dd08d96c10566a2eaf40ce.tar.gz
linux-ti-staging: Update KERNEL_LOCALVERSION
The use of KERNEL_LOCALVERSION for controlling the kernel version has changed recently. Placing the value of KERNEL_LOCALVERSION in .scmversion was causing it to duplicate the string in the final version. Instead, drop KERNEL_LOCALVERSION to just identify that it comes from TI, and that it is an RT kernel. Additionally, place the commit sha for the kernel into the .scmversion file explicitly to be both backward and forward compatible. Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r--meta-ti-bsp/recipes-kernel/linux/linux-ti-staging-rt_6.1.bb2
-rw-r--r--meta-ti-bsp/recipes-kernel/linux/setup-defconfig.inc10
2 files changed, 7 insertions, 5 deletions
diff --git a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging-rt_6.1.bb b/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging-rt_6.1.bb
index e78707f4..b7426aff 100644
--- a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging-rt_6.1.bb
+++ b/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging-rt_6.1.bb
@@ -1,5 +1,7 @@
1require linux-ti-staging_6.1.bb 1require linux-ti-staging_6.1.bb
2 2
3KERNEL_LOCALVERSION:append = "-rt"
4
3# Look in the generic major.minor directory for files 5# Look in the generic major.minor directory for files
4# This will have priority over generic non-rt path 6# This will have priority over generic non-rt path
5FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}-6.1:" 7FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}-6.1:"
diff --git a/meta-ti-bsp/recipes-kernel/linux/setup-defconfig.inc b/meta-ti-bsp/recipes-kernel/linux/setup-defconfig.inc
index df7d9ac8..8da90c79 100644
--- a/meta-ti-bsp/recipes-kernel/linux/setup-defconfig.inc
+++ b/meta-ti-bsp/recipes-kernel/linux/setup-defconfig.inc
@@ -1,6 +1,4 @@
1# KERNEL_LOCALVERSION can be set to add a tag to the end of the 1KERNEL_LOCALVERSION = "-ti"
2# kernel version string. such as the commit id
3KERNEL_LOCALVERSION = "-g${@d.getVar('SRCPV', True).replace('AUTOINC+','')[:10]}"
4 2
5# Check the defconfig file and see if it points to an in kernel 3# Check the defconfig file and see if it points to an in kernel
6# defconfig that should be used, or if it is a complete config file 4# defconfig that should be used, or if it is a complete config file
@@ -13,8 +11,10 @@ do_configure() {
13 # tree config 11 # tree config
14 cp ${WORKDIR}/defconfig ${B}/.config 12 cp ${WORKDIR}/defconfig ${B}/.config
15 13
16 echo ${KERNEL_LOCALVERSION} > ${B}/.scmversion 14 scm_version=$(printf '%s%s' -g $(git -C ${S} rev-parse --verify HEAD 2>/dev/null | cut -c1-12))
17 echo ${KERNEL_LOCALVERSION} > ${S}/.scmversion 15
16 echo ${scm_version} > ${B}/.scmversion
17 echo ${scm_version} > ${S}/.scmversion
18 18
19 # Zero, when using "tisdk" configs, pass control to defconfig_builder 19 # Zero, when using "tisdk" configs, pass control to defconfig_builder
20 config=`cat ${B}/.config | grep use-tisdk-config | cut -d= -f2` 20 config=`cat ${B}/.config | grep use-tisdk-config | cut -d= -f2`