diff options
author | Koen Kooi <koen@dominion.thruhere.net> | 2012-01-25 17:36:52 +0100 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2012-01-25 17:36:52 +0100 |
commit | 7049f8e77cffcf4d6e0f81dc69aa9b7b2c56de1a (patch) | |
tree | 1edd5f63316a711450e1d7db4d7d7ecce0f6a5dd | |
parent | 7b09dfe64675c324729f24881ef6b709c1185158 (diff) | |
download | meta-ti-7049f8e77cffcf4d6e0f81dc69aa9b7b2c56de1a.tar.gz |
linux-3.0: fix beagleboard DSI PLL regression
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
-rw-r--r-- | recipes-kernel/linux/linux-3.0/beagle/0011-beagleboard-reinstate-usage-of-hi-speed-PLL-divider.patch | 29 | ||||
-rw-r--r-- | recipes-kernel/linux/linux_3.0.bb | 3 |
2 files changed, 31 insertions, 1 deletions
diff --git a/recipes-kernel/linux/linux-3.0/beagle/0011-beagleboard-reinstate-usage-of-hi-speed-PLL-divider.patch b/recipes-kernel/linux/linux-3.0/beagle/0011-beagleboard-reinstate-usage-of-hi-speed-PLL-divider.patch new file mode 100644 index 00000000..4d2a9780 --- /dev/null +++ b/recipes-kernel/linux/linux-3.0/beagle/0011-beagleboard-reinstate-usage-of-hi-speed-PLL-divider.patch | |||
@@ -0,0 +1,29 @@ | |||
1 | From a2139a0efb9472a649465a1080799c73470fd201 Mon Sep 17 00:00:00 2001 | ||
2 | From: Koen Kooi <koen@dominion.thruhere.net> | ||
3 | Date: Wed, 25 Jan 2012 15:48:36 +0100 | ||
4 | Subject: [PATCH] beagleboard: reinstate usage of hi-speed PLL divider | ||
5 | |||
6 | Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> | ||
7 | --- | ||
8 | arch/arm/mach-omap2/board-omap3beagle.c | 5 +++++ | ||
9 | 1 files changed, 5 insertions(+), 0 deletions(-) | ||
10 | |||
11 | diff --git a/arch/arm/mach-omap2/board-omap3beagle.c b/arch/arm/mach-omap2/board-omap3beagle.c | ||
12 | index 016d0985..c4c7a99 100644 | ||
13 | --- a/arch/arm/mach-omap2/board-omap3beagle.c | ||
14 | +++ b/arch/arm/mach-omap2/board-omap3beagle.c | ||
15 | @@ -467,6 +467,11 @@ static struct omap_dss_device beagle_dvi_device = { | ||
16 | .driver_name = "generic_dpi_panel", | ||
17 | .data = &dvi_panel, | ||
18 | .phy.dpi.data_lines = 24, | ||
19 | + .clocks = { | ||
20 | + .dispc = { | ||
21 | + .dispc_fclk_src = OMAP_DSS_CLK_SRC_DSI_PLL_HSDIV_DISPC, | ||
22 | + }, | ||
23 | + }, | ||
24 | .reset_gpio = -EINVAL, | ||
25 | }; | ||
26 | |||
27 | -- | ||
28 | 1.7.7.5 | ||
29 | |||
diff --git a/recipes-kernel/linux/linux_3.0.bb b/recipes-kernel/linux/linux_3.0.bb index 70ca7cc9..d62c1ea0 100644 --- a/recipes-kernel/linux/linux_3.0.bb +++ b/recipes-kernel/linux/linux_3.0.bb | |||
@@ -10,7 +10,7 @@ PV = "3.0.17" | |||
10 | SRCREV_pn-${PN} = "e9d23be2708477feeaec78e707c80441520c1ef6" | 10 | SRCREV_pn-${PN} = "e9d23be2708477feeaec78e707c80441520c1ef6" |
11 | 11 | ||
12 | # The main PR is now using MACHINE_KERNEL_PR, for omap3 see conf/machine/include/omap3.inc | 12 | # The main PR is now using MACHINE_KERNEL_PR, for omap3 see conf/machine/include/omap3.inc |
13 | MACHINE_KERNEL_PR_append = "b" | 13 | MACHINE_KERNEL_PR_append = "c" |
14 | 14 | ||
15 | FILESPATH =. "${FILE_DIRNAME}/linux-3.0:${FILE_DIRNAME}/linux-3.0/${MACHINE}:" | 15 | FILESPATH =. "${FILE_DIRNAME}/linux-3.0:${FILE_DIRNAME}/linux-3.0/${MACHINE}:" |
16 | 16 | ||
@@ -194,6 +194,7 @@ SRC_URI += "git://git.kernel.org/pub/scm/linux/kernel/git/stable/linux-stable.gi | |||
194 | file://beagle/0008-OMAP2-add-cpu-id-register-to-MAC-address-helper.patch \ | 194 | file://beagle/0008-OMAP2-add-cpu-id-register-to-MAC-address-helper.patch \ |
195 | file://beagle/0009-HACK-OMAP2-BeagleBoard-Fix-up-random-or-missing-MAC-.patch \ | 195 | file://beagle/0009-HACK-OMAP2-BeagleBoard-Fix-up-random-or-missing-MAC-.patch \ |
196 | file://beagle/0010-ARM-OMAP2-beagleboard-fix-mmc-write-protect-pin-when.patch \ | 196 | file://beagle/0010-ARM-OMAP2-beagleboard-fix-mmc-write-protect-pin-when.patch \ |
197 | file://beagle/0011-beagleboard-reinstate-usage-of-hi-speed-PLL-divider.patch \ | ||
197 | file://madc/0001-Enabling-Hwmon-driver-for-twl4030-madc.patch \ | 198 | file://madc/0001-Enabling-Hwmon-driver-for-twl4030-madc.patch \ |
198 | file://madc/0002-mfd-twl-core-enable-madc-clock.patch \ | 199 | file://madc/0002-mfd-twl-core-enable-madc-clock.patch \ |
199 | \ | 200 | \ |