diff options
author | Denys Dmytriyenko <denys@konsulko.com> | 2024-06-20 20:56:36 -0400 |
---|---|---|
committer | Ryan Eatmon <reatmon@ti.com> | 2024-07-01 08:58:02 -0500 |
commit | 5cda7e9f4a0d9c7746adcaadefb1c8423f0e3568 (patch) | |
tree | a9ebf040076002315efc6036c7206389483075f3 | |
parent | ffae59bd23377a490c8d499522558a16d6452371 (diff) | |
download | meta-ti-5cda7e9f4a0d9c7746adcaadefb1c8423f0e3568.tar.gz |
linux: cleanup and unify mainline and next kernel recipes
Share the most commonality between the recipes, except:
* SRC_URI torvalds vs. linux-next
* SRCREV and PV
* Device Tree list vs. DT prefix
* SUMMARY
Signed-off-by: Denys Dmytriyenko <denys@konsulko.com>
Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r-- | meta-ti-bsp/recipes-kernel/linux/linux-ti-mainline_git.bb | 19 | ||||
-rw-r--r-- | meta-ti-bsp/recipes-kernel/linux/linux-ti-next_git.bb | 19 |
2 files changed, 5 insertions, 33 deletions
diff --git a/meta-ti-bsp/recipes-kernel/linux/linux-ti-mainline_git.bb b/meta-ti-bsp/recipes-kernel/linux/linux-ti-mainline_git.bb index 47b573e1..77ebb11e 100644 --- a/meta-ti-bsp/recipes-kernel/linux/linux-ti-mainline_git.bb +++ b/meta-ti-bsp/recipes-kernel/linux/linux-ti-mainline_git.bb | |||
@@ -9,30 +9,17 @@ require recipes-kernel/linux/ti-kernel.inc | |||
9 | 9 | ||
10 | DEPENDS += "gmp-native libmpc-native" | 10 | DEPENDS += "gmp-native libmpc-native" |
11 | 11 | ||
12 | KERNEL_EXTRA_ARGS += "LOADADDR=${UBOOT_ENTRYPOINT} \ | 12 | KERNEL_EXTRA_ARGS += "LOADADDR=${UBOOT_ENTRYPOINT} ${EXTRA_DTC_ARGS}" |
13 | ${EXTRA_DTC_ARGS}" | ||
14 | 13 | ||
15 | S = "${WORKDIR}/git" | 14 | S = "${WORKDIR}/git" |
16 | 15 | ||
17 | # 6.6 Mainline version | 16 | # 6.6 Mainline version |
18 | SRCREV = "ffc253263a1375a65fa6c9f62a893e9767fbebfa" | 17 | SRCREV = "ffc253263a1375a65fa6c9f62a893e9767fbebfa" |
19 | PV = "6.6+git" | 18 | PV = "6.6" |
20 | 19 | ||
21 | KERNEL_GIT_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git" | 20 | SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git;protocol=https;branch=master" |
22 | KERNEL_GIT_PROTOCOL = "https" | ||
23 | KERNEL_GIT_BRANCH = "master" | ||
24 | SRC_URI += " \ | ||
25 | ${KERNEL_GIT_URI};protocol=${KERNEL_GIT_PROTOCOL};branch=${KERNEL_GIT_BRANCH} \ | ||
26 | " | ||
27 | 21 | ||
28 | DEFCONFIG_NAME = "multi_v7_defconfig" | 22 | DEFCONFIG_NAME = "multi_v7_defconfig" |
29 | DEFCONFIG_NAME:omapl138 = "davinci_all_defconfig" | 23 | DEFCONFIG_NAME:omapl138 = "davinci_all_defconfig" |
30 | DEFCONFIG_NAME:k3 = "defconfig" | 24 | DEFCONFIG_NAME:k3 = "defconfig" |
31 | KERNEL_CONFIG_COMMAND = "oe_runmake -C ${S} O=${B} ${DEFCONFIG_NAME}" | 25 | KERNEL_CONFIG_COMMAND = "oe_runmake -C ${S} O=${B} ${DEFCONFIG_NAME}" |
32 | |||
33 | do_shared_workdir:prepend() { | ||
34 | cd ${B} | ||
35 | echo >> Module.symvers | ||
36 | } | ||
37 | |||
38 | FILES:${KERNEL_PACKAGE_NAME}-devicetree += "/${KERNEL_IMAGEDEST}/*.itb" | ||
diff --git a/meta-ti-bsp/recipes-kernel/linux/linux-ti-next_git.bb b/meta-ti-bsp/recipes-kernel/linux/linux-ti-next_git.bb index f1a14ab1..3c206754 100644 --- a/meta-ti-bsp/recipes-kernel/linux/linux-ti-next_git.bb +++ b/meta-ti-bsp/recipes-kernel/linux/linux-ti-next_git.bb | |||
@@ -1,26 +1,11 @@ | |||
1 | SECTION = "kernel" | 1 | require linux-ti-mainline_git.bb |
2 | SUMMARY = "Linux-next kernel for TI devices" | ||
3 | LICENSE = "GPL-2.0-only" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46" | ||
5 | 2 | ||
6 | inherit kernel | 3 | SUMMARY = "Linux-next kernel for TI devices" |
7 | 4 | ||
8 | require recipes-kernel/linux/ti-kernel.inc | ||
9 | include ${@ 'recipes-kernel/linux/ti-kernel-devicetree-prefix.inc' if d.getVar('KERNEL_DEVICETREE_PREFIX') else ''} | 5 | include ${@ 'recipes-kernel/linux/ti-kernel-devicetree-prefix.inc' if d.getVar('KERNEL_DEVICETREE_PREFIX') else ''} |
10 | 6 | ||
11 | DEPENDS += "gmp-native libmpc-native" | ||
12 | |||
13 | KERNEL_EXTRA_ARGS += "LOADADDR=${UBOOT_ENTRYPOINT} ${EXTRA_DTC_ARGS}" | ||
14 | |||
15 | S = "${WORKDIR}/git" | ||
16 | |||
17 | # 6.6.0-rc3+ version | 7 | # 6.6.0-rc3+ version |
18 | SRCREV = "6465e260f48790807eef06b583b38ca9789b6072" | 8 | SRCREV = "6465e260f48790807eef06b583b38ca9789b6072" |
19 | PV = "6.6.0-rc3+git" | 9 | PV = "6.6.0-rc3+git" |
20 | 10 | ||
21 | SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/next/linux-next.git;protocol=https;branch=master" | 11 | SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/next/linux-next.git;protocol=https;branch=master" |
22 | |||
23 | DEFCONFIG_NAME = "multi_v7_defconfig" | ||
24 | DEFCONFIG_NAME:omapl138 = "davinci_all_defconfig" | ||
25 | DEFCONFIG_NAME:k3 = "defconfig" | ||
26 | KERNEL_CONFIG_COMMAND = "oe_runmake -C ${S} O=${B} ${DEFCONFIG_NAME}" | ||