summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRyan Eatmon <reatmon@ti.com>2024-01-24 12:23:24 -0600
committerRyan Eatmon <reatmon@ti.com>2024-02-06 09:18:18 -0600
commit520f0e26947cb47aab6dc0d68ade749b39356027 (patch)
tree764f312d6958edacf46457c0ed637feb8a275513
parent16186a72baf20639c170e43d0705beb3f1ba2fb2 (diff)
downloadmeta-ti-520f0e26947cb47aab6dc0d68ade749b39356027.tar.gz
u-boot-ti*: Move mainline to 2024.01 and move logo code
Now that 2024.01 is official, the logo that am62xx-evm installs is available in all versions of the repo that we point to. Move all of that code out of the .bb files and into the u-boot-ti.inc file. Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r--meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-mainline_git.bb4
-rw-r--r--meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb10
-rw-r--r--meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2024.01.bb10
-rw-r--r--meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti.inc10
4 files changed, 12 insertions, 22 deletions
diff --git a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-mainline_git.bb b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-mainline_git.bb
index 692cf84a..f497054c 100644
--- a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-mainline_git.bb
+++ b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-mainline_git.bb
@@ -2,7 +2,7 @@ require u-boot-ti.inc
2 2
3PR = "r0" 3PR = "r0"
4 4
5PV = "2023.10" 5PV = "2024.01"
6 6
7# For the un-initiated: 7# For the un-initiated:
8# The actual URL you'd use with a git clone for example would be: 8# The actual URL you'd use with a git clone for example would be:
@@ -13,4 +13,4 @@ PV = "2023.10"
13# b) and we want git fetcher to use https protocol, hence GIT_PROTOCOL as https 13# b) and we want git fetcher to use https protocol, hence GIT_PROTOCOL as https
14UBOOT_GIT_URI = "git://source.denx.de/u-boot/u-boot.git" 14UBOOT_GIT_URI = "git://source.denx.de/u-boot/u-boot.git"
15UBOOT_GIT_PROTOCOL = "https" 15UBOOT_GIT_PROTOCOL = "https"
16SRCREV = "4459ed60cb1e0562bc5b40405e2b4b9bbf766d57" 16SRCREV = "866ca972d6c3cabeaf6dbac431e8e08bb30b3c8e"
diff --git a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb
index 143bcea8..e95c9c76 100644
--- a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb
+++ b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb
@@ -7,13 +7,3 @@ PR = "r0"
7BRANCH = "ti-u-boot-2023.04" 7BRANCH = "ti-u-boot-2023.04"
8 8
9SRCREV = "a97ca328b3df6abf79c5cc01878290e03131bbba" 9SRCREV = "a97ca328b3df6abf79c5cc01878290e03131bbba"
10
11do_install:append:am62xx() {
12 install -d ${D}/boot
13 install -m 0644 ${S}/tools/logos/ti_logo_414x97_32bpp.bmp.gz ${D}/boot
14}
15
16do_deploy:append:am62xx() {
17 install -d ${DEPLOYDIR}
18 install -m 0644 ${S}/tools/logos/ti_logo_414x97_32bpp.bmp.gz ${DEPLOYDIR}
19}
diff --git a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2024.01.bb b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2024.01.bb
index 58900bee..d2a6ccb5 100644
--- a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2024.01.bb
+++ b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2024.01.bb
@@ -9,13 +9,3 @@ PR = "r0"
9BRANCH = "ti-u-boot-2024.01" 9BRANCH = "ti-u-boot-2024.01"
10 10
11SRCREV = "2f0282922b2c458eea7f85c500a948a587437b63" 11SRCREV = "2f0282922b2c458eea7f85c500a948a587437b63"
12
13do_install:append:am62xx() {
14 install -d ${D}/boot
15 install -m 0644 ${S}/tools/logos/ti_logo_414x97_32bpp.bmp.gz ${D}/boot
16}
17
18do_deploy:append:am62xx() {
19 install -d ${DEPLOYDIR}
20 install -m 0644 ${S}/tools/logos/ti_logo_414x97_32bpp.bmp.gz ${DEPLOYDIR}
21}
diff --git a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti.inc b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti.inc
index 3a5d8a7d..9b26596c 100644
--- a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti.inc
+++ b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti.inc
@@ -331,4 +331,14 @@ do_deploy:append () {
331 rm ${DEPLOYDIR}/${PN}-initial-env-${MACHINE}-${PV}-${PR} || true 331 rm ${DEPLOYDIR}/${PN}-initial-env-${MACHINE}-${PV}-${PR} || true
332} 332}
333 333
334do_install:append:am62xx() {
335 install -d ${D}/boot
336 install -m 0644 ${S}/tools/logos/ti_logo_414x97_32bpp.bmp.gz ${D}/boot
337}
338
339do_deploy:append:am62xx() {
340 install -d ${DEPLOYDIR}
341 install -m 0644 ${S}/tools/logos/ti_logo_414x97_32bpp.bmp.gz ${DEPLOYDIR}
342}
343
334TOOLCHAIN = "gcc" 344TOOLCHAIN = "gcc"