summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRyan Eatmon <reatmon@ti.com>2023-11-01 13:07:21 -0500
committerRyan Eatmon <reatmon@ti.com>2023-11-01 13:07:21 -0500
commit4c0952f066689184cba6d955023c9749d91672f9 (patch)
tree3272c5527872f03893fa219aae503088db75ea9a
parent128a5074b8cc5b29a8adad4ea79a61e4b34f3906 (diff)
downloadmeta-ti-4c0952f066689184cba6d955023c9749d91672f9.tar.gz
ti-img-rogue-driver: Fix build error due to .SECONDARY/.NOTINTERMEDIATE
There is a build error under master that is not present in kirkstone related to .SECONDARY/.NOTINTERMEDIATE being set differently between the ti-img-rogue-driver repo and the kernel. The long term solution to allow this code to be built on both kirkstone/master is being investigated. In the meantime, this patch gets things building on master. Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r--meta-ti-bsp/recipes-bsp/powervr-drivers/ti-img-rogue-driver/0001-build-kbuild-Makefile.template-use-SECONDARY.patch35
-rw-r--r--meta-ti-bsp/recipes-bsp/powervr-drivers/ti-img-rogue-driver_23.2.6460340.bb2
2 files changed, 37 insertions, 0 deletions
diff --git a/meta-ti-bsp/recipes-bsp/powervr-drivers/ti-img-rogue-driver/0001-build-kbuild-Makefile.template-use-SECONDARY.patch b/meta-ti-bsp/recipes-bsp/powervr-drivers/ti-img-rogue-driver/0001-build-kbuild-Makefile.template-use-SECONDARY.patch
new file mode 100644
index 00000000..0989116e
--- /dev/null
+++ b/meta-ti-bsp/recipes-bsp/powervr-drivers/ti-img-rogue-driver/0001-build-kbuild-Makefile.template-use-SECONDARY.patch
@@ -0,0 +1,35 @@
1From 738dfc1b33a83e9995ed7f65ec41ebe2fc6a90ed Mon Sep 17 00:00:00 2001
2From: Ryan Eatmon <reatmon@ti.com>
3Date: Wed, 1 Nov 2023 10:04:29 -0500
4Subject: [PATCH] build: kbuild: Makefile.template: use SECONDARY
5
6For some reason on master we are seeing an error:
7
8| make[5]: *** .NOTINTERMEDIATE and .SECONDARY are mutually exclusive. Stop.
9
10Flip this back to .SECONDARY to fix this build issue.
11
12Signed-off-by: Ryan Eatmon <reatmon@ti.com>
13
14Upstream-Status: Pending
15
16---
17 build/linux/kbuild/Makefile.template | 2 +-
18 1 file changed, 1 insertion(+), 1 deletion(-)
19
20diff --git a/build/linux/kbuild/Makefile.template b/build/linux/kbuild/Makefile.template
21index aa19d66..31e37fb 100644
22--- a/build/linux/kbuild/Makefile.template
23+++ b/build/linux/kbuild/Makefile.template
24@@ -54,7 +54,7 @@
25
26 include $(OUT)/config_kernel.mk
27
28-.NOTINTERMEDIATE:
29+.SECONDARY:
30
31 define symlink-source-file
32 @if [ ! -e $(dir $@) ]; then mkdir -p $(dir $@); fi
33--
342.17.1
35
diff --git a/meta-ti-bsp/recipes-bsp/powervr-drivers/ti-img-rogue-driver_23.2.6460340.bb b/meta-ti-bsp/recipes-bsp/powervr-drivers/ti-img-rogue-driver_23.2.6460340.bb
index a74cc7b8..e47a1175 100644
--- a/meta-ti-bsp/recipes-bsp/powervr-drivers/ti-img-rogue-driver_23.2.6460340.bb
+++ b/meta-ti-bsp/recipes-bsp/powervr-drivers/ti-img-rogue-driver_23.2.6460340.bb
@@ -20,6 +20,8 @@ BRANCH = "linuxws/kirkstone/k6.1/${PV}"
20 20
21SRC_URI = "git://git.ti.com/git/graphics/ti-img-rogue-driver.git;protocol=https;branch=${BRANCH}" 21SRC_URI = "git://git.ti.com/git/graphics/ti-img-rogue-driver.git;protocol=https;branch=${BRANCH}"
22 22
23SRC_URI:append = " file://0001-build-kbuild-Makefile.template-use-SECONDARY.patch"
24
23S = "${WORKDIR}/git" 25S = "${WORKDIR}/git"
24 26
25SRCREV = "778aa5d1e104f36c7f7c1f50e99f8499cbbdadbb" 27SRCREV = "778aa5d1e104f36c7f7c1f50e99f8499cbbdadbb"