summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDhruva Gole <d-gole@ti.com>2023-01-17 11:42:57 +0530
committerRyan Eatmon <reatmon@ti.com>2023-01-17 09:33:30 -0600
commit46a3978c6cfff43487546875161f55d5cd3c72fb (patch)
treefe0e05a261afda40ab75ba8f1662d73406809ebe
parent07be9c4d1160271db160a528d7903495c687e79b (diff)
downloadmeta-ti-46a3978c6cfff43487546875161f55d5cd3c72fb.tar.gz
optee-os: Enable SW PRNG for OP-TEE in AM62X
commit 98506a4a07363 ("optee-os: Update SRCREV for OP-TEE TRNG in AM62X") Disables SW PRNG => Enabling Hardware RNG. This is breaking Suspend Resume on AM62xx EVM variants. To fix this keep using SOFTWARE_PRNG enabled as it was. Cc: vibhore@ti.com Cc: Andrew Davis <afd@ti.com> Signed-off-by: Dhruva Gole <d-gole@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r--recipes-security/optee/optee-os_%.bbappend4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes-security/optee/optee-os_%.bbappend b/recipes-security/optee/optee-os_%.bbappend
index db9064de..83eb9c6a 100644
--- a/recipes-security/optee/optee-os_%.bbappend
+++ b/recipes-security/optee/optee-os_%.bbappend
@@ -6,8 +6,8 @@ DEPENDS_append_ti-soc = " python3-cryptography-native"
6 6
7EXTRA_OEMAKE_append_k3 = "${@ 'CFG_CONSOLE_UART='+ d.getVar('OPTEE_K3_USART') if d.getVar('OPTEE_K3_USART') else ''}" 7EXTRA_OEMAKE_append_k3 = "${@ 'CFG_CONSOLE_UART='+ d.getVar('OPTEE_K3_USART') if d.getVar('OPTEE_K3_USART') else ''}"
8 8
9EXTRA_OEMAKE_append_am62xx-evm = " CFG_TEE_CORE_LOG_LEVEL=1" 9EXTRA_OEMAKE_append_am62xx-evm = " CFG_WITH_SOFTWARE_PRNG=y CFG_TEE_CORE_LOG_LEVEL=1"
10EXTRA_OEMAKE_append_am62xx-lp-evm = " CFG_TEE_CORE_LOG_LEVEL=1" 10EXTRA_OEMAKE_append_am62xx-lp-evm = " CFG_WITH_SOFTWARE_PRNG=y CFG_TEE_CORE_LOG_LEVEL=1"
11EXTRA_OEMAKE_append_am62axx-evm = " CFG_TEE_CORE_LOG_LEVEL=1" 11EXTRA_OEMAKE_append_am62axx-evm = " CFG_TEE_CORE_LOG_LEVEL=1"
12 12
13do_compile_prepend_ti-soc() { 13do_compile_prepend_ti-soc() {