diff options
author | Sam Nelson <sam.nelson@ti.com> | 2015-01-17 00:20:20 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2015-01-21 15:09:29 -0500 |
commit | 38fd3c3e477ac0c3d0fa0559338c61d1608be1e0 (patch) | |
tree | 1e847b8035db693d56a4e18cdc9596506f739698 | |
parent | 09410e4b765be4b2244da2f838d2b3df5ab24822 (diff) | |
download | meta-ti-38fd3c3e477ac0c3d0fa0559338c61d1608be1e0.tar.gz |
traceframework: Add recipe for TI trace framework library
- Provide libraries and test code for trace framework.
- Support framework to stream data from producer to multiple consumers
- Supports devices K2H, K2K, K2E, K2L & c6614
Signed-off-by: Sam Nelson <sam.nelson@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r-- | recipes-bsp/traceframework/traceframework_git.bb | 48 |
1 files changed, 48 insertions, 0 deletions
diff --git a/recipes-bsp/traceframework/traceframework_git.bb b/recipes-bsp/traceframework/traceframework_git.bb new file mode 100644 index 00000000..3211dea2 --- /dev/null +++ b/recipes-bsp/traceframework/traceframework_git.bb | |||
@@ -0,0 +1,48 @@ | |||
1 | DESCRIPTION = "TI Trace Framework library" | ||
2 | LICENSE = "BSD-3-Clause" | ||
3 | LIC_FILES_CHKSUM = "file://${WORKDIR}/git/ti/instrumentation/traceframework/COPYING.txt;md5=e8f6789acdcda76d02ed9203fc2e603d" | ||
4 | |||
5 | BRANCH="master" | ||
6 | SRC_URI = "git://git.ti.com/keystone-rtos/traceframework.git;destsuffix=git/ti/instrumentation/traceframework;protocol=git;branch=${BRANCH}" | ||
7 | |||
8 | # Below commit ID corresponds to DEV.TFWK-01.01.01.06A | ||
9 | SRCREV = "bd87f53f4d12dc802bcc5609afb7994643e40cb9" | ||
10 | PV = "01.01.01.06" | ||
11 | |||
12 | COMPATIBLE_MACHINE = "(tci6614-evm|keystone)" | ||
13 | DEPENDS = "cuia" | ||
14 | |||
15 | DEVICELIST = "" | ||
16 | DEVICELIST_append_tci6614-evm = "c6614" | ||
17 | DEVICELIST_append_keystone = "k2k k2h k2e k2l" | ||
18 | |||
19 | PACKAGES =+ "${PN}-test" | ||
20 | |||
21 | FILES_${PN}-test = "${bindir}/tfw*.out \ | ||
22 | ${bindir}/*.txt" | ||
23 | |||
24 | BASEDIR = "${WORKDIR}/git" | ||
25 | S = "${BASEDIR}/ti/instrumentation/traceframework" | ||
26 | |||
27 | EXTRA_OEMAKE += "-f makefile_armv7 PDK_INSTALL_PATH=${STAGING_INCDIR} \ | ||
28 | CUIA_INSTALL_DIR=${STAGING_INCDIR} CUIA_LIB_DIR=${STAGING_LIBDIR}" | ||
29 | |||
30 | do_compile () { | ||
31 | # making the library | ||
32 | oe_runmake clean | ||
33 | oe_runmake lib | ||
34 | |||
35 | # make the test application | ||
36 | for device in ${DEVICELIST} | ||
37 | do | ||
38 | oe_runmake tests DEVICE="$device" TFW_INC_DIR=${BASEDIR} TFW_SRC_DIR=${S} \ | ||
39 | TARGET_ROOT_DIR=${D} | ||
40 | done | ||
41 | } | ||
42 | |||
43 | do_install() { | ||
44 | for device in ${DEVICELIST} | ||
45 | do | ||
46 | oe_runmake install DEVICE="$device" TFW_SRC_DIR=${S} TARGET_ROOT_DIR=${D} | ||
47 | done | ||
48 | } | ||