diff options
author | Koen Kooi <koen@dominion.thruhere.net> | 2012-06-26 09:47:54 +0200 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2012-07-25 20:24:25 -0400 |
commit | 24ba2ae0857e9a2cd0221e33aa6e7888328db817 (patch) | |
tree | 3a3b8e925f45cc8e4fd34c63383922367a29b010 | |
parent | 189ce92b4c39c945c29c404e0b5ca5d366d3499e (diff) | |
download | meta-ti-24ba2ae0857e9a2cd0221e33aa6e7888328db817.tar.gz |
linux-ti33x-psp 3.2: fix audio/spidev clash on beaglebone
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r-- | recipes-kernel/linux/linux-ti33x-psp-3.2/beaglebone/0072-beaglebone-fix-audio-spi-clash.patch | 25 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-ti33x-psp_3.2.bb | 3 |
2 files changed, 27 insertions, 1 deletions
diff --git a/recipes-kernel/linux/linux-ti33x-psp-3.2/beaglebone/0072-beaglebone-fix-audio-spi-clash.patch b/recipes-kernel/linux/linux-ti33x-psp-3.2/beaglebone/0072-beaglebone-fix-audio-spi-clash.patch new file mode 100644 index 00000000..a916ad5a --- /dev/null +++ b/recipes-kernel/linux/linux-ti33x-psp-3.2/beaglebone/0072-beaglebone-fix-audio-spi-clash.patch | |||
@@ -0,0 +1,25 @@ | |||
1 | From 45ddec832968e3c1e31cf38a891372ba80027e2d Mon Sep 17 00:00:00 2001 | ||
2 | From: Koen Kooi <koen@dominion.thruhere.net> | ||
3 | Date: Tue, 26 Jun 2012 08:39:04 +0200 | ||
4 | Subject: [PATCH] beaglebone: fix audio/spi clash | ||
5 | |||
6 | Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> | ||
7 | --- | ||
8 | arch/arm/mach-omap2/board-am335xevm.c | 3 ++- | ||
9 | 1 file changed, 2 insertions(+), 1 deletion(-) | ||
10 | |||
11 | diff --git a/arch/arm/mach-omap2/board-am335xevm.c b/arch/arm/mach-omap2/board-am335xevm.c | ||
12 | index f6559b6..d0681a2 100644 | ||
13 | --- a/arch/arm/mach-omap2/board-am335xevm.c | ||
14 | +++ b/arch/arm/mach-omap2/board-am335xevm.c | ||
15 | @@ -2910,6 +2910,7 @@ static void beaglebone_cape_setup(struct memory_accessor *mem_acc, void *context | ||
16 | |||
17 | beaglebone_leds_free = 0; | ||
18 | dvileds_init(0,0); | ||
19 | + beaglebone_spi1_free = 0; | ||
20 | mcasp0_init(0,0); | ||
21 | |||
22 | if (!strncmp("00A1", cape_config.version, 4) || !strncmp("000A", cape_config.version, 4)) { | ||
23 | -- | ||
24 | 1.7.10 | ||
25 | |||
diff --git a/recipes-kernel/linux/linux-ti33x-psp_3.2.bb b/recipes-kernel/linux/linux-ti33x-psp_3.2.bb index 645d4dc6..ab42c442 100644 --- a/recipes-kernel/linux/linux-ti33x-psp_3.2.bb +++ b/recipes-kernel/linux/linux-ti33x-psp_3.2.bb | |||
@@ -15,7 +15,7 @@ PV = "${@base_contains('DISTRO_FEATURES', 'tipspkernel', "3.2", "3.2.21", d)}" | |||
15 | 15 | ||
16 | BRANCH = "v3.2-staging" | 16 | BRANCH = "v3.2-staging" |
17 | SRCREV = "720e07b4c1f687b61b147b31c698cb6816d72f01" | 17 | SRCREV = "720e07b4c1f687b61b147b31c698cb6816d72f01" |
18 | MACHINE_KERNEL_PR_append = "a+gitr${SRCREV}" | 18 | MACHINE_KERNEL_PR_append = "c+gitr${SRCREV}" |
19 | 19 | ||
20 | COMPATIBLE_MACHINE = "(ti33x)" | 20 | COMPATIBLE_MACHINE = "(ti33x)" |
21 | 21 | ||
@@ -1536,4 +1536,5 @@ PATCHES_OVER_PSP = " \ | |||
1536 | file://beaglebone/0069-beaglebone-add-support-for-LCD3-rev-A1.patch \ | 1536 | file://beaglebone/0069-beaglebone-add-support-for-LCD3-rev-A1.patch \ |
1537 | file://beaglebone/0070-beaglebone-fix-buttons-spidev-clash-when-using-mcasp.patch \ | 1537 | file://beaglebone/0070-beaglebone-fix-buttons-spidev-clash-when-using-mcasp.patch \ |
1538 | file://beaglebone/0071-beaglebone-fix-LCD3-led-key-overlap.patch \ | 1538 | file://beaglebone/0071-beaglebone-fix-LCD3-led-key-overlap.patch \ |
1539 | file://beaglebone/0072-beaglebone-fix-audio-spi-clash.patch \ | ||
1539 | " | 1540 | " |