summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@konsulko.com>2022-02-22 04:12:56 +0000
committerRyan Eatmon <reatmon@ti.com>2022-02-22 12:01:30 -0600
commit209da2791f911235faaf4104ebf289b0e11d975b (patch)
treec3813986956e92f2482f5fec5da34fccd654cbbb
parentea5b431bdac13759d1dab20a8d6e3d26a16a5501 (diff)
downloadmeta-ti-209da2791f911235faaf4104ebf289b0e11d975b.tar.gz
conf/machine: remove SoC/platforms in DaVinci and OMAP3/4 families
Those platforms are being deprecated and not supported in future meta-ti releases. Signed-off-by: Denys Dmytriyenko <denys@konsulko.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r--conf/machine/am3517-evm.conf35
-rw-r--r--conf/machine/am37x-evm.conf31
-rw-r--r--conf/machine/beagleboard.conf38
-rw-r--r--conf/machine/include/davinci.inc22
-rw-r--r--conf/machine/include/omap3.inc42
-rw-r--r--conf/machine/include/omap4.inc26
-rw-r--r--conf/machine/include/omapl137.inc5
-rw-r--r--conf/machine/lego-ev3.conf22
-rw-r--r--conf/machine/omap3evm.conf32
-rw-r--r--conf/machine/omap5-evm.conf34
-rw-r--r--conf/machine/omapl137-evm.conf15
-rw-r--r--conf/machine/pandaboard.conf16
-rw-r--r--recipes-bsp/powervr-drivers/ti-sgx-ddk-km_1.17.4948957.bb4
-rw-r--r--recipes-graphics/libgles/ti-sgx-ddk-um_1.17.4948957.bb4
-rw-r--r--recipes-ti/ipc/ti-ipc-common.inc1
-rw-r--r--recipes-ti/ipc/ti-ipc_git.bb1
16 files changed, 2 insertions, 326 deletions
diff --git a/conf/machine/am3517-evm.conf b/conf/machine/am3517-evm.conf
deleted file mode 100644
index f194c648..00000000
--- a/conf/machine/am3517-evm.conf
+++ /dev/null
@@ -1,35 +0,0 @@
1#@TYPE: Machine
2#@NAME: AM3517 EVM
3#@DESCRIPTION: Machine configuration for the TI Sitara AM3517 EVM
4
5require conf/machine/include/omap3.inc
6
7MACHINE_GUI_CLASS = "smallscreen"
8MACHINE_FEATURES += "touchscreen ethernet"
9
10IMAGE_FSTYPES += "ubi tar.xz"
11EXTRA_IMAGECMD:jffs2 = "-lnp -e 0x20000 -s 2048"
12
13SERIAL_CONSOLES = "115200;ttyS2"
14USE_VT = "2"
15
16KERNEL_DEVICETREE = "am3517-evm.dtb"
17
18UBOOT_MACHINE = "am3517_evm_config"
19XLOAD_MACHINE = "am3517evm_config"
20
21# NOTE: there are NAND and OneNAND versions of this board...
22# do ubiattach /dev/ubi_ctrl -m 4
23# From dmesg:
24# UBI: smallest flash I/O unit: 2048
25# UBI: logical eraseblock size: 129024 bytes
26# from ubiattach stdout:
27# UBI device number 0, total 1996 LEBs
28MKUBIFS_ARGS = "-m 2048 -e 129024 -c 1996"
29
30# do ubiattach /dev/ubi_ctrl -m 4
31# from dmesg:
32# UBI: smallest flash I/O unit: 2048
33# UBI: physical eraseblock size: 131072 bytes (128 KiB)
34# UBI: sub-page size: 512
35UBINIZE_ARGS = "-m 2048 -p 128KiB -s 512"
diff --git a/conf/machine/am37x-evm.conf b/conf/machine/am37x-evm.conf
deleted file mode 100644
index 9750fe64..00000000
--- a/conf/machine/am37x-evm.conf
+++ /dev/null
@@ -1,31 +0,0 @@
1#@TYPE: Machine
2#@NAME: AM37x EVM
3#@DESCRIPTION: Machine configuration for the TI AM37x EVM
4
5require conf/machine/include/omap3.inc
6
7MACHINE_GUI_CLASS = "smallscreen"
8MACHINE_FEATURES += "touchscreen ethernet"
9
10IMAGE_FSTYPES += "ubi tar.xz"
11EXTRA_IMAGECMD:jffs2 = "-lnp -e 0x20000 -s 2048"
12
13KERNEL_DEVICETREE = "omap3-evm-37xx.dtb"
14
15SERIAL_CONSOLES = "115200;ttyS0"
16
17# NOTE: there are NAND and OneNAND versions of this board...
18# do ubiattach /dev/ubi_ctrl -m 4
19# From dmesg:
20# UBI: smallest flash I/O unit: 2048
21# UBI: logical eraseblock size: 129024 bytes
22# from ubiattach stdout:
23# UBI device number 0, total 1996 LEBs
24MKUBIFS_ARGS = "-m 2048 -e 129024 -c 1996"
25
26# do ubiattach /dev/ubi_ctrl -m 4
27# from dmesg:
28# UBI: smallest flash I/O unit: 2048
29# UBI: physical eraseblock size: 131072 bytes (128 KiB)
30# UBI: sub-page size: 512
31UBINIZE_ARGS = "-m 2048 -p 128KiB -s 512"
diff --git a/conf/machine/beagleboard.conf b/conf/machine/beagleboard.conf
deleted file mode 100644
index 06777795..00000000
--- a/conf/machine/beagleboard.conf
+++ /dev/null
@@ -1,38 +0,0 @@
1#@TYPE: Machine
2#@NAME: Beagleboard machine
3#@DESCRIPTION: Machine configuration for the http://beagleboard.org/ board
4
5require conf/machine/include/omap3.inc
6
7# Only has DVI connector for external screen
8MACHINE_GUI_CLASS = "bigscreen"
9
10IMAGE_FSTYPES += "tar.xz ubi"
11EXTRA_IMAGECMD:jffs2 = "-lnp"
12
13KERNEL_DEVICETREE = "omap3-beagle.dtb omap3-beagle-xm.dtb omap3-beagle-xm-ab.dtb"
14
15SERIAL_CONSOLES = "115200;ttyS2"
16
17UBOOT_MACHINE = "omap3_beagle_config"
18
19# do ubiattach /dev/ubi_ctrl -m 4
20# From dmesg:
21# UBI: smallest flash I/O unit: 2048
22# UBI: logical eraseblock size: 129024 bytes
23# from ubiattach stdout:
24# UBI device number 0, total 1996 LEBs
25#
26# Beagleboard C5 has 3998 LEBS (490MiB)
27MKUBIFS_ARGS = "-m 2048 -e 129024 -c 1996"
28
29# do ubiattach /dev/ubi_ctrl -m 4
30# from dmesg:
31# UBI: smallest flash I/O unit: 2048
32# UBI: physical eraseblock size: 131072 bytes (128 KiB)
33# UBI: sub-page size: 512
34UBINIZE_ARGS = "-m 2048 -p 128KiB -s 512"
35
36# For a modularized kernel we want to drag in networking, sound, rtc etc."
37MACHINE_EXTRA_RRECOMMENDS = "kernel-module-smsc95xx kernel-module-snd-soc-twl4030 kernel-module-rtc-twl \
38 kernel-module-snd-soc-omap kernel-module-snd-soc-omap-mcbsp kernel-module-snd-soc-omap3beagle"
diff --git a/conf/machine/include/davinci.inc b/conf/machine/include/davinci.inc
deleted file mode 100644
index b8d207de..00000000
--- a/conf/machine/include/davinci.inc
+++ /dev/null
@@ -1,22 +0,0 @@
1require conf/machine/include/arm/armv5/tune-arm926ejs.inc
2
3# Increase this everytime you change something in the kernel
4MACHINE_KERNEL_PR = "r54"
5
6KERNEL_IMAGETYPE = "zImage"
7
8PREFERRED_PROVIDER_virtual/kernel ?= "linux-ti-staging"
9PREFERRED_PROVIDER_virtual/bootloader = "u-boot-ti-staging"
10PREFERRED_PROVIDER_u-boot = "u-boot-ti-staging"
11
12UBOOT_MACHINE = "davinci_dvevm_config"
13
14UBOOT_ENTRYPOINT = "0x80008000"
15UBOOT_LOADADDRESS = "0x80008000"
16
17EXTRA_IMAGEDEPENDS += "u-boot"
18
19SERIAL_CONSOLES ?= "115200;ttyS0"
20EXTRA_IMAGECMD:jffs2 = "--pad --little-endian --eraseblock=0x20000 -n"
21
22MACHINE_FEATURES = "kernel26 serial ethernet usbhost usbgadget mmc alsa"
diff --git a/conf/machine/include/omap3.inc b/conf/machine/include/omap3.inc
deleted file mode 100644
index 6e0d8dbc..00000000
--- a/conf/machine/include/omap3.inc
+++ /dev/null
@@ -1,42 +0,0 @@
1require conf/machine/include/ti-soc.inc
2SOC_FAMILY:append = ":omap3"
3
4DEFAULTTUNE ?= "armv7athf-neon"
5require conf/machine/include/arm/armv7a/tune-cortexa8.inc
6
7PREFERRED_PROVIDER_virtual/xserver = "xserver-xorg"
8
9# For built-in LCD, add xf86-input-tslib
10XSERVER = "xserver-xorg \
11 xf86-input-evdev \
12 xf86-input-mouse \
13 xf86-video-fbdev \
14 xf86-input-keyboard"
15
16# Default to external video, change to smallscreen for built-in LCD
17MACHINE_GUI_CLASS = "bigscreen"
18
19# Increase this everytime you change something in the kernel
20MACHINE_KERNEL_PR = "r127"
21
22KERNEL_IMAGETYPE = "zImage"
23
24# Default providers, may need to override for specific machines
25PREFERRED_PROVIDER_virtual/kernel ?= "linux-ti-staging"
26PREFERRED_PROVIDER_virtual/bootloader = "u-boot-ti-staging"
27PREFERRED_PROVIDER_u-boot = "u-boot-ti-staging"
28
29KERNEL_DEVICETREE = "omap3-beagle.dtb omap3-beagle-xm.dtb omap3-beagle-xm-ab.dtb omap3-evm.dtb omap3-evm-37xx.dtb am3517-evm.dtb"
30
31UBOOT_ARCH = "arm"
32UBOOT_MACHINE = "omap3_evm_config"
33XLOAD_MACHINE = "omap3evm_config"
34
35UBOOT_ENTRYPOINT = "0x80008000"
36UBOOT_LOADADDRESS = "0x80008000"
37
38# If SPL is not used, may need to add x-load
39EXTRA_IMAGEDEPENDS += "u-boot"
40
41# List common SoC features, may need to add touchscreen/ethernet for specific machines
42MACHINE_FEATURES = "kernel26 apm usbgadget usbhost vfat ext2 screen alsa gpu"
diff --git a/conf/machine/include/omap4.inc b/conf/machine/include/omap4.inc
deleted file mode 100644
index b8bd9d37..00000000
--- a/conf/machine/include/omap4.inc
+++ /dev/null
@@ -1,26 +0,0 @@
1require conf/machine/include/ti-soc.inc
2SOC_FAMILY:append = ":omap4"
3
4DEFAULTTUNE ?= "armv7athf-neon"
5require conf/machine/include/arm/armv7a/tune-cortexa9.inc
6
7PREFERRED_PROVIDER_virtual/kernel ?= "linux-ti-staging"
8PREFERRED_PROVIDER_virtual/bootloader = "u-boot-ti-staging"
9PREFERRED_PROVIDER_u-boot = "u-boot-ti-staging"
10
11PREFERRED_PROVIDER_virtual/xserver = "xserver-xorg"
12XSERVER = "xserver-xorg \
13 xf86-input-evdev \
14 xf86-video-fbdev"
15
16# Increase this everytime you change something in the kernel
17MACHINE_KERNEL_PR = "r4"
18
19KERNEL_IMAGETYPE = "zImage"
20
21UBOOT_MACHINE = "omap4_panda_config"
22
23UBOOT_ENTRYPOINT = "0x80008000"
24UBOOT_LOADADDRESS = "0x80008000"
25
26EXTRA_IMAGEDEPENDS += "u-boot"
diff --git a/conf/machine/include/omapl137.inc b/conf/machine/include/omapl137.inc
deleted file mode 100644
index 6dd49418..00000000
--- a/conf/machine/include/omapl137.inc
+++ /dev/null
@@ -1,5 +0,0 @@
1require conf/machine/include/omapl1.inc
2SOC_FAMILY:append = ":omapl137"
3
4# Set the list of device targets for ti-pdk class recipes
5TI_PDK_LIMIT_SOCS = "omapl137"
diff --git a/conf/machine/lego-ev3.conf b/conf/machine/lego-ev3.conf
deleted file mode 100644
index 5b89a6a7..00000000
--- a/conf/machine/lego-ev3.conf
+++ /dev/null
@@ -1,22 +0,0 @@
1#@TYPE: Machine
2#@NAME: LEGO Mindstorms EV3
3#@DESCRIPTION: Machine configuration for the LEGO Mindstorms EV3
4
5require conf/machine/include/davinci.inc
6require conf/machine/include/omapl138.inc
7
8UBOOT_MACHINE = "legoev3_config"
9UBOOT_SUFFIX = "bin"
10UBOOT_ENTRYPOINT = "0xC0008000"
11UBOOT_LOADADDRESS = "0xC0008000"
12SPL_BINARY = ""
13
14KERNEL_DEVICETREE = "da850-lego-ev3.dtb"
15KERNEL_IMAGETYPES = "uImage"
16KERNEL_DEVICETREE_BUNDLE = "1"
17SERIAL_CONSOLES = "115200;ttyS1"
18
19IMAGE_FSTYPES += " wic"
20WKS_FILE ?= "sdimage-bootpart.wks"
21WIC_CREATE_EXTRA_ARGS += " --no-fstab-update"
22IMAGE_BOOT_FILES = "${KERNEL_IMAGETYPES}"
diff --git a/conf/machine/omap3evm.conf b/conf/machine/omap3evm.conf
deleted file mode 100644
index dc56d57a..00000000
--- a/conf/machine/omap3evm.conf
+++ /dev/null
@@ -1,32 +0,0 @@
1#@TYPE: Machine
2#@NAME: OMAP3 EVM
3#@DESCRIPTION: Machine configuration for the TI OMAP3 EVM
4
5require conf/machine/include/omap3.inc
6
7MACHINE_GUI_CLASS = "smallscreen"
8MACHINE_FEATURES += "touchscreen ethernet"
9
10IMAGE_FSTYPES += "jffs2 tar.xz"
11EXTRA_IMAGECMD:jffs2 = "-lnp -e 0x20000 -s 2048"
12
13SERIAL_CONSOLES = "115200;ttyS0"
14USE_VT = "0"
15
16EXTRA_IMAGEDEPENDS += "x-load"
17
18# NOTE: there are NAND and OneNAND versions of this board...
19# do ubiattach /dev/ubi_ctrl -m 4
20# From dmesg:
21# UBI: smallest flash I/O unit: 2048
22# UBI: logical eraseblock size: 129024 bytes
23# from ubiattach stdout:
24# UBI device number 0, total 1996 LEBs
25MKUBIFS_ARGS = "-m 2048 -e 129024 -c 1996"
26
27# do ubiattach /dev/ubi_ctrl -m 4
28# from dmesg:
29# UBI: smallest flash I/O unit: 2048
30# UBI: physical eraseblock size: 131072 bytes (128 KiB)
31# UBI: sub-page size: 512
32UBINIZE_ARGS = "-m 2048 -p 128KiB -s 512"
diff --git a/conf/machine/omap5-evm.conf b/conf/machine/omap5-evm.conf
deleted file mode 100644
index b4cec1a2..00000000
--- a/conf/machine/omap5-evm.conf
+++ /dev/null
@@ -1,34 +0,0 @@
1#@TYPE: Machine
2#@NAME: OMAP5 EVM
3#@DESCRIPTION: Machine configuration for the TI OMAP5 uEVM
4
5require conf/machine/include/omap-a15.inc
6
7IMAGE_FSTYPES += "ubi tar.xz"
8
9KERNEL_DEVICETREE = "omap5-uevm.dtb"
10
11SERIAL_CONSOLES = "115200;ttyS2"
12
13# UBI information. Note that this is board and kernel specific. Changes
14# in your kernel port may require changes in these variables. For more
15# details about this board please see
16# http://processors.wiki.ti.com/index.php/UBIFS_Support
17
18# do ubiattach /dev/ubi_ctrl -m 7 -O 2048
19# From dmesg:
20# UBI: smallest flash I/O unit: 2048
21# UBI: logical eraseblock size: 126976 bytes
22# from ubiattach stdout:
23# UBI device number 0, total 1988 LEBs
24MKUBIFS_ARGS = "-F -m 2048 -e 126976 -c 4300"
25
26# do ubiattach /dev/ubi_ctrl -m 7 -O 2048
27# from dmesg:
28# UBI: smallest flash I/O unit: 2048
29# UBI: physical eraseblock size: 131072 bytes (128 KiB)
30# UBI: sub-page size: 512
31# UBI: VID header offset: 2048 (aligned 2048)
32UBINIZE_ARGS = "-m 2048 -p 128KiB -s 512 -O 2048"
33
34UBOOT_MACHINE = "omap5_uevm_config"
diff --git a/conf/machine/omapl137-evm.conf b/conf/machine/omapl137-evm.conf
deleted file mode 100644
index 207b213a..00000000
--- a/conf/machine/omapl137-evm.conf
+++ /dev/null
@@ -1,15 +0,0 @@
1#@TYPE: Machine
2#@NAME: OMAP-L137 EVM
3#@DESCRIPTION: Machine configuration for the TI OMAP-L137 EVM board
4
5require conf/machine/include/davinci.inc
6require conf/machine/include/omapl137.inc
7
8# HACK: The omapl137 family does not have linux kernel support.
9PREFERRED_PROVIDER_virtual/kernel ?= "linux-dummy"
10EXTRA_IMAGEDEPENDS = ""
11
12IMAGE_FSTYPES = "tar.xz"
13
14# Set the list of device targets for ti-pdk class recipes
15TI_PDK_LIMIT_BOARDS = "evmOMAPL137"
diff --git a/conf/machine/pandaboard.conf b/conf/machine/pandaboard.conf
deleted file mode 100644
index 4dd6fa29..00000000
--- a/conf/machine/pandaboard.conf
+++ /dev/null
@@ -1,16 +0,0 @@
1#@TYPE: Machine
2#@NAME: Pandaboard
3#@DESCRIPTION: Machine configuration for the OMAP4430 Panda
4
5require conf/machine/include/omap4.inc
6
7MACHINE_GUI_CLASS = "bigscreen"
8
9IMAGE_FSTYPES += "tar.xz"
10
11KERNEL_DEVICETREE = "omap4-panda.dtb omap4-panda-a4.dtb omap4-panda-es.dtb"
12
13SERIAL_CONSOLES = "115200;ttyS2"
14
15MACHINE_EXTRA_RRECOMMENDS = " kernel-modules"
16MACHINE_FEATURES = "kernel26 wifi bluetooth alsa apm ext2 screen usbgadget usbhost vfat gpu"
diff --git a/recipes-bsp/powervr-drivers/ti-sgx-ddk-km_1.17.4948957.bb b/recipes-bsp/powervr-drivers/ti-sgx-ddk-km_1.17.4948957.bb
index 5657408f..5fe6c201 100644
--- a/recipes-bsp/powervr-drivers/ti-sgx-ddk-km_1.17.4948957.bb
+++ b/recipes-bsp/powervr-drivers/ti-sgx-ddk-km_1.17.4948957.bb
@@ -7,7 +7,7 @@ inherit module features_check
7 7
8REQUIRED_MACHINE_FEATURES = "gpu" 8REQUIRED_MACHINE_FEATURES = "gpu"
9 9
10COMPATIBLE_MACHINE = "pandaboard|beagleboard|ti33x|ti43x|omap-a15|k3" 10COMPATIBLE_MACHINE = "ti33x|ti43x|omap-a15|k3"
11 11
12MACHINE_KERNEL_PR:append = "x" 12MACHINE_KERNEL_PR:append = "x"
13PR = "${MACHINE_KERNEL_PR}" 13PR = "${MACHINE_KERNEL_PR}"
@@ -30,8 +30,6 @@ TARGET_PRODUCT:omap-a15 = "jacinto6evm"
30TARGET_PRODUCT:ti33x = "ti335x" 30TARGET_PRODUCT:ti33x = "ti335x"
31TARGET_PRODUCT:ti43x = "ti437x" 31TARGET_PRODUCT:ti43x = "ti437x"
32TARGET_PRODUCT:k3 = "ti654x" 32TARGET_PRODUCT:k3 = "ti654x"
33TARGET_PRODUCT:beagleboard = "ti343x"
34TARGET_PRODUCT:pandaboard = "ti443x"
35 33
36EXTRA_OEMAKE += 'KERNELDIR="${STAGING_KERNEL_DIR}" TARGET_PRODUCT=${TARGET_PRODUCT} WINDOW_SYSTEM=nulldrmws' 34EXTRA_OEMAKE += 'KERNELDIR="${STAGING_KERNEL_DIR}" TARGET_PRODUCT=${TARGET_PRODUCT} WINDOW_SYSTEM=nulldrmws'
37 35
diff --git a/recipes-graphics/libgles/ti-sgx-ddk-um_1.17.4948957.bb b/recipes-graphics/libgles/ti-sgx-ddk-um_1.17.4948957.bb
index 9d55122c..d4b7a1a6 100644
--- a/recipes-graphics/libgles/ti-sgx-ddk-um_1.17.4948957.bb
+++ b/recipes-graphics/libgles/ti-sgx-ddk-um_1.17.4948957.bb
@@ -8,7 +8,7 @@ inherit features_check
8REQUIRED_MACHINE_FEATURES = "gpu" 8REQUIRED_MACHINE_FEATURES = "gpu"
9 9
10PACKAGE_ARCH = "${MACHINE_ARCH}" 10PACKAGE_ARCH = "${MACHINE_ARCH}"
11COMPATIBLE_MACHINE = "pandaboard|beagleboard|ti33x|ti43x|omap-a15|k3" 11COMPATIBLE_MACHINE = "ti33x|ti43x|omap-a15|k3"
12 12
13PR = "r37" 13PR = "r37"
14 14
@@ -21,8 +21,6 @@ TARGET_PRODUCT:omap-a15 = "jacinto6evm"
21TARGET_PRODUCT:ti33x = "ti335x" 21TARGET_PRODUCT:ti33x = "ti335x"
22TARGET_PRODUCT:ti43x = "ti437x" 22TARGET_PRODUCT:ti43x = "ti437x"
23TARGET_PRODUCT:k3 = "ti654x" 23TARGET_PRODUCT:k3 = "ti654x"
24TARGET_PRODUCT:beagleboard = "ti343x"
25TARGET_PRODUCT:pandaboard = "ti443x"
26 24
27INITSCRIPT_NAME = "rc.pvr" 25INITSCRIPT_NAME = "rc.pvr"
28INITSCRIPT_PARAMS = "defaults 8" 26INITSCRIPT_PARAMS = "defaults 8"
diff --git a/recipes-ti/ipc/ti-ipc-common.inc b/recipes-ti/ipc/ti-ipc-common.inc
index a32aad09..1879a3f2 100644
--- a/recipes-ti/ipc/ti-ipc-common.inc
+++ b/recipes-ti/ipc/ti-ipc-common.inc
@@ -6,7 +6,6 @@ COMPATIBLE_HOST ?= "null"
6COMPATIBLE_HOST:ti-soc = "(.*)" 6COMPATIBLE_HOST:ti-soc = "(.*)"
7 7
8PLATFORM = "UNKNOWN" 8PLATFORM = "UNKNOWN"
9PLATFORM:omap5-evm = "OMAP54XX"
10PLATFORM:dra7xx = "DRA7XX" 9PLATFORM:dra7xx = "DRA7XX"
11PLATFORM:k2hk = "TCI6638" 10PLATFORM:k2hk = "TCI6638"
12PLATFORM:k2l = "TCI6630" 11PLATFORM:k2l = "TCI6630"
diff --git a/recipes-ti/ipc/ti-ipc_git.bb b/recipes-ti/ipc/ti-ipc_git.bb
index c3a58472..ed712bab 100644
--- a/recipes-ti/ipc/ti-ipc_git.bb
+++ b/recipes-ti/ipc/ti-ipc_git.bb
@@ -15,7 +15,6 @@ SRC_URI += "file://tiipclad-daemon.sh \
15 " 15 "
16 16
17DAEMON = "UNKNOWN" 17DAEMON = "UNKNOWN"
18DAEMON:omap5-evm = "lad_omap54xx_smp"
19DAEMON:dra7xx = "lad_dra7xx" 18DAEMON:dra7xx = "lad_dra7xx"
20DAEMON:k2hk = "lad_tci6638" 19DAEMON:k2hk = "lad_tci6638"
21DAEMON:k2l = "lad_tci6630" 20DAEMON:k2l = "lad_tci6630"