summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2016-12-10 03:48:17 +0000
committerDenys Dmytriyenko <denys@ti.com>2016-12-09 17:25:48 -0500
commit1c08c3ecb9161541b0d24adc32e3ff2b0c8ab74b (patch)
treefc3cbcfe6f366e1f30168ea5199ceeb41136c52f
parent243fc8275e58b720d27e24b10473b02f8a99e73f (diff)
downloadmeta-ti-1c08c3ecb9161541b0d24adc32e3ff2b0c8ab74b.tar.gz
goodix-fw: add Goodix GT9271 config firmware
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-bsp/goodix-fw/goodix-fw_git.bb29
-rw-r--r--recipes-kernel/linux/linux-ti-staging_4.4.bb9
2 files changed, 34 insertions, 4 deletions
diff --git a/recipes-bsp/goodix-fw/goodix-fw_git.bb b/recipes-bsp/goodix-fw/goodix-fw_git.bb
new file mode 100644
index 00000000..815466b7
--- /dev/null
+++ b/recipes-bsp/goodix-fw/goodix-fw_git.bb
@@ -0,0 +1,29 @@
1DESCRIPTION = "Goodix GT9271 config firmware"
2
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENCE.Spectrum-GT9271;md5=2a6de6be7af1fe46370c684daf27c852"
5
6PV = "1.0.0.0"
7PR = "r0"
8
9CLEANBROKEN = "1"
10
11COMPATIBLE_MACHINE = "dra7xx"
12
13PACKAGE_ARCH = "${MACHINE_ARCH}"
14
15SRCREV = "f1a8d1d0131f83bd1a775cde7075eb67c070892c"
16BRANCH ?= "ti-linux-firmware-4.1.y"
17
18SRC_URI = "git://git.ti.com/processor-firmware/ti-linux-firmware.git;protocol=git;branch=${BRANCH}"
19
20S = "${WORKDIR}/git"
21ORIGIN = "DRA71x-RevA-GT9271_SpecDig_Config.bin"
22TARGET = "goodix_9271_cfg.bin"
23
24do_install() {
25 install -d ${D}${base_libdir}/firmware
26 install -m 0644 ${S}/ti-evm/${ORIGIN} ${D}${base_libdir}/firmware/${TARGET}
27}
28
29FILES_${PN} = "${base_libdir}/firmware"
diff --git a/recipes-kernel/linux/linux-ti-staging_4.4.bb b/recipes-kernel/linux/linux-ti-staging_4.4.bb
index 92ef5eb2..d1abdc99 100644
--- a/recipes-kernel/linux/linux-ti-staging_4.4.bb
+++ b/recipes-kernel/linux/linux-ti-staging_4.4.bb
@@ -16,15 +16,16 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}-4.4:"
16# Pull in the devicetree files into the rootfs 16# Pull in the devicetree files into the rootfs
17RDEPENDS_kernel-base += "kernel-devicetree" 17RDEPENDS_kernel-base += "kernel-devicetree"
18 18
19# Add a run-time dependency for the PM firmware to be installed 19# Add run-time dependency for PM firmware to the rootfs
20# on the target file system.
21RDEPENDS_kernel-base_append_ti33x = " amx3-cm3" 20RDEPENDS_kernel-base_append_ti33x = " amx3-cm3"
22RDEPENDS_kernel-base_append_ti43x = " amx3-cm3" 21RDEPENDS_kernel-base_append_ti43x = " amx3-cm3"
23 22
24# Add a run-time dependency for the VPE VPDMA firmware to be installed 23# Add run-time dependency for VPE VPDMA firmware to the rootfs
25# on the target file system.
26RDEPENDS_kernel-base_append_dra7xx = " vpdma-fw" 24RDEPENDS_kernel-base_append_dra7xx = " vpdma-fw"
27 25
26# Add run-time dependency for Goodix firmware to the rootfs
27RDEPENDS_kernel-base_append_dra7xx = " goodix-fw"
28
28# Install boot-monitor skern file into /boot dir of rootfs 29# Install boot-monitor skern file into /boot dir of rootfs
29RDEPENDS_kernel-base_append_keystone = " boot-monitor" 30RDEPENDS_kernel-base_append_keystone = " boot-monitor"
30 31