summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSam Nelson <sam.nelson@ti.com>2015-01-08 09:01:02 +0000
committerDenys Dmytriyenko <denys@ti.com>2015-01-08 12:00:00 -0500
commit12691b5868fae14dc9f2668e4df4c177177c3c74 (patch)
tree2b0a3fec0020d7f98338adeae859be6347c15e8e
parentb195119dc2331ba75d92e54b2ae91c7288b4ee7f (diff)
downloadmeta-ti-12691b5868fae14dc9f2668e4df4c177177c3c74.tar.gz
pktlib: Adds recipe for pklib component
- pktlib: provides library for handling packet descriptor for keystone devices Signed-off-by: Sam Nelson <sam.nelson@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-bsp/pktlib/pktlib_git.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes-bsp/pktlib/pktlib_git.bb b/recipes-bsp/pktlib/pktlib_git.bb
new file mode 100644
index 00000000..df68f762
--- /dev/null
+++ b/recipes-bsp/pktlib/pktlib_git.bb
@@ -0,0 +1,19 @@
1DESCRIPTION = "Provides library for handling packet descriptors for keystone devices"
2LICENSE = "BSD-3-Clause"
3LIC_FILES_CHKSUM = "file://${WORKDIR}/git/COPYING.txt;md5=b7982a377c680ad71ca2fbb735982462"
4
5DEPENDS = "common-csl-ip rm-lld qmss-lld cppi-lld"
6COMPATIBLE_MACHINE = "keystone"
7
8BRANCH = "master"
9SRC_URI = "git://git.ti.com/keystone-rtos/pktlib.git;protocol=git;branch=${BRANCH}"
10
11# Corresponds to DEV.PKTLIB.2.1.0.4
12SRCREV = "a9aa56afed54b0a04f36d2fdb248cad5dcac6ff6"
13PV = "2.1.0.4"
14
15S = "${WORKDIR}/git/ti/runtime/pktlib"
16
17EXTRA_OEMAKE += "-f make=file_armv7 PDK_INSTALL_PATH=${STAGING_INCDIR} INSTALL_INC_BASE_DIR=${D}${includedir} INSTALL_LIB_BASE_DIR=${D}${libdir}"
18
19MAKE_TARGETS = "lib"