summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRyan Eatmon <reatmon@ti.com>2024-01-22 14:19:06 -0600
committerRyan Eatmon <reatmon@ti.com>2024-01-22 14:49:15 -0600
commit04c2204c11cb3ee5eee84f2d213037b763954786 (patch)
tree27d7f019ef7f20970ca70cd68f30e22f85ebf71f
parent1cbf96ebb2c48c0377bee2ed94f0862312683d63 (diff)
downloadmeta-ti-04c2204c11cb3ee5eee84f2d213037b763954786.tar.gz
python3-yamllint: Temporarily carry this new recipe
Add recipe for yamllint. There is an upcoming change in u-boot where the binman tool is now configured to call yamllint to verify the configs during compile time. There was a previous patch a year ago from Trevor Woerner that never made it into oe-core. This patch is a reworking of his patch but pointing to a newer version. We are waiting on this patch to be accepted in oe-core. Once it is available on master we will remove this recipe to avoid conflict. Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r--meta-ti-extras/recipes-devtools/python-yamllint/python3-yamllint_1.33.0.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-ti-extras/recipes-devtools/python-yamllint/python3-yamllint_1.33.0.bb b/meta-ti-extras/recipes-devtools/python-yamllint/python3-yamllint_1.33.0.bb
new file mode 100644
index 00000000..4b7bd065
--- /dev/null
+++ b/meta-ti-extras/recipes-devtools/python-yamllint/python3-yamllint_1.33.0.bb
@@ -0,0 +1,15 @@
1SUMMARY = "A linter for YAML files."
2HOMEPAGE = "https://github.com/adrienverge/yamllint"
3LICENSE = "GPL-3.0-only"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=1ebbd3e34237af26da5dc08a4e440464"
5
6inherit pypi setuptools3
7
8PYPI_PACKAGE = "yamllint"
9
10SRC_URI[sha256sum] = "2dceab9ef2d99518a2fcf4ffc964d44250ac4459be1ba3ca315118e4a1a81f7d"
11
12DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
13RDEPENDS:${PN} += "${PYTHON_PN}-pyyaml"
14
15BBCLASSEXTEND = "native nativesdk"