summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRandolph Sapp <rs@ti.com>2023-08-21 20:11:38 -0500
committerRyan Eatmon <reatmon@ti.com>2023-09-12 12:53:08 -0500
commit0271f0a9bc355abcea41ea06be9fddc598a0d7d1 (patch)
treefc5f36abd49845484b050738ae936a6091036993
parentc3916324a01fe96c68a78ef9ed0070d6b1fc8f2f (diff)
downloadmeta-ti-0271f0a9bc355abcea41ea06be9fddc598a0d7d1.tar.gz
mesa-pvr: add dynamic-layer append for llvmpipe
Meta-clang provides a bbappend for mesa to use clang to accelerate it's rasterization with runtime code generation through the use of llvmpipe. With the addition of mesa-pvr we no longer get this for free with the blanket mesa bbappend on the devices that explicitly request mesa-pvr so lets add a dynamic layer to append the same args meta-clang does. Though the number of devices that would select pvr-mesa and still want to use software rendering is small, it's not zero due to debug and testing purposes. Signed-off-by: Randolph Sapp <rs@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r--meta-ti-bsp/conf/layer.conf4
-rw-r--r--meta-ti-bsp/dynamic-layers/clang-layer/recipes-graphics/mesa/mesa-pvr_%.bbappend14
2 files changed, 18 insertions, 0 deletions
diff --git a/meta-ti-bsp/conf/layer.conf b/meta-ti-bsp/conf/layer.conf
index 26cbb4b5..56ca392b 100644
--- a/meta-ti-bsp/conf/layer.conf
+++ b/meta-ti-bsp/conf/layer.conf
@@ -18,6 +18,10 @@ LAYERDEPENDS_meta-ti-bsp = " \
18 meta-arm \ 18 meta-arm \
19" 19"
20 20
21BBFILES_DYNAMIC += " \
22 clang-layer:${LAYERDIR}/dynamic-layers/clang-layer/recipes*/*/*.bbappend \
23"
24
21SIGGEN_EXCLUDERECIPES_ABISAFE += " \ 25SIGGEN_EXCLUDERECIPES_ABISAFE += " \
22 mesa-pvr \ 26 mesa-pvr \
23" 27"
diff --git a/meta-ti-bsp/dynamic-layers/clang-layer/recipes-graphics/mesa/mesa-pvr_%.bbappend b/meta-ti-bsp/dynamic-layers/clang-layer/recipes-graphics/mesa/mesa-pvr_%.bbappend
new file mode 100644
index 00000000..7e5c36fd
--- /dev/null
+++ b/meta-ti-bsp/dynamic-layers/clang-layer/recipes-graphics/mesa/mesa-pvr_%.bbappend
@@ -0,0 +1,14 @@
1# This is a copy of meta-clang/recipes-graphics/mesa/mesa_%.bbappend required
2# for llvmpipe when using pvr-mesa since we aren't caught by that glob.
3
4FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
5
6LDFLAGS:append:toolchain-clang = " -latomic -lm"
7DEPENDS:append:toolchain-clang = " libatomic-ops"
8
9EXTRA_OEMASON:append:toolchain-clang:x86 = " -Dasm=false"
10EXTRA_OEMASON:append:toolchain-clang:x86-64 = " -Dasm=false"
11
12export YOCTO_ALTERNATE_EXE_PATH = "${STAGING_LIBDIR}/llvm-config"
13
14PACKAGECONFIG[gallium-llvm] = "-Dllvm=true -Dshared-llvm=true -Ddraw-use-llvm=true,-Dllvm=false,clang clang-native elfutils"