summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSam Nelson <sam.nelson@ti.com>2015-09-01 07:34:54 +0000
committerDenys Dmytriyenko <denys@ti.com>2015-09-02 09:44:59 -0400
commit090b02a104924886afd0fa79be7b5d08eebf071f (patch)
tree4e1e12a61d80a9e92759c7d6a4a844b37cec67f8
parent3ba05c758e14eb58056735c0daca6bf00610c02a (diff)
downloadmeta-ti-daisy.tar.gz
uio-module-drv: Update to new version 1.0.2.3daisy
- Also add test code recipe for uio-module-drv - Common part of recipe moved to uio-module-drv.inc Signed-off-by: Sam Nelson <sam.nelson@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-bsp/uio-module-drv/uio-module-drv-test_git.bb16
-rw-r--r--recipes-bsp/uio-module-drv/uio-module-drv.inc10
-rw-r--r--recipes-bsp/uio-module-drv/uio-module-drv_git.bb13
3 files changed, 28 insertions, 11 deletions
diff --git a/recipes-bsp/uio-module-drv/uio-module-drv-test_git.bb b/recipes-bsp/uio-module-drv/uio-module-drv-test_git.bb
new file mode 100644
index 00000000..1080a916
--- /dev/null
+++ b/recipes-bsp/uio-module-drv/uio-module-drv-test_git.bb
@@ -0,0 +1,16 @@
1DESCRIPTION = "Test code for user space IO (UIO) driver"
2
3include uio-module-drv.inc
4PV = "1.0.2.3"
5
6COMPATIBLE_MACHINE = "keystone"
7RDEPENDS_${PN} = "uio-module-drv"
8
9do_compile() {
10 oe_runmake -C ${S} test
11}
12
13do_install() {
14 install -d ${D}${bindir}/
15 install -c -m 755 ${S}/test/uio_cic2_int_multithread_test ${D}${bindir}/.
16}
diff --git a/recipes-bsp/uio-module-drv/uio-module-drv.inc b/recipes-bsp/uio-module-drv/uio-module-drv.inc
new file mode 100644
index 00000000..567f7f65
--- /dev/null
+++ b/recipes-bsp/uio-module-drv/uio-module-drv.inc
@@ -0,0 +1,10 @@
1LICENSE = "BSD"
2LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=2b7c96eb2aed7b0f6f922214dbde9016"
3
4BRANCH = "master"
5# This corresponds to version 01.00.02.03
6SRCREV = "634a0c64763c5cd7840e2d439d0ee900455584c8"
7
8SRC_URI = "git://git.ti.com/keystone-linux/uio-module-drv.git;protocol=git;branch=${BRANCH}"
9
10S = "${WORKDIR}/git"
diff --git a/recipes-bsp/uio-module-drv/uio-module-drv_git.bb b/recipes-bsp/uio-module-drv/uio-module-drv_git.bb
index b2475278..d75fda2c 100644
--- a/recipes-bsp/uio-module-drv/uio-module-drv_git.bb
+++ b/recipes-bsp/uio-module-drv/uio-module-drv_git.bb
@@ -1,21 +1,12 @@
1DESCRIPTION="User space IO (UIO) driver for on-chip modules" 1DESCRIPTION="User space IO (UIO) driver for on-chip modules"
2 2
3LICENSE = "BSD" 3include uio-module-drv.inc
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=2b7c96eb2aed7b0f6f922214dbde9016" 4PV = "1.0.2.3+git${SRCPV}"
5
6BRANCH ?= "master"
7# This corresponds to version 01.00.02.01
8SRCREV = "c1988446e3364af4df7cd877e6536f0c6647d7bb"
9PV = "1.0.2.1+git${SRCPV}"
10
11SRC_URI = "git://git.ti.com/keystone-linux/uio-module-drv.git;protocol=git;branch=${BRANCH}"
12 5
13# This package builds a kernel module, use kernel PR as base and append a local 6# This package builds a kernel module, use kernel PR as base and append a local
14MACHINE_KERNEL_PR_append = "b" 7MACHINE_KERNEL_PR_append = "b"
15PR = "${MACHINE_KERNEL_PR}" 8PR = "${MACHINE_KERNEL_PR}"
16 9
17S = "${WORKDIR}/git"
18
19module_auto_load_uio-module-drv = "uio-module-drv" 10module_auto_load_uio-module-drv = "uio-module-drv"
20 11
21inherit module 12inherit module