summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@konsulko.com>2023-10-23 22:38:16 +0000
committerRyan Eatmon <reatmon@ti.com>2023-10-24 09:56:09 -0500
commitef80a01ba0294d9f9c045c252ecef7883198b0cb (patch)
tree4a58ab244750ce026fa65cbb1660a827e37ae0bc
parent2749107fb3951a49a9afdfb1fecbdb74177f5ecb (diff)
downloadmeta-ti-cicd.master.202310260100.tar.gz
conf: machine: move RDEPENDS and RRECOMMENDS from kernel-rdepends.inccicd.master.202310260100cicd.master.202310250100
Instead of making kernel RDEPENDS on devicetree and different FW images with lots of machine-override appends that are hard to modify downstream, use proper MACHINE_ESSENTIAL_EXTRA_RDEPENDS and MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS vars that are specifically designed for this purpose. This also makes such dependencies generic and not tied to a particular kernel recipe including kernel-rdepends.inc with the entire machine-specific list. Signed-off-by: Denys Dmytriyenko <denys@konsulko.com> Acked-by: Andrew Davis <afd@ti.com> Acked-by: Ryan Eatmon <reatmon@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r--meta-ti-bsp/conf/machine/am65xx-evm.conf2
-rw-r--r--meta-ti-bsp/conf/machine/beagle-x15.conf2
-rw-r--r--meta-ti-bsp/conf/machine/beaglebone-ai64.conf4
-rw-r--r--meta-ti-bsp/conf/machine/beaglebone.conf4
-rw-r--r--meta-ti-bsp/conf/machine/beagleplay.conf4
-rw-r--r--meta-ti-bsp/conf/machine/include/am57xx.inc2
-rw-r--r--meta-ti-bsp/conf/machine/include/am62axx.inc2
-rw-r--r--meta-ti-bsp/conf/machine/include/am64xx.inc2
-rw-r--r--meta-ti-bsp/conf/machine/include/am65xx.inc2
-rw-r--r--meta-ti-bsp/conf/machine/include/j7200.inc2
-rw-r--r--meta-ti-bsp/conf/machine/include/j721e.inc2
-rw-r--r--meta-ti-bsp/conf/machine/include/j721s2.inc2
-rw-r--r--meta-ti-bsp/conf/machine/include/j784s4.inc2
-rw-r--r--meta-ti-bsp/conf/machine/include/k3.inc2
-rw-r--r--meta-ti-bsp/conf/machine/include/omap-a15.inc4
-rw-r--r--meta-ti-bsp/conf/machine/include/omapl138.inc2
-rw-r--r--meta-ti-bsp/conf/machine/include/ti-soc.inc4
-rw-r--r--meta-ti-bsp/conf/machine/include/ti33x.inc4
-rw-r--r--meta-ti-bsp/conf/machine/include/ti43x.inc6
-rw-r--r--meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc38
-rw-r--r--meta-ti-bsp/recipes-kernel/linux/linux-ti-mainline_git.bb1
-rw-r--r--meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_5.10.bb1
-rw-r--r--meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_6.1.bb1
23 files changed, 39 insertions, 56 deletions
diff --git a/meta-ti-bsp/conf/machine/am65xx-evm.conf b/meta-ti-bsp/conf/machine/am65xx-evm.conf
index 8b6ef546..f6eb6f0c 100644
--- a/meta-ti-bsp/conf/machine/am65xx-evm.conf
+++ b/meta-ti-bsp/conf/machine/am65xx-evm.conf
@@ -5,3 +5,5 @@
5require conf/machine/include/am65xx.inc 5require conf/machine/include/am65xx.inc
6 6
7UBOOT_MACHINE = "am65x_evm_a53_defconfig" 7UBOOT_MACHINE = "am65x_evm_a53_defconfig"
8
9MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS += "prueth-fw-am65x-sr2 pruhsr-fw-am65x-sr2 prusw-fw-am65x-sr2"
diff --git a/meta-ti-bsp/conf/machine/beagle-x15.conf b/meta-ti-bsp/conf/machine/beagle-x15.conf
index 3b857165..be27705c 100644
--- a/meta-ti-bsp/conf/machine/beagle-x15.conf
+++ b/meta-ti-bsp/conf/machine/beagle-x15.conf
@@ -19,5 +19,3 @@ MACHINE_GUI_CLASS = "bigscreen"
19SERIAL_CONSOLES = "115200;ttyS2" 19SERIAL_CONSOLES = "115200;ttyS2"
20 20
21UBOOT_MACHINE = "am57xx_evm_config" 21UBOOT_MACHINE = "am57xx_evm_config"
22
23MACHINE_ESSENTIAL_EXTRA_RDEPENDS += "kernel-devicetree kernel-image-zimage"
diff --git a/meta-ti-bsp/conf/machine/beaglebone-ai64.conf b/meta-ti-bsp/conf/machine/beaglebone-ai64.conf
index 3f5a027e..e529f565 100644
--- a/meta-ti-bsp/conf/machine/beaglebone-ai64.conf
+++ b/meta-ti-bsp/conf/machine/beaglebone-ai64.conf
@@ -24,7 +24,3 @@ ti/k3-j721e-sk.dtb \
24" 24"
25 25
26MACHINE_GUI_CLASS = "bigscreen" 26MACHINE_GUI_CLASS = "bigscreen"
27
28MACHINE_ESSENTIAL_EXTRA_RDEPENDS += "kernel-devicetree kernel-image-image"
29
30MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS += "cadence-mhdp-fw vxd-dec-fw"
diff --git a/meta-ti-bsp/conf/machine/beaglebone.conf b/meta-ti-bsp/conf/machine/beaglebone.conf
index 45944ce8..d9353e9b 100644
--- a/meta-ti-bsp/conf/machine/beaglebone.conf
+++ b/meta-ti-bsp/conf/machine/beaglebone.conf
@@ -21,7 +21,3 @@ MACHINE_GUI_CLASS = "bigscreen"
21MACHINE_FEATURES += "screen" 21MACHINE_FEATURES += "screen"
22 22
23SERIAL_CONSOLES = "115200;ttyS0" 23SERIAL_CONSOLES = "115200;ttyS0"
24
25MACHINE_ESSENTIAL_EXTRA_RDEPENDS += "kernel-devicetree kernel-image-zimage"
26
27MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS += "amx3-cm3"
diff --git a/meta-ti-bsp/conf/machine/beagleplay.conf b/meta-ti-bsp/conf/machine/beagleplay.conf
index 4dd550a1..978bbc5a 100644
--- a/meta-ti-bsp/conf/machine/beagleplay.conf
+++ b/meta-ti-bsp/conf/machine/beagleplay.conf
@@ -42,7 +42,3 @@ ti/k3-am625-sk-rpi-hdr-pwm.dtbo \
42" 42"
43 43
44MACHINE_GUI_CLASS = "bigscreen" 44MACHINE_GUI_CLASS = "bigscreen"
45
46MACHINE_ESSENTIAL_EXTRA_RDEPENDS += "kernel-devicetree kernel-image-image"
47
48MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS += ""
diff --git a/meta-ti-bsp/conf/machine/include/am57xx.inc b/meta-ti-bsp/conf/machine/include/am57xx.inc
index 6c52883b..85290924 100644
--- a/meta-ti-bsp/conf/machine/include/am57xx.inc
+++ b/meta-ti-bsp/conf/machine/include/am57xx.inc
@@ -3,3 +3,5 @@ SOC_FAMILY:append = ":dra7xx"
3SOC_FAMILY:append = ":am57xx" 3SOC_FAMILY:append = ":am57xx"
4 4
5MACHINE_FEATURES += "pci" 5MACHINE_FEATURES += "pci"
6
7MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS += "prueth-fw prusw-fw pruhsr-fw pruprp-fw"
diff --git a/meta-ti-bsp/conf/machine/include/am62axx.inc b/meta-ti-bsp/conf/machine/include/am62axx.inc
index 12889057..93a41d8d 100644
--- a/meta-ti-bsp/conf/machine/include/am62axx.inc
+++ b/meta-ti-bsp/conf/machine/include/am62axx.inc
@@ -16,3 +16,5 @@ IMAGE_BOOT_FILES += "tiboot3-am62ax-hs-evm.bin"
16 16
17TFA_BOARD = "lite" 17TFA_BOARD = "lite"
18OPTEEMACHINE = "k3-am62x" 18OPTEEMACHINE = "k3-am62x"
19
20MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS += "cnm-wave-fw"
diff --git a/meta-ti-bsp/conf/machine/include/am64xx.inc b/meta-ti-bsp/conf/machine/include/am64xx.inc
index 9112b78b..85652eef 100644
--- a/meta-ti-bsp/conf/machine/include/am64xx.inc
+++ b/meta-ti-bsp/conf/machine/include/am64xx.inc
@@ -20,3 +20,5 @@ IMAGE_BOOT_FILES += "tiboot3-am64x_sr2-hs-evm.bin"
20TFA_BOARD = "lite" 20TFA_BOARD = "lite"
21 21
22OPTEEMACHINE = "k3-am64x" 22OPTEEMACHINE = "k3-am64x"
23
24MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS += "prueth-fw-am65x-sr2 pruhsr-fw-am65x-sr2 prusw-fw-am65x-sr2"
diff --git a/meta-ti-bsp/conf/machine/include/am65xx.inc b/meta-ti-bsp/conf/machine/include/am65xx.inc
index 2c427b88..7c9d5fb1 100644
--- a/meta-ti-bsp/conf/machine/include/am65xx.inc
+++ b/meta-ti-bsp/conf/machine/include/am65xx.inc
@@ -25,3 +25,5 @@ IMAGE_BOOT_FILES += "sysfw-am65x_sr2-hs-evm.itb"
25TFA_BOARD = "generic" 25TFA_BOARD = "generic"
26 26
27OPTEEMACHINE = "k3-am65x" 27OPTEEMACHINE = "k3-am65x"
28
29MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS += "prueth-fw-am65x"
diff --git a/meta-ti-bsp/conf/machine/include/j7200.inc b/meta-ti-bsp/conf/machine/include/j7200.inc
index d21e26cc..f23e70cd 100644
--- a/meta-ti-bsp/conf/machine/include/j7200.inc
+++ b/meta-ti-bsp/conf/machine/include/j7200.inc
@@ -4,3 +4,5 @@ SOC_FAMILY:append = ":j7200"
4TFA_BOARD = "generic" 4TFA_BOARD = "generic"
5 5
6OPTEEMACHINE = "k3-j721e" 6OPTEEMACHINE = "k3-j721e"
7
8MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS += "ti-eth-fw"
diff --git a/meta-ti-bsp/conf/machine/include/j721e.inc b/meta-ti-bsp/conf/machine/include/j721e.inc
index ca653770..92235527 100644
--- a/meta-ti-bsp/conf/machine/include/j721e.inc
+++ b/meta-ti-bsp/conf/machine/include/j721e.inc
@@ -23,3 +23,5 @@ IMAGE_BOOT_FILES += "sysfw-j721e_sr1_1-hs-evm.itb"
23TFA_BOARD = "generic" 23TFA_BOARD = "generic"
24 24
25OPTEEMACHINE = "k3-j721e" 25OPTEEMACHINE = "k3-j721e"
26
27MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS += "cadence-mhdp-fw vxd-dec-fw ti-eth-fw"
diff --git a/meta-ti-bsp/conf/machine/include/j721s2.inc b/meta-ti-bsp/conf/machine/include/j721s2.inc
index 98cc611f..cc58fb89 100644
--- a/meta-ti-bsp/conf/machine/include/j721s2.inc
+++ b/meta-ti-bsp/conf/machine/include/j721s2.inc
@@ -9,3 +9,5 @@ PREFERRED_PROVIDER_virtual/gpudriver ?= "ti-img-rogue-driver"
9TFA_BOARD = "generic" 9TFA_BOARD = "generic"
10 10
11OPTEEMACHINE = "k3-j784s4" 11OPTEEMACHINE = "k3-j784s4"
12
13MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS += "cadence-mhdp-fw cnm-wave-fw"
diff --git a/meta-ti-bsp/conf/machine/include/j784s4.inc b/meta-ti-bsp/conf/machine/include/j784s4.inc
index de207687..d4cf876b 100644
--- a/meta-ti-bsp/conf/machine/include/j784s4.inc
+++ b/meta-ti-bsp/conf/machine/include/j784s4.inc
@@ -9,3 +9,5 @@ PREFERRED_PROVIDER_virtual/gpudriver ?= "ti-img-rogue-driver"
9TFA_BOARD = "j784s4" 9TFA_BOARD = "j784s4"
10 10
11OPTEEMACHINE = "k3-j784s4" 11OPTEEMACHINE = "k3-j784s4"
12
13MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS += "cadence-mhdp-fw cnm-wave-fw ti-eth-fw"
diff --git a/meta-ti-bsp/conf/machine/include/k3.inc b/meta-ti-bsp/conf/machine/include/k3.inc
index a8e80fa7..2415f0ba 100644
--- a/meta-ti-bsp/conf/machine/include/k3.inc
+++ b/meta-ti-bsp/conf/machine/include/k3.inc
@@ -40,6 +40,8 @@ FIT_SIGN_ALG ?= "rsa4096"
40 40
41EXTRA_IMAGEDEPENDS += "virtual/bootloader" 41EXTRA_IMAGEDEPENDS += "virtual/bootloader"
42 42
43MACHINE_ESSENTIAL_EXTRA_RDEPENDS += "kernel-image-image"
44
43TFA_PLATFORM = "k3" 45TFA_PLATFORM = "k3"
44 46
45# Use the expected value of the ubifs filesystem's volume name in the kernel 47# Use the expected value of the ubifs filesystem's volume name in the kernel
diff --git a/meta-ti-bsp/conf/machine/include/omap-a15.inc b/meta-ti-bsp/conf/machine/include/omap-a15.inc
index c1eb659b..6187f2ea 100644
--- a/meta-ti-bsp/conf/machine/include/omap-a15.inc
+++ b/meta-ti-bsp/conf/machine/include/omap-a15.inc
@@ -40,6 +40,10 @@ UBOOT_SUFFIX = "img"
40 40
41EXTRA_IMAGEDEPENDS += "virtual/bootloader" 41EXTRA_IMAGEDEPENDS += "virtual/bootloader"
42 42
43MACHINE_ESSENTIAL_EXTRA_RDEPENDS += "kernel-image-zimage"
44
45MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS += "vpdma-fw goodix-fw"
46
43# Use the expected value of the ubifs filesystem's volume name in the kernel 47# Use the expected value of the ubifs filesystem's volume name in the kernel
44# and u-boot. 48# and u-boot.
45UBI_VOLNAME = "rootfs" 49UBI_VOLNAME = "rootfs"
diff --git a/meta-ti-bsp/conf/machine/include/omapl138.inc b/meta-ti-bsp/conf/machine/include/omapl138.inc
index 72cfd659..7f8262a5 100644
--- a/meta-ti-bsp/conf/machine/include/omapl138.inc
+++ b/meta-ti-bsp/conf/machine/include/omapl138.inc
@@ -11,4 +11,6 @@ PREFERRED_PROVIDER_u-boot = "u-boot-ti-staging"
11 11
12EXTRA_IMAGEDEPENDS += "virtual/bootloader" 12EXTRA_IMAGEDEPENDS += "virtual/bootloader"
13 13
14MACHINE_ESSENTIAL_EXTRA_RDEPENDS += "kernel-image-zimage"
15
14MACHINE_FEATURES = "serial usbhost usbgadget alsa" 16MACHINE_FEATURES = "serial usbhost usbgadget alsa"
diff --git a/meta-ti-bsp/conf/machine/include/ti-soc.inc b/meta-ti-bsp/conf/machine/include/ti-soc.inc
index 2792d2a0..a1fd3cbf 100644
--- a/meta-ti-bsp/conf/machine/include/ti-soc.inc
+++ b/meta-ti-bsp/conf/machine/include/ti-soc.inc
@@ -1,5 +1,9 @@
1# This is a generic TI SOC family. It is a superset of all other SOCs 1# This is a generic TI SOC family. It is a superset of all other SOCs
2# and platforms defined in meta-ti to allow BSP-level overrides. 2# and platforms defined in meta-ti to allow BSP-level overrides.
3SOC_FAMILY = "ti-soc" 3SOC_FAMILY = "ti-soc"
4
5# TI platforms all use devicetrees with overlays
6MACHINE_ESSENTIAL_EXTRA_RDEPENDS += "kernel-devicetree"
4KERNEL_DTB_OVERLAY_SUPPORT ?= "1" 7KERNEL_DTB_OVERLAY_SUPPORT ?= "1"
8
5require conf/machine/include/soc-family.inc 9require conf/machine/include/soc-family.inc
diff --git a/meta-ti-bsp/conf/machine/include/ti33x.inc b/meta-ti-bsp/conf/machine/include/ti33x.inc
index 567cf128..d6a70895 100644
--- a/meta-ti-bsp/conf/machine/include/ti33x.inc
+++ b/meta-ti-bsp/conf/machine/include/ti33x.inc
@@ -63,6 +63,10 @@ UBI_VOLNAME = "rootfs"
63 63
64EXTRA_IMAGEDEPENDS += "virtual/bootloader" 64EXTRA_IMAGEDEPENDS += "virtual/bootloader"
65 65
66MACHINE_ESSENTIAL_EXTRA_RDEPENDS += "kernel-image-zimage"
67
68MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS += "amx3-cm3 prueth-fw pruhsr-fw pruprp-fw"
69
66# List common SoC features, may need to add touchscreen for specific machines 70# List common SoC features, may need to add touchscreen for specific machines
67MACHINE_FEATURES = "apm usbgadget usbhost vfat ext2 alsa gpu" 71MACHINE_FEATURES = "apm usbgadget usbhost vfat ext2 alsa gpu"
68 72
diff --git a/meta-ti-bsp/conf/machine/include/ti43x.inc b/meta-ti-bsp/conf/machine/include/ti43x.inc
index c70a8363..05a28b77 100644
--- a/meta-ti-bsp/conf/machine/include/ti43x.inc
+++ b/meta-ti-bsp/conf/machine/include/ti43x.inc
@@ -57,7 +57,11 @@ UBOOT_SUFFIX = "img"
57# and u-boot. 57# and u-boot.
58UBI_VOLNAME = "rootfs" 58UBI_VOLNAME = "rootfs"
59 59
60EXTRA_IMAGEDEPENDS += "u-boot" 60EXTRA_IMAGEDEPENDS += "virtual/bootloader"
61
62MACHINE_ESSENTIAL_EXTRA_RDEPENDS += "kernel-image-zimage"
63
64MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS += "amx3-cm3 prueth-fw pruhsr-fw pruprp-fw"
61 65
62# List common SoC features, may need to add touchscreen for specific machines 66# List common SoC features, may need to add touchscreen for specific machines
63MACHINE_FEATURES = "apm usbgadget usbhost vfat ext2 screen alsa gpu" 67MACHINE_FEATURES = "apm usbgadget usbhost vfat ext2 screen alsa gpu"
diff --git a/meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc b/meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc
deleted file mode 100644
index 266a7ef5..00000000
--- a/meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc
+++ /dev/null
@@ -1,38 +0,0 @@
1# Pull in the devicetree files into the rootfs
2RDEPENDS:${KERNEL_PACKAGE_NAME}-base += "kernel-devicetree"
3
4# Add run-time dependency for PM firmware to the rootfs
5RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:ti33x = " amx3-cm3"
6RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:ti43x = " amx3-cm3"
7
8# Add run-time dependency for VPE VPDMA firmware to the rootfs
9RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:dra7xx = " vpdma-fw"
10
11# Add run-time dependency for Goodix firmware to the rootfs
12RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:dra7xx = " goodix-fw"
13
14# Add run-time dependency for PRU Ethernet firmware to the rootfs
15RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:am57xx = " prueth-fw prusw-fw pruhsr-fw pruprp-fw"
16RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:ti43x = " prueth-fw pruhsr-fw pruprp-fw"
17RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:ti33x = " prueth-fw pruhsr-fw pruprp-fw"
18RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:am65xx = " prueth-fw-am65x"
19RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:am65xx-evm = " prueth-fw-am65x-sr2 pruhsr-fw-am65x-sr2 prusw-fw-am65x-sr2"
20RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:am64xx = " prueth-fw-am65x-sr2 pruhsr-fw-am65x-sr2 prusw-fw-am65x-sr2"
21
22# Add run-time dependency for Cadence MHDP firmware to the rootfs
23RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:j721e = " cadence-mhdp-fw"
24RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:j721s2 = " cadence-mhdp-fw"
25RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:j784s4 = " cadence-mhdp-fw"
26
27# Add run-time dependency for Video Decoding firmware to the rootfs
28RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:j721e = " vxd-dec-fw"
29
30# Add run-time dependency for Chips&Media Wave521 firmware to the rootfs
31RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:j721s2 = " cnm-wave-fw"
32RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:j784s4 = " cnm-wave-fw"
33RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:am62axx = " cnm-wave-fw"
34
35# Add run-time dependency for TI ETH firmware to the rootfs
36RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:j721e = " ti-eth-fw"
37RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:j7200 = " ti-eth-fw"
38RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:j784s4 = " ti-eth-fw"
diff --git a/meta-ti-bsp/recipes-kernel/linux/linux-ti-mainline_git.bb b/meta-ti-bsp/recipes-kernel/linux/linux-ti-mainline_git.bb
index dfa46f48..a7b5ca74 100644
--- a/meta-ti-bsp/recipes-kernel/linux/linux-ti-mainline_git.bb
+++ b/meta-ti-bsp/recipes-kernel/linux/linux-ti-mainline_git.bb
@@ -5,7 +5,6 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
5 5
6inherit kernel 6inherit kernel
7 7
8require recipes-kernel/linux/kernel-rdepends.inc
9require recipes-kernel/linux/ti-kernel.inc 8require recipes-kernel/linux/ti-kernel.inc
10 9
11DEPENDS += "gmp-native libmpc-native" 10DEPENDS += "gmp-native libmpc-native"
diff --git a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_5.10.bb b/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_5.10.bb
index 58a2fd69..c53ae1e1 100644
--- a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_5.10.bb
+++ b/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_5.10.bb
@@ -9,7 +9,6 @@ inherit kernel
9 9
10DEFCONFIG_BUILDER = "${S}/ti_config_fragments/defconfig_builder.sh" 10DEFCONFIG_BUILDER = "${S}/ti_config_fragments/defconfig_builder.sh"
11require recipes-kernel/linux/setup-defconfig.inc 11require recipes-kernel/linux/setup-defconfig.inc
12require recipes-kernel/linux/kernel-rdepends.inc
13require recipes-kernel/linux/ti-kernel.inc 12require recipes-kernel/linux/ti-kernel.inc
14include ${@ 'recipes-kernel/linux/ti-kernel-devicetree-prefix.inc' if d.getVar('KERNEL_DEVICETREE_PREFIX') else ''} 13include ${@ 'recipes-kernel/linux/ti-kernel-devicetree-prefix.inc' if d.getVar('KERNEL_DEVICETREE_PREFIX') else ''}
15 14
diff --git a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_6.1.bb b/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_6.1.bb
index 66be6944..ee106a7f 100644
--- a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_6.1.bb
+++ b/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_6.1.bb
@@ -7,7 +7,6 @@ inherit ti-secdev
7inherit kernel 7inherit kernel
8 8
9require recipes-kernel/linux/setup-defconfig.inc 9require recipes-kernel/linux/setup-defconfig.inc
10require recipes-kernel/linux/kernel-rdepends.inc
11require recipes-kernel/linux/ti-kernel.inc 10require recipes-kernel/linux/ti-kernel.inc
12include ${@ 'recipes-kernel/linux/ti-kernel-devicetree-prefix.inc' if d.getVar('KERNEL_DEVICETREE_PREFIX') else ''} 11include ${@ 'recipes-kernel/linux/ti-kernel-devicetree-prefix.inc' if d.getVar('KERNEL_DEVICETREE_PREFIX') else ''}
13include ${@ 'recipes-kernel/linux/ti-extras.inc' if d.getVar('TI_EXTRAS') else ''} 12include ${@ 'recipes-kernel/linux/ti-extras.inc' if d.getVar('TI_EXTRAS') else ''}