summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRyan Eatmon <reatmon@ti.com>2023-07-24 15:45:36 -0500
committerRyan Eatmon <reatmon@ti.com>2023-07-31 14:55:48 -0500
commitb12c4b83db420fe8020d04bd26d3e28bc6355440 (patch)
treee93cea7f3353b2e5dab04fb98cd375b2ffaa5c2f
parente969884edb5a679c09960207253d785d82b72d3d (diff)
downloadmeta-ti-cicd.master.202308040100.tar.gz
linux-ti-next,conf/machine: Add support for new vendored dts dircicd.master.202308040100
The latest kernel has made the change to add vendor subdirectories into the arch/arm/boot/dts directory. This effectively breaks the KERNEL_DEVICETREE settings in the machine configs for 32bit platforms, so switch them over to using the PREFIX variable. Also change the linux-ti-next to use the PREFIX setting for KERNEL_DEVICETREE. Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r--meta-ti-bsp/conf/machine/am57xx-evm.conf3
-rw-r--r--meta-ti-bsp/conf/machine/dra7xx-evm.conf1
-rw-r--r--meta-ti-bsp/conf/machine/include/ti33x.inc5
-rw-r--r--meta-ti-bsp/conf/machine/include/ti43x.inc2
-rw-r--r--meta-ti-bsp/conf/machine/omapl138-lcdk.conf5
-rw-r--r--meta-ti-bsp/recipes-kernel/linux/linux-ti-next_git.bb1
6 files changed, 15 insertions, 2 deletions
diff --git a/meta-ti-bsp/conf/machine/am57xx-evm.conf b/meta-ti-bsp/conf/machine/am57xx-evm.conf
index 26b7f78c..43a6a833 100644
--- a/meta-ti-bsp/conf/machine/am57xx-evm.conf
+++ b/meta-ti-bsp/conf/machine/am57xx-evm.conf
@@ -13,11 +13,14 @@ KERNEL_DEVICETREE_PREFIX = " \
13 ti/am57 \ 13 ti/am57 \
14 ti/lcd \ 14 ti/lcd \
15 ti/ov10635 \ 15 ti/ov10635 \
16 ti/omap/am57 \
16" 17"
17 18
18KERNEL_DEVICETREE_DTBMERGE = " \ 19KERNEL_DEVICETREE_DTBMERGE = " \
19 am57xx-evm.dtb \ 20 am57xx-evm.dtb \
20 am57xx-evm-reva3.dtb \ 21 am57xx-evm-reva3.dtb \
22 ti/omap/am57xx-evm.dtb \
23 ti/omap/am57xx-evm-reva3.dtb \
21" 24"
22 25
23KERNEL_DEVICETREE = " \ 26KERNEL_DEVICETREE = " \
diff --git a/meta-ti-bsp/conf/machine/dra7xx-evm.conf b/meta-ti-bsp/conf/machine/dra7xx-evm.conf
index c47a1e80..30884ae1 100644
--- a/meta-ti-bsp/conf/machine/dra7xx-evm.conf
+++ b/meta-ti-bsp/conf/machine/dra7xx-evm.conf
@@ -12,6 +12,7 @@ KERNEL_DEVICETREE_PREFIX = " \
12 dra7 \ 12 dra7 \
13 ti/dra7 \ 13 ti/dra7 \
14 ti/lcd \ 14 ti/lcd \
15 ti/omap/dra7 \
15" 16"
16 17
17KERNEL_DEVICETREE = " \ 18KERNEL_DEVICETREE = " \
diff --git a/meta-ti-bsp/conf/machine/include/ti33x.inc b/meta-ti-bsp/conf/machine/include/ti33x.inc
index f7f126f4..bc61a773 100644
--- a/meta-ti-bsp/conf/machine/include/ti33x.inc
+++ b/meta-ti-bsp/conf/machine/include/ti33x.inc
@@ -19,7 +19,10 @@ PVR_DISPLAY_CONTROLLER_ALIAS ?= "tilcdc"
19 19
20KERNEL_IMAGETYPE = "zImage" 20KERNEL_IMAGETYPE = "zImage"
21 21
22KERNEL_DEVICETREE_PREFIX = "am335x" 22KERNEL_DEVICETREE_PREFIX = " \
23 am335x \
24 ti/omap/am335x \
25"
23 26
24KERNEL_DEVICETREE = " \ 27KERNEL_DEVICETREE = " \
25 am335x-evm.dtb \ 28 am335x-evm.dtb \
diff --git a/meta-ti-bsp/conf/machine/include/ti43x.inc b/meta-ti-bsp/conf/machine/include/ti43x.inc
index a6af56e3..ea5d1505 100644
--- a/meta-ti-bsp/conf/machine/include/ti43x.inc
+++ b/meta-ti-bsp/conf/machine/include/ti43x.inc
@@ -22,6 +22,8 @@ KERNEL_IMAGETYPE = "zImage"
22KERNEL_DEVICETREE_PREFIX = " \ 22KERNEL_DEVICETREE_PREFIX = " \
23 am437x \ 23 am437x \
24 am43x \ 24 am43x \
25 ti/omap/am437x \
26 ti/omap/am43x \
25" 27"
26 28
27KERNEL_DEVICETREE = " \ 29KERNEL_DEVICETREE = " \
diff --git a/meta-ti-bsp/conf/machine/omapl138-lcdk.conf b/meta-ti-bsp/conf/machine/omapl138-lcdk.conf
index a8b08964..fdbaffae 100644
--- a/meta-ti-bsp/conf/machine/omapl138-lcdk.conf
+++ b/meta-ti-bsp/conf/machine/omapl138-lcdk.conf
@@ -15,7 +15,10 @@ IMAGE_FSTYPES += "tar.xz"
15 15
16SERIAL_CONSOLES = "115200;ttyS2" 16SERIAL_CONSOLES = "115200;ttyS2"
17 17
18KERNEL_DEVICETREE_PREFIX = "da850" 18KERNEL_DEVICETREE_PREFIX = " \
19 da850 \
20 ti/davinci/da850 \
21"
19 22
20KERNEL_DEVICETREE = " \ 23KERNEL_DEVICETREE = " \
21 da850-evm.dtb \ 24 da850-evm.dtb \
diff --git a/meta-ti-bsp/recipes-kernel/linux/linux-ti-next_git.bb b/meta-ti-bsp/recipes-kernel/linux/linux-ti-next_git.bb
index 9138c7c5..8228f4ff 100644
--- a/meta-ti-bsp/recipes-kernel/linux/linux-ti-next_git.bb
+++ b/meta-ti-bsp/recipes-kernel/linux/linux-ti-next_git.bb
@@ -6,6 +6,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
6inherit kernel 6inherit kernel
7 7
8require recipes-kernel/linux/ti-kernel.inc 8require recipes-kernel/linux/ti-kernel.inc
9include ${@ 'recipes-kernel/linux/ti-kernel-devicetree-prefix.inc' if d.getVar('KERNEL_DEVICETREE_PREFIX') else ''}
9 10
10DEPENDS += "gmp-native libmpc-native" 11DEPENDS += "gmp-native libmpc-native"
11 12