summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRandolph Sapp <rs@ti.com>2023-04-27 16:07:43 -0500
committerRyan Eatmon <reatmon@ti.com>2023-05-02 17:33:49 -0500
commitf027b5399cace365e5d63d9b98331ce5404e02f3 (patch)
treeeb44df0d0ca05ed836b507255c8a7a4803053eed
parent6fa3a588b7a1250a756c06e94fe6fdd28a57a8a6 (diff)
downloadmeta-ti-f027b5399cace365e5d63d9b98331ce5404e02f3.tar.gz
ti-img-rogue-umlibs: bump srcrev, add vulkan, update deps
Update the source revision for the following upstream changes: - Drop the included ICD loader. Use the Mesa/Khronos one instead. - Enable all vulkan window system extensions Separate the vulkan libs into their own package so people can choose to ignore them if they want, considering the new runtime deps. Signed-off-by: Randolph Sapp <rs@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r--meta-ti-bsp/recipes-graphics/libgles/ti-img-rogue-umlibs_23.1.6404501.bb27
1 files changed, 21 insertions, 6 deletions
diff --git a/meta-ti-bsp/recipes-graphics/libgles/ti-img-rogue-umlibs_23.1.6404501.bb b/meta-ti-bsp/recipes-graphics/libgles/ti-img-rogue-umlibs_23.1.6404501.bb
index 3ad0cce6..9068d341 100644
--- a/meta-ti-bsp/recipes-graphics/libgles/ti-img-rogue-umlibs_23.1.6404501.bb
+++ b/meta-ti-bsp/recipes-graphics/libgles/ti-img-rogue-umlibs_23.1.6404501.bb
@@ -12,7 +12,7 @@ PR = "r2"
12 12
13BRANCH = "linuxws/kirkstone/k6.1/${PV}" 13BRANCH = "linuxws/kirkstone/k6.1/${PV}"
14SRC_URI = "git://git.ti.com/git/graphics/ti-img-rogue-umlibs.git;protocol=https;branch=${BRANCH}" 14SRC_URI = "git://git.ti.com/git/graphics/ti-img-rogue-umlibs.git;protocol=https;branch=${BRANCH}"
15SRCREV = "49958a8e820a321d22ac3c635bd21d4a3118c006" 15SRCREV = "452b0f50d2984171c81d5a0d3b22198177d919ad"
16S = "${WORKDIR}/git/targetfs/${TARGET_PRODUCT}/${PVR_WS}/${PVR_BUILD}" 16S = "${WORKDIR}/git/targetfs/${TARGET_PRODUCT}/${PVR_WS}/${PVR_BUILD}"
17 17
18TARGET_PRODUCT:j721e = "j721e_linux" 18TARGET_PRODUCT:j721e = "j721e_linux"
@@ -30,14 +30,29 @@ do_install:append() {
30 rmdir ${D}/lib 30 rmdir ${D}/lib
31 fi 31 fi
32 rm -rf "${D}/etc/init.d" 32 rm -rf "${D}/etc/init.d"
33 rm -rf "${D}/usr/lib/libvulkan.so"
34 rm -rf "${D}/usr/lib/libvulkan.so.0"
35 rm -rf "${D}/usr/lib/libvulkan.so.1"
36} 33}
37 34
38PACKAGES = "${PN}-tools ${PN}" 35PACKAGES = "${PN}-vulkan ${PN}-tools ${PN}"
36
37FILES:${PN}-vulkan = " \
38 ${datadir}/vulkan \
39 ${libdir}/libVK_IMG.so* \
40"
41RDEPENDS:${PN}-vulkan += " \
42 mesa-vulkan-drivers \
43 libdrm \
44 ti-img-rogue-driver \
45 libx11-xcb \
46 wayland \
47"
48INSANE_SKIP:${PN}-vulkan += " \
49 already-stripped \
50 dev-so \
51"
52
39FILES:${PN}-tools = "${bindir}/" 53FILES:${PN}-tools = "${bindir}/"
40RDEPENDS:${PN}-tools = "python3-core" 54RDEPENDS:${PN}-tools = "python3-core"
41RRECOMMENDS:${PN} += "${PN}-tools" 55
56RRECOMMENDS:${PN} += "${PN}-vulkan ${PN}-tools"
42 57
43INSANE_SKIP:${PN} += "ldflags arch already-stripped dev-so" 58INSANE_SKIP:${PN} += "ldflags arch already-stripped dev-so"