summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2020-05-14 06:12:38 +0000
committerDenys Dmytriyenko <denys@ti.com>2020-05-14 00:13:45 +0000
commitd8cc5fb4af4e0ea3b1eebd2803d7ca4d8760dd71 (patch)
tree924ed7165a3b9be343ceef7aa6c114d3a37eaae5
parent86c16be6cdad21f47836d68ad2f3ac734977639c (diff)
downloadmeta-ti-07.00.00.002.tar.gz
atf, sciclient: add missing j7-hs-evm support07.00.00.002
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_2.2.bb8
-rw-r--r--recipes-bsp/sciclient/sciclient-rtos_git.bb1
2 files changed, 9 insertions, 0 deletions
diff --git a/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_2.2.bb b/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_2.2.bb
index f15570cf..ae957bf8 100644
--- a/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_2.2.bb
+++ b/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_2.2.bb
@@ -54,6 +54,14 @@ do_compile_append_am65xx-hs-evm() {
54 ) 54 )
55} 55}
56 56
57do_compile_append_j7-hs-evm() {
58 export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG}
59 ( cd ${S}/build/${ATFPLATFORM}/${ATFBOARD}/release/; \
60 mv bl31.bin bl31.bin.unsigned; \
61 ${TI_SECURE_DEV_PKG}/scripts/secure-binary-image.sh bl31.bin.unsigned bl31.bin; \
62 )
63}
64
57do_install() { 65do_install() {
58 install -d ${D}/boot 66 install -d ${D}/boot
59 install -m 0644 ${S}/build/${ATFPLATFORM}/${ATFBOARD}/release/bl31.bin ${D}/boot/ 67 install -m 0644 ${S}/build/${ATFPLATFORM}/${ATFBOARD}/release/bl31.bin ${D}/boot/
diff --git a/recipes-bsp/sciclient/sciclient-rtos_git.bb b/recipes-bsp/sciclient/sciclient-rtos_git.bb
index 7fbeb1e2..deaf0b12 100644
--- a/recipes-bsp/sciclient/sciclient-rtos_git.bb
+++ b/recipes-bsp/sciclient/sciclient-rtos_git.bb
@@ -27,6 +27,7 @@ export PDK_SCICLIENT_ROOT_PATH = "${SCICLIENT_PACKAGE_BASE}/package/all/pdk_/pac
27 27
28BUILD_HS = "" 28BUILD_HS = ""
29BUILD_HS_am65xx-hs-evm = "yes" 29BUILD_HS_am65xx-hs-evm = "yes"
30BUILD_HS_j7-hs-evm = "yes"
30export BUILD_HS 31export BUILD_HS
31 32
32# Sciclient for am65x supports mcu1_1 in addition to the default cores in TI_PDK_LIMIT_CORES 33# Sciclient for am65x supports mcu1_1 in addition to the default cores in TI_PDK_LIMIT_CORES