summaryrefslogtreecommitdiffstats
path: root/recipes-security/setools/setools_4.4.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-security/setools/setools_4.4.2.bb')
-rw-r--r--recipes-security/setools/setools_4.4.2.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/recipes-security/setools/setools_4.4.2.bb b/recipes-security/setools/setools_4.4.2.bb
new file mode 100644
index 0000000..4e41c69
--- /dev/null
+++ b/recipes-security/setools/setools_4.4.2.bb
@@ -0,0 +1,38 @@
1SUMMARY = "Policy analysis tools for SELinux"
2DESCRIPTION = "\
3SETools is a collection of graphical tools, command-line tools, and \
4libraries designed to facilitate SELinux policy analysis."
5SECTION = "base"
6LICENSE = "GPL-2.0-only & LGPL-2.1-only"
7
8SRC_URI = "git://github.com/SELinuxProject/${BPN}.git;branch=4.4;protocol=https \
9 file://setools4-fixes-for-cross-compiling.patch \
10 "
11SRCREV = "d8d0dcc4c70c858784b56c5400203d52dfe01755"
12
13LIC_FILES_CHKSUM = "file://${S}/COPYING;md5=69a7b68f0a4a570d7c0c43465333ecbc \
14 file://${S}/COPYING.GPL;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
15 file://${S}/COPYING.LGPL;md5=4fbd65380cdd255951079008b364516c"
16
17S = "${WORKDIR}/git"
18
19DEPENDS = "python3-cython-native libsepol libselinux"
20
21RDEPENDS:${PN} = "python3-networkx python3-setuptools \
22 python3-logging libselinux-python"
23
24RPROVIDES:${PN} = "${PN}-console"
25
26inherit setuptools3
27
28do_install:prepend() {
29 sed -i -e 's:${RECIPE_SYSROOT}::g' ${S}/setools/policyrep.c
30}
31
32do_install:append() {
33 # Need PyQt5 support, disable gui tools
34 rm -f ${D}${bindir}/apol
35 rm -rf ${D}${libdir}/${PYTHON_DIR}/site-packages/setoolsgui
36 rm -rf ${D}${libdir}/${PYTHON_DIR}/site-packages/setools/__pycache__
37 rm -rf ${D}${libdir}/${PYTHON_DIR}/site-packages/setools/*/__pycache__
38}