summaryrefslogtreecommitdiffstats
path: root/recipes-security/selinux/semodule-utils_3.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-security/selinux/semodule-utils_3.5.bb')
-rw-r--r--recipes-security/selinux/semodule-utils_3.5.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes-security/selinux/semodule-utils_3.5.bb b/recipes-security/selinux/semodule-utils_3.5.bb
new file mode 100644
index 0000000..0c1c189
--- /dev/null
+++ b/recipes-security/selinux/semodule-utils_3.5.bb
@@ -0,0 +1,28 @@
1SUMMARY = "Utilities to manipulate SELinux policy module package"
2DESCRIPTION = "\
3The utilities to create, expand, link and show the dependencies between \
4the SELinux policy module packages."
5SECTION = "base"
6LICENSE = "GPL-2.0-or-later"
7LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=393a5ca445f6965873eca0259a17f833"
8
9require selinux_common.inc
10
11DEPENDS = "libsepol"
12
13S = "${WORKDIR}/git/semodule-utils"
14
15PACKAGES =+ "\
16 ${PN}-semodule-expand \
17 ${PN}-semodule-link \
18 ${PN}-semodule-package \
19"
20
21FILES:${PN}-semodule-expand = "${bindir}/semodule_expand"
22FILES:${PN}-semodule-link = "${bindir}/semodule_link"
23FILES:${PN}-semodule-package = "\
24 ${bindir}/semodule_package \
25 ${bindir}/semodule_unpackage \
26"
27
28BBCLASSEXTEND = "native"