summaryrefslogtreecommitdiffstats
path: root/recipes-security/selinux/restorecond_3.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-security/selinux/restorecond_3.6.bb')
-rw-r--r--recipes-security/selinux/restorecond_3.6.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/recipes-security/selinux/restorecond_3.6.bb b/recipes-security/selinux/restorecond_3.6.bb
new file mode 100644
index 0000000..8e57283
--- /dev/null
+++ b/recipes-security/selinux/restorecond_3.6.bb
@@ -0,0 +1,37 @@
1SUMMARY = "Daemon to watch for file creation and set default file context"
2DESCRIPTION = "\
3The restorecond daemon uses inotify to watch files listed in the \
4/etc/selinux/restorecond.conf, when they are created, this daemon \
5will make sure they have the correct file context associated with \
6the policy."
7SECTION = "base"
8LICENSE = "GPL-2.0-or-later"
9LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=393a5ca445f6965873eca0259a17f833"
10
11require selinux_common.inc
12
13inherit pkgconfig systemd update-rc.d
14
15DEPENDS = "libsepol libselinux glib-2.0"
16
17EXTRA_OEMAKE = "SYSTEMDSYSTEMUNITDIR=${systemd_system_unitdir} \
18 SYSTEMDUSERUNITDIR=${systemd_user_unitdir} \
19 "
20
21S = "${WORKDIR}/git/restorecond"
22
23FILES:${PN} += "${datadir}/dbus-1/services/org.selinux.Restorecond.service \
24 ${systemd_user_unitdir}/* \
25 "
26
27SYSTEMD_SERVICE:restorecond = "restorecond.service"
28INITSCRIPT_PACKAGES = "restorecond"
29INITSCRIPT_NAME:restorecond = "restorecond"
30INITSCRIPT_PARAMS:restorecond = "defaults"
31
32do_install:append() {
33 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'false', 'true', d)}; then
34 # remove /usr/lib/systemd/user
35 rm -rf ${D}${nonarch_libdir}
36 fi
37}