summaryrefslogtreecommitdiffstats
path: root/recipes-security/selinux/libsepol_3.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-security/selinux/libsepol_3.6.bb')
-rw-r--r--recipes-security/selinux/libsepol_3.6.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes-security/selinux/libsepol_3.6.bb b/recipes-security/selinux/libsepol_3.6.bb
new file mode 100644
index 0000000..0c28e9b
--- /dev/null
+++ b/recipes-security/selinux/libsepol_3.6.bb
@@ -0,0 +1,18 @@
1SUMMARY = "SELinux binary policy manipulation library"
2DESCRIPTION = "libsepol provides an API for the manipulation of SELinux binary policies. \
3It is used by checkpolicy (the policy compiler) and similar tools, as well \
4as by programs like load_policy that need to perform specific transformations \
5on binary policies such as customizing policy boolean settings."
6SECTION = "base"
7LICENSE = "LGPL-2.0-or-later"
8LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=a6f89e2100d9b6cdffcea4f398e37343"
9
10require selinux_common.inc
11
12inherit lib_package
13
14S = "${WORKDIR}/git/libsepol"
15
16DEPENDS = "flex-native"
17
18BBCLASSEXTEND = "native"