summaryrefslogtreecommitdiffstats
path: root/recipes-security/selinux/libselinux_3.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-security/selinux/libselinux_3.3.bb')
-rw-r--r--recipes-security/selinux/libselinux_3.3.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes-security/selinux/libselinux_3.3.bb b/recipes-security/selinux/libselinux_3.3.bb
new file mode 100644
index 0000000..1144840
--- /dev/null
+++ b/recipes-security/selinux/libselinux_3.3.bb
@@ -0,0 +1,29 @@
1SUMMARY = "SELinux library and simple utilities"
2DESCRIPTION = "libselinux provides an API for SELinux applications to get and set \
3process and file security contexts and to obtain security policy \
4decisions. Required for any applications that use the SELinux API."
5SECTION = "base"
6LICENSE = "PD"
7LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=84b4d2c6ef954a2d4081e775a270d0d0"
8
9require selinux_common.inc
10
11inherit lib_package python3native pkgconfig
12
13DEPENDS += "libsepol libpcre"
14DEPENDS:append:libc-musl = " fts"
15
16S = "${WORKDIR}/git/libselinux"
17
18def get_policyconfigarch(d):
19 import re
20 target = d.getVar('TARGET_ARCH')
21 p = re.compile('i.86')
22 target = p.sub('i386',target)
23 return "ARCH=%s" % (target)
24
25EXTRA_OEMAKE += "${@get_policyconfigarch(d)}"
26EXTRA_OEMAKE += "LDFLAGS='${LDFLAGS} -lpcre' LIBSEPOLA='${STAGING_LIBDIR}/libsepol.a'"
27EXTRA_OEMAKE:append:libc-musl = " FTS_LDLIBS=-lfts"
28
29BBCLASSEXTEND = "native"