summaryrefslogtreecommitdiffstats
path: root/recipes-security/selinux/checkpolicy_3.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-security/selinux/checkpolicy_3.5.bb')
-rw-r--r--recipes-security/selinux/checkpolicy_3.5.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes-security/selinux/checkpolicy_3.5.bb b/recipes-security/selinux/checkpolicy_3.5.bb
new file mode 100644
index 0000000..60f506d
--- /dev/null
+++ b/recipes-security/selinux/checkpolicy_3.5.bb
@@ -0,0 +1,23 @@
1SUMMARY = "SELinux policy compiler"
2DESCRIPTION = "\
3This package contains checkpolicy, the SELinux policy compiler. Only \
4required for building policies. It uses libsepol to generate the \
5binary policy. checkpolicy uses the static libsepol since it deals \
6with low level details of the policy that have not been \
7encapsulated/abstracted by a proper shared library interface."
8SECTION = "base"
9LICENSE = "GPL-2.0-or-later"
10LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=393a5ca445f6965873eca0259a17f833"
11
12require selinux_common.inc
13
14DEPENDS = "libsepol bison-native"
15
16S = "${WORKDIR}/git/checkpolicy"
17
18do_install:append() {
19 install test/dismod ${D}/${bindir}/sedismod
20 install test/dispol ${D}/${bindir}/sedispol
21}
22
23BBCLASSEXTEND = "native"