summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorXin Ouyang <Xin.Ouyang@windriver.com>2012-02-13 16:09:24 +0800
committerXin Ouyang <Xin.Ouyang@windriver.com>2012-02-13 16:09:24 +0800
commit396137be3a99adabef33c8a32e75017278fe439b (patch)
tree1f35ee2a4503cd82e0634866b06c64b001a7df44 /recipes-devtools
parenta032b2ec117d1ae6960c2994d118455ff0a9a010 (diff)
downloadmeta-selinux-396137be3a99adabef33c8a32e75017278fe439b.tar.gz
python-IPy: needed by policycoreutils.
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/python/python-IPy_0.75.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-IPy_0.75.bb b/recipes-devtools/python/python-IPy_0.75.bb
new file mode 100644
index 0000000..9ccb6bc
--- /dev/null
+++ b/recipes-devtools/python/python-IPy_0.75.bb
@@ -0,0 +1,34 @@
1SUMMARY = "Python module for handling IPv4 and IPv6 Addresses and Networks"
2DESCRIPTION = "IPy is a Python module for handling IPv4 and IPv6 Addresses and Networks \
3in a fashion similar to perl's Net::IP and friends. The IP class allows \
4a comfortable parsing and handling for most notations in use for IPv4 \
5and IPv6 Addresses and Networks."
6SECTION = "devel/python"
7HOMEPAGE = "https://github.com/haypo/python-ipy"
8DEPENDS = "python"
9LICENSE = "BSD"
10LIC_FILES_CHKSUM = "file://COPYING;md5=ebc0028ff5cdaf7796604875027dcd55"
11
12PR = "r1"
13
14SRC_URI = "http://pypi.python.org/packages/source/I/IPy/IPy-${PV}.tar.gz"
15
16SRC_URI[md5sum] = "d56716a3d8c77fe8539b6e90c88010bd"
17SRC_URI[sha256sum] = "0fa14af4792cc0b6f61cb5a1cd8fbdf7ddbaa6864ef82681021b750e9e6b2b61"
18
19S = "${WORKDIR}/IPy-${PV}"
20
21inherit distutils
22
23# need to export these variables for python-config to work
24export BUILD_SYS
25export HOST_SYS
26export STAGING_INCDIR
27export STAGING_LIBDIR
28
29BBCLASSEXTEND = "native"
30
31do_install_append() {
32 install -d ${D}/${datadir}/doc/${PN}-${PV}
33 install AUTHORS COPYING ChangeLog PKG-INFO README ${D}/${datadir}/doc/${PN}-${PV}
34}