summaryrefslogtreecommitdiffstats
path: root/dynamic-layers
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2021-08-19 12:47:02 +0800
committerJoe MacDonald <joe@deserted.net>2021-08-29 21:34:22 -0400
commita101ac3dcedf5e8957061576dd6dadd738711717 (patch)
tree30783785f2a874712b2695ed0922f98f4f3b5591 /dynamic-layers
parent0c417aa70d0e70e3067f4142a3311e49c759b234 (diff)
downloadmeta-selinux-a101ac3dcedf5e8957061576dd6dadd738711717.tar.gz
python2: drop bbappend
This bbappend was added long time ago and it is useless now. Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Joe MacDonald <joe@deserted.net>
Diffstat (limited to 'dynamic-layers')
-rw-r--r--dynamic-layers/python2-layer/recipes-devtools/python/files/sitecustomize.py26
-rw-r--r--dynamic-layers/python2-layer/recipes-devtools/python/python_%.bbappend1
-rw-r--r--dynamic-layers/python2-layer/recipes-devtools/python/python_selinux.inc5
3 files changed, 0 insertions, 32 deletions
diff --git a/dynamic-layers/python2-layer/recipes-devtools/python/files/sitecustomize.py b/dynamic-layers/python2-layer/recipes-devtools/python/files/sitecustomize.py
deleted file mode 100644
index d2b71fa..0000000
--- a/dynamic-layers/python2-layer/recipes-devtools/python/files/sitecustomize.py
+++ /dev/null
@@ -1,26 +0,0 @@
1# OpenEmbedded sitecustomize.py (C) 2002-2008 Michael 'Mickey' Lauer <mlauer@vanille-media.de>
2# GPLv2 or later
3# Version: 20081123
4# Features:
5# * set proper default encoding
6# Features removed for SELinux:
7# * enable readline completion in the interactive interpreter
8# * load command line history on startup
9# * save command line history on exit
10
11import os
12
13def __enableDefaultEncoding():
14 import sys
15 try:
16 sys.setdefaultencoding( "utf8" )
17 except LookupError:
18 pass
19
20import sys
21try:
22 import rlcompleter, readline
23except ImportError:
24 pass
25else:
26 __enableDefaultEncoding()
diff --git a/dynamic-layers/python2-layer/recipes-devtools/python/python_%.bbappend b/dynamic-layers/python2-layer/recipes-devtools/python/python_%.bbappend
deleted file mode 100644
index 7719d3b..0000000
--- a/dynamic-layers/python2-layer/recipes-devtools/python/python_%.bbappend
+++ /dev/null
@@ -1 +0,0 @@
1require ${@bb.utils.contains('DISTRO_FEATURES', 'selinux', '${BPN}_selinux.inc', '', d)}
diff --git a/dynamic-layers/python2-layer/recipes-devtools/python/python_selinux.inc b/dynamic-layers/python2-layer/recipes-devtools/python/python_selinux.inc
deleted file mode 100644
index 4fed832..0000000
--- a/dynamic-layers/python2-layer/recipes-devtools/python/python_selinux.inc
+++ /dev/null
@@ -1,5 +0,0 @@
1# If selinux enabled, disable handlers to rw command history file
2FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
3
4inherit selinux
5