summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2023-12-16 16:21:31 +0800
committerJoe MacDonald <joe@deserted.net>2023-12-18 11:06:30 -0500
commit6bd4f3c633ec0fa0a830d8a3b6e66c1ea9b9ae38 (patch)
tree6a23c8f62f3dbe92c871dbf9059f7996f355c6c2
parent62b9c816a5000dc01b28e78213bde26b58cbca9d (diff)
downloadmeta-selinux-6bd4f3c633ec0fa0a830d8a3b6e66c1ea9b9ae38.tar.gz
libsemanage: upgrade 3.5 -> 3.6
* Refresh patches Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Joe MacDonald <joe@deserted.net>
-rw-r--r--recipes-security/selinux/libsemanage/libsemanage-Fix-execve-segfaults-on-Ubuntu.patch4
-rw-r--r--recipes-security/selinux/libsemanage/libsemanage-allow-to-disable-audit-support.patch22
-rw-r--r--recipes-security/selinux/libsemanage/libsemanage-disable-expand-check-on-policy-load.patch2
-rw-r--r--recipes-security/selinux/libsemanage_3.6.bb (renamed from recipes-security/selinux/libsemanage_3.5.bb)0
4 files changed, 14 insertions, 14 deletions
diff --git a/recipes-security/selinux/libsemanage/libsemanage-Fix-execve-segfaults-on-Ubuntu.patch b/recipes-security/selinux/libsemanage/libsemanage-Fix-execve-segfaults-on-Ubuntu.patch
index 5a03d30..daaeb3b 100644
--- a/recipes-security/selinux/libsemanage/libsemanage-Fix-execve-segfaults-on-Ubuntu.patch
+++ b/recipes-security/selinux/libsemanage/libsemanage-Fix-execve-segfaults-on-Ubuntu.patch
@@ -1,4 +1,4 @@
1From 2111f86dce8defd9bebd9b43008339e3b5af0aa7 Mon Sep 17 00:00:00 2001 1From a91134e98ba4b3b6645d12bb68a07976b60f86c8 Mon Sep 17 00:00:00 2001
2From: Xin Ouyang <Xin.Ouyang@windriver.com> 2From: Xin Ouyang <Xin.Ouyang@windriver.com>
3Date: Mon, 26 Mar 2012 15:15:16 +0800 3Date: Mon, 26 Mar 2012 15:15:16 +0800
4Subject: [PATCH] libsemanage: Fix execve segfaults on Ubuntu. 4Subject: [PATCH] libsemanage: Fix execve segfaults on Ubuntu.
@@ -17,7 +17,7 @@ Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
17 1 file changed, 1 insertion(+), 1 deletion(-) 17 1 file changed, 1 insertion(+), 1 deletion(-)
18 18
19diff --git a/src/semanage_store.c b/src/semanage_store.c 19diff --git a/src/semanage_store.c b/src/semanage_store.c
20index 14a0957..0a9200e 100644 20index 27c5d34..519f298 100644
21--- a/src/semanage_store.c 21--- a/src/semanage_store.c
22+++ b/src/semanage_store.c 22+++ b/src/semanage_store.c
23@@ -1470,7 +1470,7 @@ static int semanage_exec_prog(semanage_handle_t * sh, 23@@ -1470,7 +1470,7 @@ static int semanage_exec_prog(semanage_handle_t * sh,
diff --git a/recipes-security/selinux/libsemanage/libsemanage-allow-to-disable-audit-support.patch b/recipes-security/selinux/libsemanage/libsemanage-allow-to-disable-audit-support.patch
index 19263d8..e9df8be 100644
--- a/recipes-security/selinux/libsemanage/libsemanage-allow-to-disable-audit-support.patch
+++ b/recipes-security/selinux/libsemanage/libsemanage-allow-to-disable-audit-support.patch
@@ -1,4 +1,4 @@
1From 5718384543ff06ad4032e90291f9e4398a2749c4 Mon Sep 17 00:00:00 2001 1From c96010440e7a2a87787a535fd0f9ccf26a2b4a5e Mon Sep 17 00:00:00 2001
2From: Wenzong Fan <wenzong.fan@windriver.com> 2From: Wenzong Fan <wenzong.fan@windriver.com>
3Date: Mon, 20 Jan 2014 03:53:48 -0500 3Date: Mon, 20 Jan 2014 03:53:48 -0500
4Subject: [PATCH] libsemanage: allow to disable audit support 4Subject: [PATCH] libsemanage: allow to disable audit support
@@ -13,10 +13,10 @@ Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com>
13 3 files changed, 31 insertions(+), 2 deletions(-) 13 3 files changed, 31 insertions(+), 2 deletions(-)
14 14
15diff --git a/src/Makefile b/src/Makefile 15diff --git a/src/Makefile b/src/Makefile
16index 71c2a1d..52f335e 100644 16index d525996..2f5e159 100644
17--- a/src/Makefile 17--- a/src/Makefile
18+++ b/src/Makefile 18+++ b/src/Makefile
19@@ -26,6 +26,14 @@ ifeq ($(DEBUG),1) 19@@ -27,6 +27,14 @@ ifeq ($(DEBUG),1)
20 export LDFLAGS ?= -g 20 export LDFLAGS ?= -g
21 endif 21 endif
22 22
@@ -31,17 +31,17 @@ index 71c2a1d..52f335e 100644
31 LEX = flex 31 LEX = flex
32 LFLAGS = -s 32 LFLAGS = -s
33 YACC = bison 33 YACC = bison
34@@ -89,7 +97,7 @@ $(LIBA): $(OBJS) 34@@ -90,7 +98,7 @@ $(LIBA): $(OBJS)
35 $(RANLIB) $@ 35 $(RANLIB) $@
36 36
37 $(LIBSO): $(LOBJS) 37 $(LIBSO): $(LOBJS)
38- $(CC) $(CFLAGS) $(LDFLAGS) -shared -o $@ $^ -lsepol -laudit -lselinux -lbz2 -Wl,-soname,$(LIBSO),--version-script=libsemanage.map,-z,defs 38- $(CC) $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) -shared -o $@ $^ -lsepol -laudit -lselinux -lbz2 -Wl,-soname,$(LIBSO),--version-script=libsemanage.map,-z,defs
39+ $(CC) $(CFLAGS) $(LDFLAGS) -shared -o $@ $^ -lsepol $(LIBAUDIT) -lselinux -lbz2 -Wl,-soname,$(LIBSO),--version-script=libsemanage.map,-z,defs 39+ $(CC) $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) -shared -o $@ $^ -lsepol $(LIBAUDIT) -lselinux -lbz2 -Wl,-soname,$(LIBSO),--version-script=libsemanage.map,-z,defs
40 ln -sf $@ $(TARGET) 40 ln -sf $@ $(TARGET)
41 41
42 $(LIBPC): $(LIBPC).in ../VERSION 42 $(LIBPC): $(LIBPC).in ../VERSION
43diff --git a/src/seusers_local.c b/src/seusers_local.c 43diff --git a/src/seusers_local.c b/src/seusers_local.c
44index 6508ec0..1b26956 100644 44index 795a33d..6539cdf 100644
45--- a/src/seusers_local.c 45--- a/src/seusers_local.c
46+++ b/src/seusers_local.c 46+++ b/src/seusers_local.c
47@@ -8,7 +8,11 @@ typedef struct semanage_seuser record_t; 47@@ -8,7 +8,11 @@ typedef struct semanage_seuser record_t;
@@ -56,7 +56,7 @@ index 6508ec0..1b26956 100644
56 #include <errno.h> 56 #include <errno.h>
57 #include "user_internal.h" 57 #include "user_internal.h"
58 #include "seuser_internal.h" 58 #include "seuser_internal.h"
59@@ -55,6 +59,7 @@ static char *semanage_user_roles(semanage_handle_t * handle, const char *sename) 59@@ -56,6 +60,7 @@ static char *semanage_user_roles(semanage_handle_t * handle, const char *sename)
60 return roles; 60 return roles;
61 } 61 }
62 62
@@ -64,7 +64,7 @@ index 6508ec0..1b26956 100644
64 static int semanage_seuser_audit(semanage_handle_t * handle, 64 static int semanage_seuser_audit(semanage_handle_t * handle,
65 const semanage_seuser_t * seuser, 65 const semanage_seuser_t * seuser,
66 const semanage_seuser_t * previous, 66 const semanage_seuser_t * previous,
67@@ -119,6 +124,7 @@ err: 67@@ -120,6 +125,7 @@ err:
68 free(proles); 68 free(proles);
69 return rc; 69 return rc;
70 } 70 }
@@ -72,7 +72,7 @@ index 6508ec0..1b26956 100644
72 72
73 int semanage_seuser_modify_local(semanage_handle_t * handle, 73 int semanage_seuser_modify_local(semanage_handle_t * handle,
74 const semanage_seuser_key_t * key, 74 const semanage_seuser_key_t * key,
75@@ -163,8 +169,11 @@ int semanage_seuser_modify_local(semanage_handle_t * handle, 75@@ -164,8 +170,11 @@ int semanage_seuser_modify_local(semanage_handle_t * handle,
76 (void) semanage_seuser_query(handle, key, &previous); 76 (void) semanage_seuser_query(handle, key, &previous);
77 handle->msg_callback = callback; 77 handle->msg_callback = callback;
78 rc = dbase_modify(handle, dconfig, key, new); 78 rc = dbase_modify(handle, dconfig, key, new);
@@ -84,7 +84,7 @@ index 6508ec0..1b26956 100644
84 err: 84 err:
85 if (previous) 85 if (previous)
86 semanage_seuser_free(previous); 86 semanage_seuser_free(previous);
87@@ -180,8 +189,12 @@ int semanage_seuser_del_local(semanage_handle_t * handle, 87@@ -181,8 +190,12 @@ int semanage_seuser_del_local(semanage_handle_t * handle,
88 dbase_config_t *dconfig = semanage_seuser_dbase_local(handle); 88 dbase_config_t *dconfig = semanage_seuser_dbase_local(handle);
89 rc = dbase_del(handle, dconfig, key); 89 rc = dbase_del(handle, dconfig, key);
90 semanage_seuser_query(handle, key, &seuser); 90 semanage_seuser_query(handle, key, &seuser);
diff --git a/recipes-security/selinux/libsemanage/libsemanage-disable-expand-check-on-policy-load.patch b/recipes-security/selinux/libsemanage/libsemanage-disable-expand-check-on-policy-load.patch
index 6e0faeb..d880e1e 100644
--- a/recipes-security/selinux/libsemanage/libsemanage-disable-expand-check-on-policy-load.patch
+++ b/recipes-security/selinux/libsemanage/libsemanage-disable-expand-check-on-policy-load.patch
@@ -1,4 +1,4 @@
1From dd52bfb66d710473aeb75c5fe92d5cf0a66b637e Mon Sep 17 00:00:00 2001 1From 7af73c1684ce0e30ce0cd58b51708bde1e3a1984 Mon Sep 17 00:00:00 2001
2From: Joe MacDonald <joe@deserted.net> 2From: Joe MacDonald <joe@deserted.net>
3Date: Wed, 7 May 2014 11:36:27 -0400 3Date: Wed, 7 May 2014 11:36:27 -0400
4Subject: [PATCH] libsemanage: disable expand-check on policy load 4Subject: [PATCH] libsemanage: disable expand-check on policy load
diff --git a/recipes-security/selinux/libsemanage_3.5.bb b/recipes-security/selinux/libsemanage_3.6.bb
index 93eb870..93eb870 100644
--- a/recipes-security/selinux/libsemanage_3.5.bb
+++ b/recipes-security/selinux/libsemanage_3.6.bb