summaryrefslogtreecommitdiffstats
path: root/recipes-security/xmlsec1/xmlsec1/change-finding-path-of-nss.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-security/xmlsec1/xmlsec1/change-finding-path-of-nss.patch')
-rw-r--r--recipes-security/xmlsec1/xmlsec1/change-finding-path-of-nss.patch68
1 files changed, 68 insertions, 0 deletions
diff --git a/recipes-security/xmlsec1/xmlsec1/change-finding-path-of-nss.patch b/recipes-security/xmlsec1/xmlsec1/change-finding-path-of-nss.patch
new file mode 100644
index 0000000..0f4cef9
--- /dev/null
+++ b/recipes-security/xmlsec1/xmlsec1/change-finding-path-of-nss.patch
@@ -0,0 +1,68 @@
1From: Yulong Pei <Yulong.pei@windriver.com>
2Date: Wed, 21 Jul 2010 22:33:43 +0800
3Subject: [PATCH] change finding path of nss and nspr
4
5Upstream-Status: Pending
6
7Signed-off-by: Yulong Pei <Yulong.pei@windriver.com>
8Signed-off-by: Mingli Yu <Mingli.Yu@windriver.com>
9---
10 configure.ac | 12 ++++++------
11 1 files changed, 6 insertions(+), 6 deletions(-)
12
13--- a/configure.ac
14+++ b/configure.ac
15@@ -618,7 +618,7 @@
16
17 if test "z$with_nspr" != "z" ; then
18 NSPR_PREFIX="$with_nspr"
19- NSPR_CFLAGS="-I$with_nspr/include -I$with_nspr/include/nspr"
20+ NSPR_CFLAGS="-I$with_nspr/usr/include -I$with_nspr/usr/include/nspr4"
21 if test "z$with_gnu_ld" = "zyes" ; then
22 NSPR_LIBS="-Wl,-rpath-link -Wl,$with_nspr/lib -L$with_nspr/lib $NSPR_LIBS_LIST"
23 else
24@@ -626,7 +626,7 @@
25 fi
26 NSPR_INCLUDES_FOUND="yes"
27 NSPR_LIBS_FOUND="yes"
28- NSPR_PRINIT_H="$with_nspr/include/prinit.h"
29+ NSPR_PRINIT_H="$with_nspr/usr/include/nspr4/prinit.h"
30 else
31 for dir in $ac_nss_inc_dir ; do
32 if test -f $dir/nspr/prinit.h ; then
33@@ -664,7 +664,7 @@
34 OLD_CPPFLAGS=$CPPFLAGS
35 CPPFLAGS="$NSPR_CFLAGS"
36 AC_EGREP_CPP(yes,[
37- #include <prinit.h>
38+ #include <nspr4/prinit.h>
39 #if PR_VMAJOR >= 4
40 yes
41 #endif
42@@ -689,7 +689,7 @@
43 NSS_NSS_H=""
44
45 if test "z$with_nss" != "z" ; then
46- NSS_CFLAGS="$NSS_CFLAGS -I$with_nss/include -I$with_nss/include/nss"
47+ NSS_CFLAGS="$NSS_CFLAGS -I$with_nss/usr/include -I$with_nss/usr/include/nss3 -I$with_nspr/usr/include/nspr4"
48 if test "z$with_gnu_ld" = "zyes" ; then
49 NSS_LIBS="$NSS_LIBS -Wl,-rpath-link -Wl,$with_nss/lib -L$with_nss/lib $NSS_LIBS_LIST"
50 else
51@@ -697,7 +697,7 @@
52 fi
53 NSS_INCLUDES_FOUND="yes"
54 NSS_LIBS_FOUND="yes"
55- NSS_NSS_H="$with_nss/include/nss.h"
56+ NSS_NSS_H="$with_nss/usr/include/nss3/nss.h"
57 else
58 for dir in $ac_nss_inc_dir ; do
59 if test -f $dir/nss/nss.h ; then
60@@ -735,7 +735,7 @@
61 OLD_CPPFLAGS=$CPPFLAGS
62 CPPFLAGS="$NSS_CFLAGS"
63 AC_EGREP_CPP(yes,[
64- #include <nss.h>
65+ #include <nss3/nss.h>
66 #if NSS_VMAJOR >= 3 && NSS_VMINOR >= 2
67 yes
68 #endif