summaryrefslogtreecommitdiffstats
path: root/recipes-security/sssd/sssd_1.16.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-security/sssd/sssd_1.16.0.bb')
-rw-r--r--recipes-security/sssd/sssd_1.16.0.bb71
1 files changed, 71 insertions, 0 deletions
diff --git a/recipes-security/sssd/sssd_1.16.0.bb b/recipes-security/sssd/sssd_1.16.0.bb
new file mode 100644
index 0000000..e41a38e
--- /dev/null
+++ b/recipes-security/sssd/sssd_1.16.0.bb
@@ -0,0 +1,71 @@
1SUMMARY = "system security services daemon"
2DESCRIPTION = "SSSD is a system security services daemon"
3HOMEPAGE = "https://fedorahosted.org/sssd/"
4SECTION = "base"
5LICENSE = "GPLv3+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
7
8DEPENDS = "openldap cyrus-sasl libtdb ding-libs libpam c-ares krb5 autoconf-archive"
9DEPENDS += "libldb dbus libtalloc libpcre glib-2.0 popt e2fsprogs libtevent"
10
11SRC_URI = "https://releases.pagure.org/SSSD/${BPN}/${BP}.tar.gz\
12 file://sssd.conf "
13
14SRC_URI[md5sum] = "f721ace2ebfa6744cfea55e3ecd2d82f"
15SRC_URI[sha256sum] = "c581a6e5365cef87fca419c0c9563cf15eadbb682863d648d85ffcded7a3940f"
16
17inherit autotools pkgconfig gettext update-rc.d python-dir
18
19CACHED_CONFIGUREVARS = "ac_cv_member_struct_ldap_conncb_lc_arg=no \
20 ac_cv_path_NSUPDATE=${bindir} \
21 ac_cv_path_PYTHON2=${PYTHON_DIR} ac_cv_prog_HAVE_PYTHON3=${PYTHON_DIR} \
22 "
23
24PACKAGECONFIG ?="nss nscd"
25PACKAGECONFIG += "${@bb.utils.contains('DISTRO_FEATURES', 'selinux', 'selinux', '', d)}"
26
27PACKAGECONFIG[ssh] = "--with-ssh, --with-ssh=no, "
28PACKAGECONFIG[samba] = "--with-samba, --with-samba=no, samba"
29PACKAGECONFIG[selinux] = "--with-selinux, --with-selinux=no --with-semanage=no, libselinux"
30PACKAGECONFIG[manpages] = "--with-manpages, --with-manpages=no"
31PACKAGECONFIG[python2] = "--with-python2-bindings, --without-python2-bindings"
32PACKAGECONFIG[python3] = "--with-python3-bindings, --without-python3-bindings"
33PACKAGECONFIG[nss] = "--with-crypto=nss, ,nss,"
34PACKAGECONFIG[cyrpto] = "--with-crypto=libcrypto, , libcrypto"
35PACKAGECONFIG[nscd] = "--with-nscd=${sbindir}, --with-nscd=no "
36PACKAGECONFIG[nl] = "--with-libnl, --with-libnl=no, libnl"
37PACKAGECONFIG[systemd] = "--with-systemdunitdir=${systemd_unitdir}/system/, --with-systemdunitdir="
38PACKAGECONFIG[http] = "--with-secrets, --without-secrets, apache2"
39PACKAGECONFIG[curl] = "--with-secrets --with-kcm, --without-secrets --without-kcm, curl"
40
41EXTRA_OECONF += "--disable-cifs-idmap-plugin --without-nfsv4-idmapd-plugin --without-ipa-getkeytab"
42
43do_configure_prepend() {
44 mkdir -p ${AUTOTOOLS_AUXDIR}/build
45 cp ${STAGING_DATADIR_NATIVE}/gettext/config.rpath ${AUTOTOOLS_AUXDIR}/build/
46
47 # libresove has host path, remove it
48 sed -i -e "s#\$sss_extra_libdir##" ${S}/src/external/libresolv.m4
49}
50
51do_install () {
52 oe_runmake install DESTDIR="${D}"
53 rmdir --ignore-fail-on-non-empty "${D}/${bindir}"
54 install -d ${D}/${sysconfdir}/${BPN}
55 install -m 600 ${WORKDIR}/${BPN}.conf ${D}/${sysconfdir}/${BPN}
56}
57
58CONFFILES_${PN} = "${sysconfdir}/${BPN}/${BPN}.conf"
59
60INITSCRIPT_NAME = "sssd"
61INITSCRIPT_PARAMS = "start 02 5 3 2 . stop 20 0 1 6 ."
62SYSTEMD_SERVICE_${PN} = "${BPN}.service"
63SYSTEMD_AUTO_ENABLE = "disable"
64
65FILES_${PN} += "${libdir} ${datadir} /run ${libdir}/*.so* "
66FILES_${PN}-dev = " ${includedir}/* ${libdir}/*la ${libdir}/*/*la"
67
68# The package contains symlinks that trip up insane
69INSANE_SKIP_${PN} = "dev-so"
70
71RDEPENDS_${PN} += "bind dbus"