summaryrefslogtreecommitdiffstats
path: root/recipes-security/smack/smack_1.3.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-security/smack/smack_1.3.1.bb')
-rw-r--r--recipes-security/smack/smack_1.3.1.bb54
1 files changed, 54 insertions, 0 deletions
diff --git a/recipes-security/smack/smack_1.3.1.bb b/recipes-security/smack/smack_1.3.1.bb
new file mode 100644
index 0000000..246562a
--- /dev/null
+++ b/recipes-security/smack/smack_1.3.1.bb
@@ -0,0 +1,54 @@
1DESCRIPTION = "Selection of tools for developers working with Smack"
2HOMEPAGE = "https://github.com/smack-team/smack"
3SECTION = "Security/Access Control"
4LICENSE = "LGPL-2.1"
5
6LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
7
8SRCREV = "4a102c7584b39ce693995ffb65e0918a9df98dd8"
9SRC_URI = " \
10 git://github.com/smack-team/smack.git \
11 file://smack_generator_make_fixup.patch \
12 file://run-ptest"
13
14PV = "1.3.1"
15
16inherit autotools update-rc.d pkgconfig ptest ${@bb.utils.contains('VIRTUAL-RUNTIME_init_manager','systemd','systemd','', d)}
17
18S = "${WORKDIR}/git"
19
20PACKAGECONFIG ??= ""
21PACKAGECONFIG_append = " ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}"
22
23PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_system_unitdir}, --without-systemdsystemunitdir, systemd"
24
25do_compile_append () {
26 oe_runmake -C ${S}/tests generator
27}
28
29do_install_append () {
30 install -d ${D}${sysconfdir}/init.d
31 install -d ${D}${sysconfdir}/smack
32 install -d ${D}${sysconfdir}/smack/accesses.d
33 install -d ${D}${sysconfdir}/smack/cipso.d
34 install ${S}/init/smack.rc ${D}/${sysconfdir}/init.d/smack
35}
36
37do_install_ptest () {
38 install -d ${D}${PTEST_PATH}/tests
39 install ${S}/tests/generator ${D}/${PTEST_PATH}/tests
40 install ${S}/tests/generate-rules.sh ${D}${PTEST_PATH}/tests
41 install ${S}/tests/make_policies.bash ${D}${PTEST_PATH}/tests
42}
43
44INITSCRIPT_PACKAGES = "${PN}"
45INITSCRIPT_NAME = "smack"
46INITSCRIPT_PARAMS = "start 16 2 3 4 5 . stop 35 0 1 6 ."
47
48FILES_${PN} += "${sysconfdir}/init.d/smack"
49FILES_${PN}-ptest += "generator"
50
51RDEPENDS_${PN} += "coreutils"
52RDEPENDS_${PN}-ptest += "make bash bc"
53
54BBCLASSEXTEND = "native"