summaryrefslogtreecommitdiffstats
path: root/recipes-security/libseccomp/libseccomp_2.3.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-security/libseccomp/libseccomp_2.3.3.bb')
-rw-r--r--recipes-security/libseccomp/libseccomp_2.3.3.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/recipes-security/libseccomp/libseccomp_2.3.3.bb b/recipes-security/libseccomp/libseccomp_2.3.3.bb
new file mode 100644
index 0000000..8d58163
--- /dev/null
+++ b/recipes-security/libseccomp/libseccomp_2.3.3.bb
@@ -0,0 +1,42 @@
1SUMMARY = "interface to seccomp filtering mechanism"
2DESCRIPTION = "The libseccomp library provides and easy to use, platform independent,interface to the Linux Kernel's syscall filtering mechanism: seccomp."
3SECTION = "security"
4LICENSE = "LGPL-2.1"
5LIC_FILES_CHKSUM = "file://LICENSE;beginline=0;endline=1;md5=8eac08d22113880357ceb8e7c37f989f"
6
7SRCREV = "74b190e1aa05f07da0c61fb9a30dbc9c18ce2c9d"
8
9SRC_URI = "git://github.com/seccomp/libseccomp.git;branch=release-2.3 \
10 file://run-ptest \
11"
12
13S = "${WORKDIR}/git"
14
15inherit autotools-brokensep pkgconfig ptest
16
17PACKAGECONFIG ??= ""
18PACKAGECONFIG[python] = "--enable-python, --disable-python, python"
19
20do_compile_ptest() {
21 oe_runmake -C tests check-build
22}
23
24do_install_ptest() {
25 install -d ${D}${PTEST_PATH}/tests
26 install -d ${D}${PTEST_PATH}/tools
27 for file in $(find tests/* -executable -type f); do
28 install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tests
29 done
30 for file in $(find tests/*.tests -type f); do
31 install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tests
32 done
33 for file in $(find tools/* -executable -type f); do
34 install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tools
35 done
36}
37
38FILES_${PN} = "${bindir} ${libdir}/${PN}.so*"
39FILES_${PN}-dbg += "${libdir}/${PN}/tests/.debug/* ${libdir}/${PN}/tools/.debug"
40
41RDEPENDS_${PN} = "bash"
42RDEPENDS_${PN}-ptest = "bash"